LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-01-2008, 04:11 AM   #1
simple99
LQ Newbie
 
Registered: Feb 2008
Posts: 4

Rep: Reputation: 0
Question Lvm corrupted after rebooting in united linux.


I connected disk array to perc4 controller and created one logical drive by controller configuration utility.

After that created volume group and logical volume by yast2 ( united linux ) in logical drive.

After rebooting my lvm is corrupted giving below error messages

fsck ext3 : no such device or address while typing to open /dev/vol1/test

possibley non-existent or swap device.


pls give me solutions for this problem.
 
Old 02-01-2008, 07:49 PM   #2
cjcox
Member
 
Registered: Jun 2004
Posts: 307

Rep: Reputation: 42
Boot into rescue mode and use logical volume commands to inspect what is there. Then you can try to mount them to temporary mount points and see if that succeeds.

It's possible that your SCSI drives are being recognized in a different order than before (thus /dev/sda is /dev/sdb, or something like that). In general that's not a problem with regards to LVM, but I'm just taking a wild guess.
 
Old 02-04-2008, 11:48 AM   #3
simple99
LQ Newbie
 
Registered: Feb 2008
Posts: 4

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by cjcox View Post
Boot into rescue mode and use logical volume commands to inspect what is there. Then you can try to mount them to temporary mount points and see if that succeeds.

It's possible that your SCSI drives are being recognized in a different order than before (thus /dev/sda is /dev/sdb, or something like that). In general that's not a problem with regards to LVM, but I'm just taking a wild guess.

I tried this , but not successed.
 
Old 02-04-2008, 12:09 PM   #4
cjcox
Member
 
Registered: Jun 2004
Posts: 307

Rep: Reputation: 42
Can you provide any more detail of what commands you tried and their output?

For example:

lsscsi
pvscan
vgscan
lvscan
etc..
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
RAID1+LVM: data keeps getting corrupted Chojin Linux - Software 4 10-22-2006 10:55 AM
United Linux astablemaverick Linux - Distributions 1 11-09-2002 02:05 AM
United Linux Beta rivang Linux - General 1 08-14-2002 03:29 PM
United Linux ph34r3d Slackware 4 08-07-2002 06:14 AM
United Linux? Will it sucdeed? nixdisciple Linux - General 6 06-20-2002 04:52 AM


All times are GMT -5. The time now is 05:51 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration