LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-22-2006, 02:40 PM   #1
_abbenormal
LQ Newbie
 
Registered: Sep 2005
Posts: 2

Rep: Reputation: 0
lspci command not found


ok ive got deian setup on my system basic net install
running fine so far. ive setup xfce4 desktop working out some minor bugs couldnt get xterminal to load as it is missing dep. so installed terminal to use and now for some reason i try to do lspci and get this..

mybox://# lspci
bash: lspci: command not found

have i missed something in my setup or is it maybe a config problem with this terminal any ideas would help
if not ill live with it until i reload
 
Old 02-22-2006, 02:49 PM   #2
victorh
Member
 
Registered: Jul 2005
Location: La Paz, Bolivia
Distribution: Debian Sarge - Sid, Slackware, Gentoo, openSuse, Fedora, Ubuntu, Mandriva
Posts: 241

Rep: Reputation: 30
You have to be root to run the command lspci.

Change to root using su:

Quote:
su
Password: (type your root password)
# lspci
 
Old 02-22-2006, 03:01 PM   #3
_abbenormal
LQ Newbie
 
Registered: Sep 2005
Posts: 2

Original Poster
Rep: Reputation: 0
sorry guys found my problem

in debian you have to add the pciutils thought it was part of the basic setup and it is not..

to fix it do

sudo apt-get install pciutils

and on mine i dont need to be root to run lspci

sorry for the dumb post but learned something new....
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
lspci command not working lowebb Linux - General 1 10-24-2005 02:22 PM
Interpreting the output of 'lspci' command. drminix Linux - Hardware 2 06-14-2005 04:20 AM
sound card not found but get with lspci bpman Linux - Hardware 1 03-22-2005 12:23 AM
lspci command not working in FC3 pookguy88 Linux - Newbie 9 01-19-2005 03:52 AM
lspci.. lspci -H.. difference on different meachines? rohan208 Linux - Wireless Networking 0 06-28-2004 12:19 PM


All times are GMT -5. The time now is 05:38 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration