LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices



Reply
 
Search this Thread
Old 03-07-2013, 09:03 AM   #1
yashfire007
Member
 
Registered: Jan 2013
Distribution: CentOS, RHEL 6.4
Posts: 79

Rep: Reputation: Disabled
Question lsmod command not working


Dear all,

When i trying to user #lsmod /proc/modules it is showing as below
#lsmod /proc/modules
Usage: lsmod


Please suggest me what have to be done.
 
Old 03-07-2013, 09:05 AM   #2
druuna
LQ Veteran
 
Registered: Sep 2003
Posts: 10,532
Blog Entries: 7

Rep: Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374
You are mixing up two different things.

It is lsmod or cat /proc/modules
 
Old 03-07-2013, 09:07 AM   #3
camorri
Senior Member
 
Registered: Nov 2002
Location: Somewhere inside 9.9 million sq. km. Canada
Distribution: Slackware 14.1
Posts: 4,869

Rep: Reputation: 434Reputation: 434Reputation: 434Reputation: 434Reputation: 434
Just type 'lsmod' without the quotes. The program knows to format the contents of /proc/modules ; you don't need to specify that.
 
Old 03-07-2013, 10:04 AM   #4
yashfire007
Member
 
Registered: Jan 2013
Distribution: CentOS, RHEL 6.4
Posts: 79

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by camorri View Post
Just type 'lsmod' without the quotes. The program knows to format the contents of /proc/modules ; you don't need to specify that.

No i am just typed as lsmod /proc/modules
 
Old 03-07-2013, 10:11 AM   #5
camorri
Senior Member
 
Registered: Nov 2002
Location: Somewhere inside 9.9 million sq. km. Canada
Distribution: Slackware 14.1
Posts: 4,869

Rep: Reputation: 434Reputation: 434Reputation: 434Reputation: 434Reputation: 434
Quote:
No i am just typed as lsmod /proc/modules
Please explain what you are trying to do. I don't understand your comment.
 
Old 03-07-2013, 10:22 AM   #6
yashfire007
Member
 
Registered: Jan 2013
Distribution: CentOS, RHEL 6.4
Posts: 79

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by camorri View Post
Please explain what you are trying to do. I don't understand your comment.


i want to read the file /proc/modules.
I used cat /proc/modules, but it is little hard to understand the contents.
So i used to read by the command lsmod /proc/modules which displays in an understandable mode..
 
Old 03-07-2013, 10:37 AM   #7
druuna
LQ Veteran
 
Registered: Sep 2003
Posts: 10,532
Blog Entries: 7

Rep: Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374
Quote:
Originally Posted by yashfire007 View Post
i want to read the file /proc/modules.
I used cat /proc/modules, but it is little hard to understand the contents.
So i used to read by the command lsmod /proc/modules which displays in an understandable mode..
You cannot use lsmod to show the content of /proc/modules. It (lsmod) already looks at /proc/modules, no need to specify the file.

I.e. (as shown above): lsmod (nothing more, nothing less).
 
1 members found this post helpful.
Old 03-07-2013, 10:46 AM   #8
yashfire007
Member
 
Registered: Jan 2013
Distribution: CentOS, RHEL 6.4
Posts: 79

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by druuna View Post
You cannot use lsmod to show the content of /proc/modules. It (lsmod) already looks at /proc/modules, no need to specify the file.

I.e. (as shown above): lsmod (nothing more, nothing less).
Thank you for your reply..
Now i got clarified..
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Synaptic package not working from xcfe yet working from the command line onerous Debian 8 11-15-2012 04:40 PM
Command "lsmod" Doesn't Work In Fedora rrrssssss Fedora 4 03-11-2007 10:24 AM
lsmod is not working in linux in my system shrikantpwr245 Programming 1 04-17-2006 04:41 AM
How to block lsmod and su so user can't use those command Ninja_212 Slackware 4 04-18-2004 01:13 AM
lsmod command manojrkrish Linux - Newbie 5 06-20-2002 05:45 PM


All times are GMT -5. The time now is 02:45 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration