LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 09-12-2008, 05:37 PM   #1
ubuntuorrin
LQ Newbie
 
Registered: Sep 2008
Posts: 11

Rep: Reputation: 0
Love Linux, just need some translation


Hi, I'm fairly new to Linux but definitely love the os and the community. The only problem i have had is with my wireless usb card. I found a page with a solution but what they are telling me to do doesnt make sense to me, just wondering if someone could take some time to help me out. here is the site
http://www.jooz.net/rndis/

Linksys WUSB54GS (v2.1) (Linksys Wireless-G USB Adapter w/speed booster). I have spent a few days trying to install it myself and research other forums but finally have just given in to posting like a nub (i know its embarrassing) .


thanks for your time, i cant wait to get some updates and get more familiar with the environment

Last edited by ubuntuorrin; 09-12-2008 at 05:45 PM. Reason: updated the card info
 
Old 09-12-2008, 05:44 PM   #2
pinniped
Senior Member
 
Registered: May 2008
Location: planet earth
Distribution: Debian
Posts: 1,732

Rep: Reputation: 50
It might be better if you tell us what device you have; there may be other (better) ways to get it working.

If you have installed "usbutils" you can use 'lsusb' to get the product information (you must run it as 'root') for example:

lsusb
Bus 002 Device 004: ID 12d1:1003 Huawei Technologies Co., Ltd. E220 HSDPA Modem
Bus 002 Device 002: ID 046d:0a01 Logitech, Inc. Logitech USB Headset
 
Old 09-12-2008, 06:18 PM   #3
ubuntuorrin
LQ Newbie
 
Registered: Sep 2008
Posts: 11

Original Poster
Rep: Reputation: 0
k pinn I put the hardware info there.. i have searched through a lot of forums and i think i found my solution, i really just need a translation of that webpage, not sure exactly what they are asking me to do but it seems like people have had good success using their solution
 
Old 09-12-2008, 06:46 PM   #4
pinniped
Senior Member
 
Registered: May 2008
Location: planet earth
Distribution: Debian
Posts: 1,732

Rep: Reputation: 50
First you have to download that .tar.gz package; put it in some directory.
Then unpack the package: tar zxvf rndis_wlan-snapshot-20080509.tar.gz

Then install the 'kernel headers' for your Linux distribution - so what type of Linux did you install? For Debian-based distributions you can do this via:

apt-get install linux-headers-$(uname -r)

For the "back up" part, create a directory 'bak' in your home directory:
mkdir ~/bak
Then find the files mentioned:
cd /lib/modules/$(uname -r)
find . -name usbnet.ko
find . -name cdc_ether.ko
find . -name rndis_host.ko
and move them to the 'bak' directory using the 'mv' command as 'root' - for example:
sudo mv /lib/modules/2.6.21-2-amd64/kernel/drivers/usb/net/cdc_ether.ko ~/bak
You should make notes about where these files were taken from so you can put them back where they belong if you decide to revert your changes.

Next, change back to the directory you unpacked the .tar.gz file to, and:
sudo ./clean.sh

Then:
make
sudo make install

The 'udev' entry is a bit more complicated - that can be lesson #2 - get up to the 'install' part first.
 
Old 09-12-2008, 07:23 PM   #5
ubuntuorrin
LQ Newbie
 
Registered: Sep 2008
Posts: 11

Original Poster
Rep: Reputation: 0
so far so good

so far so good, thanks so much for your help everything seems to be moved and installed so far (i'm on ubuntu hardy btw)
 
Old 09-12-2008, 07:28 PM   #6
wildar
Member
 
Registered: Jan 2007
Distribution: Mandriva 2008, Mandrake 2005, Ubuntu 8.04.1
Posts: 239

Rep: Reputation: 30
Opps, began writing this before you posted at 7:23pm.

Hi ubuntuorrin,
It helps if you specify the Linux distro and version you're dealing with when posting questions. I would guess your using Ubuntu, considering your username.
With that in mind, I did a search and found this post on Ubuntu forums. It's couple of years old, but the concepts should still apply, http://ubuntuforums.org/showthread.php?t=225206

Not sure what you need translated, could you be more specific?

As far as your need to get your Linksys WUSB54GS (v2.1) working, you'll need to get familar with NDISwrappers. Basically, NDISwrapper is a project to help Linux systems use Windows drivers in order to get wireless devices to work (as most vendors do not directly develope non Windows drivers).

I was able to find a post on Ubuntu forums that looks like a nice how-to for getting your device working. The post is couple of years old, but hopefully it'll help, http://ubuntuforums.org/showthread.php?t=225206. It's got pictures and everything.

Again, I can only assume you're using Ubuntu, if not let us know.

Last edited by wildar; 09-12-2008 at 07:30 PM.
 
Old 09-12-2008, 07:33 PM   #7
ubuntuorrin
LQ Newbie
 
Registered: Sep 2008
Posts: 11

Original Poster
Rep: Reputation: 0
thanks

thanks wildar, yeah i tried that solution from that post and it didnt work, pinn is helping me out atm so i'm just waiting on them to write up part #2 (thanks so much btw pinn) . also yeah thanks for pointing out the information thing, i think i will just put a signature up or something with the system i am running and such, i love the comm members soo much, i often encounter "elitists" when dealing with things of this nature but so far everyone seems happy to help !

also pinn can you tell me if i need to enable or disable the regular cable network card when i go to plug in the wireless one or if i can have them both plugged in ?!?!?

Last edited by ubuntuorrin; 09-12-2008 at 08:36 PM. Reason: pinniped
 
Old 09-13-2008, 01:02 AM   #8
pinniped
Senior Member
 
Registered: May 2008
Location: planet earth
Distribution: Debian
Posts: 1,732

Rep: Reputation: 50
Quote:
Originally Posted by ubuntuorrin View Post
also pinn can you tell me if i need to enable or disable the regular cable network card when i go to plug in the wireless one or if i can have them both plugged in ?!?!?
Once you have wireless set up, it is best if you remove the wired connection or you can get strange things happening with the routing. All you'd have to do is:
ifdown eth0
Then go to /etc/networking/interfaces and comment out the 'auto eth0' line.

Anyway, back to the installation, the next instruction is to create a udev rule to help set up your device - on the web site they have:

BUS=="usb", SYSFS{idProduct}=="011b", SYSFS{idVendor}=="0baf", RUN+="/bin/sh -c 'echo 1 > /sys/%p/device/bConfigurationValue'

That is actually incorrect because there is no 'SYSFS' or 'BUS' parameter in a contemporary udev; instead it should be something like:

SUBSYSTEM=="usb", ATTR{idVendor}=="xxxx", ATTR{idProduct}="xxxx", RUN+="/bin/sh -c 'echo 1 > /sys/%p/device/bConfigurationValue'

So where do you get that idVendor and idProduct? If I use lsusb to look at my audio headset:

Bus 002 Device 002: ID 046d:0a01 Logitech, Inc. Logitech USB Headset

The two hexadecimal numbers after 'ID" are the VendorID:ProductID pair (in that order).

So where do you put this? If Ubuntu didn't play around too much with the default Debian outlay of udev:

1. go to the udev configuration directory: cd /etc/udev
2. create a file with your rule: touch wusb54gs
Then of course edit that file to add the rule above to it with the correct values for ATTR{idVendor} and ATTR{idProduct}.
3. go to the udev rules directory and add a symbolic link to your new rule set:
cd rules.d
ln -s ../wusb54gs 001_wusb54gs.rules
4. force udev to reload its rules: /etc/init.d/udev force-reload
5. unplug the USB gizmo, wait 10s, plug it in, wait a few seconds again, and see if you've now got a wireless interface: iwconfig

If iwconfig shows that you have a wireless interface then all you need to do is configure the wireless connection. To do that, we need to know how your wireless access is set up - do you have an 'access point' (wireless router) and what wireless protection scheme do you use (WPA-PSK is common for home use).
 
Old 09-13-2008, 09:50 AM   #9
ubuntuorrin
LQ Newbie
 
Registered: Sep 2008
Posts: 11

Original Poster
Rep: Reputation: 0
thanks pinn :)

Hi pinn, so far so good i think, the iwconfig read :
wlan0 IEEE802.11bg ESSIDff/any

Mode:Managed Frequency:2.412 GHz Bit Rate:54 Mb/s Tx-Power=14 dBm

RTS thr=2347 B Fragment thr=2346 B

Link Quality:0 Signal level:0 Noise level:0

Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0

Tx excessive retries:0 Invalid misc:0 Missed beacon:0


"do you have an 'access point' (wireless router) and what wireless protection scheme do you use (WPA-PSK is common for home use)"

Linksys WRT54G Router and probably just have a default WPA-PSK access point (i live out in the sticks so dont have anyone living with in miles of my house so didnt feel a need for password protect)

so i guess i'm ready for step #3

thanks again

p.s. not sure what is up with those smiley faces but i didnt put them in there is there a away to deactivate

Last edited by ubuntuorrin; 09-13-2008 at 10:01 AM. Reason: not sure what is up with those smiley faces but i didnt put them in there
 
Old 09-13-2008, 06:51 PM   #10
pinniped
Senior Member
 
Registered: May 2008
Location: planet earth
Distribution: Debian
Posts: 1,732

Rep: Reputation: 50
If you have no encryption then you can try to set up your network like this:

1. ifdown eth0 (bring down the wired connection so you don't mess up routing)
2. ifconfig wlan0 up 0.0.0.0 (bring up the wireless interface but don't configure it)
3. iwconfig wlan0 essid "Your ESSID" mode managed key off (set up the radio)
4. dhclient wlan0 (attempt to get an IP from your router)

If you need to specify a frequency/channel to use, just add 'channel ?' to your iwconfig line, where ? is the channel to use. To see what your router is currently doing:

iwlist wlan0 scan

If all that works, then you can add these lines to your /etc/network/interfaces file:

allow-hotplug wlan0
iface wlan0 inet dhcp
wireless-essid "your essid"
wireless-mode managed
wireless-keymode open

You can check if the interface now comes up automatically:
1. ifdown wlan0
2. unplug the radio, wait 10 seconds
3. plug in the radio

To avoid a long annoying wait for DHCP discovery during boot (when you don't have the wired ethernet plugged in), install "ifplugd" and change the 'auto eth0' line in the interfaces file to 'allow-hotplug eth0'.
 
Old 09-13-2008, 08:03 PM   #11
ubuntuorrin
LQ Newbie
 
Registered: Sep 2008
Posts: 11

Original Poster
Rep: Reputation: 0
thanks so much

thanks again pini for all your help, internet works great

..I followed your instructions:
To avoid a long annoying wait for DHCP discovery during boot (when you don't have the wired ethernet plugged in), install "ifplugd" and change the 'auto eth0' line in the interfaces file to 'allow-hotplug eth0'.

When I restart my computer it doesnt seem to pick up the internet, i waited like 10 minutes, and the light on the adapter is green so i know its recognizing it, its just not getting through to the router. so i
2. ifconfig wlan0 up 0.0.0.0
3. iwconfig wlan0 essid "Your ESSID" mode managed key off
4. dhclient wlan0 (attempt to get an IP from your router)
5. iwlist wlan0 scan

again and it seems to bring it back up, do you have any suggestions on how to short cut the process of getting hooked up when i reboot (i dont mind just typing a few things into the terminal or even if there was a script i could make and lauch).
thanks again!
 
Old 09-13-2008, 08:53 PM   #12
pinniped
Senior Member
 
Registered: May 2008
Location: planet earth
Distribution: Debian
Posts: 1,732

Rep: Reputation: 50
You can add an 'auto wlan0' line to the interfaces file; everything will work then provided the drivers have loaded and you're in range.

The "wpasupplicant" package can also be abused for the job (it works better if the wireless network isn't available 100% of the time); you will need to install wpasupplicant, then go into its configuration directory /etc/wpa_supplicant

Then you need to create a file 'wpa_supplicant.conf' with an entry like this:

network={
id_str="home"
ssid="your essid"
key_mgmt=NONE
}

The interfaces file will need an entry like this (so you can comment out the older wlan0 entries if you made them):

allow-hotplug wlan0
iface wlan0 inet manual
wpa-driver wext
wpa-roam /etc/wpa_supplicant/wpa_supplicant.conf

iface home inet dhcp
iface default inet dhcp

You may need to put in an "auto wlan0" line if things don't run at startup.
After setting up the configuration, doing an 'ifup wlan0' should get everything working. You shouldn't have to do that the next time you reboot though - if you do have to do it, then add that 'auto wlan0' line to the interfaces file.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Translation software for Linux? xpucto Linux - Software 3 06-07-2006 11:24 AM
Need English translation of Spanish Linux instructions SteveH Linux - General 5 08-27-2004 07:54 AM
Is there: Language Translation Program in Linux? DaFrEQ Linux - Software 3 12-03-2003 04:09 PM
I love linux, I love it ! SuseBoy General 5 07-18-2003 12:51 AM


All times are GMT -5. The time now is 12:37 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration