LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-27-2003, 03:10 PM   #1
scottie
Member
 
Registered: Oct 2003
Location: UK
Distribution: Slackware 8.0
Posts: 56

Rep: Reputation: 15
Unhappy Lost internet using netconfig


my internet was working fine the other day in linux, but then i was trying to set up my local network. all i did was type netconfig in the terminal window answered what my hostname and domain was and the internet stopped working! I cancelled the terminal window but it made no difference, all i get now is an error message saying it cannot find the server everytime i try to go online

how can i get my internet working again? i dont really know where to begin

scottie
 
Old 10-27-2003, 03:17 PM   #2
Joey.Dale
Member
 
Registered: Jun 2003
Location: Tampa, Fl
Distribution: Gentoo, Slackware
Posts: 828

Rep: Reputation: 30
what kind of internet dial up, cable, dsl? router?
 
Old 10-27-2003, 04:14 PM   #3
scottie
Member
 
Registered: Oct 2003
Location: UK
Distribution: Slackware 8.0
Posts: 56

Original Poster
Rep: Reputation: 15
i'm on a local network of 4 of us and use a router..
 
Old 10-27-2003, 05:14 PM   #4
Joey.Dale
Member
 
Registered: Jun 2003
Location: Tampa, Fl
Distribution: Gentoo, Slackware
Posts: 828

Rep: Reputation: 30
check your dns settings and your gateway
 
Old 10-27-2003, 06:24 PM   #5
scottie
Member
 
Registered: Oct 2003
Location: UK
Distribution: Slackware 8.0
Posts: 56

Original Poster
Rep: Reputation: 15
sorry to sound proper newbie, but where do i check the dns settings and my gateway? and what am i checking for?
 
Old 10-27-2003, 07:28 PM   #6
scottie
Member
 
Registered: Oct 2003
Location: UK
Distribution: Slackware 8.0
Posts: 56

Original Poster
Rep: Reputation: 15
i dunno if this helps but this is error i get when i try to go to google, 1st it says:

Cannot connect to host

www.google.com

then it says:

Warning the following hosts are unknown:
scottiedog
home.netscape.com
home6.netscape.com
internic.net
This means that some or all hosts will be unreachable.

Perhaps there is a problem with your name server? If your site must use a non-root name server, you will need to set the $SOCKS_NS environment variable to point to the appropiate name server. It may (or may not) be necessary to set this variable, or the SOCKS host preference, to the IP address of the host in question rather than its name.

Consult your system administrator

I'm begining to wish i hadnt played around with netconfig

scottie
 
Old 10-27-2003, 08:41 PM   #7
Joey.Dale
Member
 
Registered: Jun 2003
Location: Tampa, Fl
Distribution: Gentoo, Slackware
Posts: 828

Rep: Reputation: 30
you want to check that your gateway is set to your router
if not set as such and type service network restart
if this seting is already set then make sure your dsn is set to the dsn of your router

Sorry but I will have to find out how to do it and will post back tomorrow, got to go to bed. Try ifconfig (to check it)
 
Old 10-28-2003, 02:51 AM   #8
twantrd
Senior Member
 
Registered: Nov 2002
Location: CA
Distribution: redhat 7.3
Posts: 1,440

Rep: Reputation: 52
Hi Scottie,

Does ifconfig post your eth0 interface? Does your eth0 look correct? Have you tried pinging 216.239.57.99 (google's ip address)? If you can ping that IP, it means that your linux box is connected to the internet but it can't resolve domain names because it's not connecting to your DNS server(s). Add your DNS server IP's into /etc/resolve.conf. That should do the trick, if not, post back.

-twantrd
 
Old 10-28-2003, 07:25 AM   #9
scottie
Member
 
Registered: Oct 2003
Location: UK
Distribution: Slackware 8.0
Posts: 56

Original Poster
Rep: Reputation: 15
OK, i tried to ping google and it says.....

sendto: Network is unreachable
ping: sent 64 octets to 216.239.57.99 ret1

Also i tried ifconfig eth0 and i get.....

eth0 Link encap:Ethernet HWaddr 00:90:47:03:BAS
BROADCAST MULTICAST MTV:1500 Metric 1
RX packets:0 errors:0 dropped:0 overuns:0 frame:0
TX packets:0 errors:0 dropped:0 overuns:0 carrier:0
collisions:0 txqueuelen:100
RX bytes:0 (0.0 b) TX bytes (0.0 b)
Interrupt: 5 Base address: 0xd800

I looked in my resolv.conf and it just says.....

search desert

i think desert is what i called my domain in netconfig but i reckon i might need an extra line of text or something. I've checked my hosts in etc aswell and its ses.....

#for loopbacking
127.0.0.1 localhost
127.0.0.1 scottiedog.desert scottiedog

it says something like you shouldnt have your machines ip as 127.0.0.1 in the comments, but i dont know if that matters.

scottie
 
Old 10-28-2003, 08:10 AM   #10
repe
Member
 
Registered: Aug 2003
Location: Finland
Distribution: Slackware 9.0 & 9.1. FreeBSD 4.8 & 5.1
Posts: 30

Rep: Reputation: 15
Run netconfig again and use DHCP when it asks for it.
 
Old 10-28-2003, 08:38 AM   #11
scottie
Member
 
Registered: Oct 2003
Location: UK
Distribution: Slackware 8.0
Posts: 56

Original Poster
Rep: Reputation: 15
I've tried that but it doesnt even ask me if i want to use DHCP, it asks me for....

hostname (which is set at scottiedog)
then domain name (set at desert)
then the IP address of scottiedog.desert (set at 127.0.0.1)
then the netmask of local network (set at 255.255.255.0)
then the gateway address (unsure what i should answer)
and then i get confused!

I dont even think i use a gateway! Also i'm not too sure which answers i should be giving netconfig, I've tried to keep most the answers at default by just pressing enter but it doesnt seem to help anything

scottie
 
Old 10-28-2003, 12:42 PM   #12
twantrd
Senior Member
 
Registered: Nov 2002
Location: CA
Distribution: redhat 7.3
Posts: 1,440

Rep: Reputation: 52
Hi Scottie,

Ok your eth0 card is recognized BUT it is not picking up an IP address. Do you have dhcp enabled on your router (it looks like it's not). Anyhow, run "netconfig" and pick a static ip (192.168.1.100 or whatever), subnet mask is 255.255.255.0, and from looking at your router configuration put in those same exact nameservers (DNS ip's). Once you are done, look in your /etc/resolve.conf and see if nameserver entries are listed. If not (and probably not) type this in:

nameserver <your primary DNS server>
nameserver <your alternative DNS server>

So, to clarify this is what my /etc/resolve.conf looks like:

search localdomain

nameserver 29.81.168.1
nameserver 29.81.168.3

Try those steps and u should be able to connect to the internet. If not, post back. Good luck

-twantrd
 
Old 10-28-2003, 08:50 PM   #13
scottie
Member
 
Registered: Oct 2003
Location: UK
Distribution: Slackware 8.0
Posts: 56

Original Poster
Rep: Reputation: 15
WOOHOO

i got it to work, thanks for your help guys

i stumbled upon a file in /etc/rc.d/rc.inet1 and checked it out with a txt editor theres a line in thats says...

#To use DHCP instead of static IP, set this value to yes
DHCP="no" #Use DHCP "yes" or "no"

I changed it to yes then saved the file, rebooted and bingo!

Scottie
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Lost internet :/ Foxtrick Linux - Newbie 6 12-10-2005 07:25 AM
Lost internet connection RonCum Linux - Networking 4 04-30-2005 08:53 PM
Lost access to internet KunoNoOni Linux - Networking 2 04-25-2005 10:02 AM
Lost internet connectivity wremote SUSE / openSUSE 3 03-19-2005 11:03 AM
Internet stopped working after running netconfig on 2.6.0 GT_Onizuka Slackware 6 01-03-2004 04:47 PM


All times are GMT -5. The time now is 02:31 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration