LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 04-26-2005, 04:22 AM   #1
khader69
LQ Newbie
 
Registered: Apr 2005
Posts: 2

Rep: Reputation: 0
Exclamation Lost /boot contents. Oops!


Hi guys,

I need some help. I had Redhat 9 installed in my box. I had a spare partition in which I wanted to install RHEL.

I shud have specified during RHEL install to not install Grub or any boot related stuff. But I did not.!!!

Now I am able to boot into RHEL but not RH9. All the contents of RH9 are intact but since the boot partition was over-written i lost the initrd images, kernel and the likes of RH9.

Any chance of me recovering form the current scenario and work on RH9 again???

Plz help.

Khader69
 
Old 04-26-2005, 04:28 AM   #2
MasterC
LQ Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 68
Sure, you just need a bootable kernel. From there it's all gravy.

Edit your boot loader to have your root device be your RH9 partition, and that should be it.

Cool
 
Old 04-26-2005, 05:06 AM   #3
khader69
LQ Newbie
 
Registered: Apr 2005
Posts: 2

Original Poster
Rep: Reputation: 0
Thanks MasterC.

I had tried that initially, but when it did not work I posted the message in the forum. Now that u 2 suggested so, I rechecked my steps and found my error in the
root (hdx,x)
line.


Khader69
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
contents of /home lost! skvasistha Linux - Software 2 11-23-2004 05:31 AM
OOps, lost winmanager installing nvidia drivers BajaNick Linux - Software 2 06-17-2004 03:57 AM
Lost a startup script... OoPs Hooper Slackware 11 06-13-2004 09:33 PM
Oops - I lost my system tray !! smevans Red Hat 5 11-05-2003 07:06 AM
Lost my instructions for wireless connect...oops! jpohara Linux - Newbie 4 04-24-2002 09:49 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 05:06 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration