LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 09-10-2003, 12:59 AM   #1
dwaynehoover
LQ Newbie
 
Registered: Sep 2003
Distribution: Mandrake 9.1
Posts: 3

Rep: Reputation: 0
lost access to win2k thru lilo &/or grub


I've searched for a couple of days now and can't find an answer that works for this, so sorry if it's been posted in here somewhere already.

When I fist set up Mandrake 9.1 (dual boot win2k), it would boot by default to linux thru my hd or floppy, after (unfortunately) screwing with it, to default to windows (so my g/f could use the computer), I've lost access to windows. In fact I can only get to linux thru floppy. I've tried running my recovery disk, and i get a message that it can't be done?! Do I have to wipe it all and start again?
thanx in advance - I'm totally new to linux btw, and with the exception of my bootloader issues I think it's great.
 
Old 09-10-2003, 01:11 AM   #2
Skyline
Senior Member
 
Registered: Jun 2003
Distribution: Debian/other
Posts: 2,104

Rep: Reputation: 45
Quote:
1've lost access to windows. In fact I can only get to linux thru floppy
Use this floppy to boot into Mandrake - if youre using LILO as your bootloader then

open a shell

su
root password

/sbin/lilo

to reinstall lilo

then try rebooting to see if you can get into Mandrake via the harddrive (I'm assuming youve got LILO installed on the MBR - ie boot=/dev/hda ?)

If you still cant boot to Mandrake the normal way via your harddrive - then boot from your floppy again and post your Lilo.conf file

open a shell

su
root password

cat /etc/lilo.conf

copy the results and post them here.
 
Old 09-10-2003, 01:59 AM   #3
dwaynehoover
LQ Newbie
 
Registered: Sep 2003
Distribution: Mandrake 9.1
Posts: 3

Original Poster
Rep: Reputation: 0
Thanksfor your quick response, but this is what I got when I tried /sbin/lilo
"Device 0x0301: Partition type 0x17 does not seem suitable for a LILO boot sector"
Weird thing is when I use Drak to configure Lilo, it keeps saying that I'm using Grub even after I change it to lilo...
 
Old 09-10-2003, 06:11 AM   #4
crashmeister
Senior Member
 
Registered: Feb 2002
Distribution: t2 - trying to anyway
Posts: 2,541

Rep: Reputation: 47
About the windows part:
I had the problem that a installer removed the boot tag from the win partition once.
 
Old 09-16-2003, 02:44 PM   #5
dwaynehoover
LQ Newbie
 
Registered: Sep 2003
Distribution: Mandrake 9.1
Posts: 3

Original Poster
Rep: Reputation: 0
thanx for the help - I ended up wipeing everything (windows and linux) fortunately i had a recent back-up... I'm gonna re-install Linux on my other computer as soon as I get it back. Can't risk losing windows again cuz I need it for work (unfortunately)
 
Old 01-09-2004, 06:12 PM   #6
kuyalfinator
Member
 
Registered: Jul 2003
Location: Los Angeles
Distribution: RedHat8 2.4.18-14 RedHat9 2.4.20-8 FreeBSD 5.2.1 Ubuntu 10_4 Mandrake 2.4.21-0.13mdk
Posts: 118

Rep: Reputation: 16
another type of answer

I lost windows 2000 before when I had triple boot laptop. In order
to get the windows 2000 back, you would need the boot.ini
file that is included when you have two types of windows operating
systems installed. Then, I ran the windows 2000 and booted off
the CD-ROM. I choose the repair option for an exsisting OS,
and got it fixed that way. After repairing the windows 2000, it
then ran the linux rescue boot and installed the the boot loader.
Hope this helps.

Details about triple boot
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
dualboot win2k w/ntfs & fedora w/grub? bewildered Fedora 2 12-19-2003 10:33 AM
how to uninstall lilo & install grub without using gui & linuxconf? prav_284 Red Hat 1 11-28-2003 06:45 AM
LILO/GRUB fail & Lost data pete_willis Linux - Newbie 2 11-15-2003 10:56 PM
dual booting Win2k & RH Linux using ntldr->GRUB has problems whitepine Linux - General 3 01-28-2003 06:39 PM
Howto: remove lilo & put win2k boot loader back? hugodog Linux - General 2 05-10-2002 01:45 PM


All times are GMT -5. The time now is 08:33 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration