LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (http://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   logout in x doesn't work and nvidia doesn't boot (http://www.linuxquestions.org/questions/linux-newbie-8/logout-in-x-doesnt-work-and-nvidia-doesnt-boot-194910/)

Meriadoc 06-18-2004 04:48 AM

logout in x doesn't work and nvidia doesn't boot
 
Hi all,
I have two strange problems that I think are related. The first is during boot, nine times out of ten X won't start but dumps me to root login. I discovered I had to do 'modprobe nvidia', login under my own username and then type 'startx' to get the machine going.
When I logout in the graphic shell (to login as another user for instance), the machine crashes to the text line mode again. The weird thing is that it crashes with a different error every time. I have written down a two:
- waiting for X server to shut down FreeFontPath: FPE "unix/:-1" refcount is 2, should be 1; fixing.
- clients rejected from local host
Now my hands are just itching to do yet another reinstall, but my mind is resisting. Reinstalling is for Windoze users, and besides I won't learn anything if I do that. I am failing rather miserably at finding a soluting for this problem. Can anybody point me in the right direction?
Thanks in advance,
Merijn

jeffreybluml 06-18-2004 06:40 AM

This may or may not work, but if you'r not getting any other help it's worth a try...

I "broke" my nvidia driver one day while playing GLTron. DOn't know what happened, it was fine, but GLTron froze and after reboot I could no longer boot. So, I entered runlevel 3 (/sbin/init 3) and re-installed the nvidia drivers, then re-edited my XFree86 file, and rebooted. All was better...

So, for kicks, try re-installing your nvidia driver. It's worth a shot...

Good luck!

Meriadoc 06-18-2004 12:32 PM

I gave it a shot, and it seems to have fixed my problems for now. I faintly remember trying out the laserbikes game, but I'm not sure if it was before or after my problems started. But everything works once again.
Thanks for the help.
Cheers,
Merijn


All times are GMT -5. The time now is 12:58 PM.