LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (http://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Logitech Usb Headset (http://www.linuxquestions.org/questions/linux-newbie-8/logitech-usb-headset-723318/)

GypsyPants 05-03-2009 10:21 AM

Logitech Usb Headset
 
Just switcehd to linuxmint6 xcfe desktop, and for some reason it won't find or read my logitech usb Headset? could it be a driver issue?

10speed705 05-03-2009 03:49 PM

Quote:

Originally Posted by GypsyPants (Post 3528515)
Just switcehd to linuxmint6 xcfe desktop, and for some reason it won't find or read my logitech usb Headset? could it be a driver issue?

Drivers can be a possibility do any USB devices work?

GypsyPants 05-03-2009 04:06 PM

Quote:

Originally Posted by 10speed705 (Post 3528769)
Drivers can be a possibility do any USB devices work?

Yes my firelite external hard drive does. But for some reason not my usb headset. Firelite is connected by usb as well.

GypsyPants 05-03-2009 07:54 PM

Bump, need some help with this. Really would like to listen to music..

Hangdog42 05-04-2009 07:10 AM

Check the output of lsmod. When you plug in the headset (or boot with it plugged in) the snd-usb-audio module should be loaded. If it isn't, try loading it manually:

modprobe snd-usb-audio

You also might need to configure the headset in whatever sound mixer linux mint uses.

GypsyPants 05-04-2009 03:42 PM

Quote:

Originally Posted by Hangdog42 (Post 3529432)
Check the output of lsmod. When you plug in the headset (or boot with it plugged in) the snd-usb-audio module should be loaded. If it isn't, try loading it manually:

modprobe snd-usb-audio

You also might need to configure the headset in whatever sound mixer linux mint uses.

It reads it, but no sound, neither does my moniter either. And how do I configure my headset?

Hangdog42 05-04-2009 03:59 PM

OK, lets see if your computer recognizes it. Please post the output of arecord -l. That should list all of the audio devices that your system knows about. Each device will have a "card" number. To configure your USB headset, run alsamixer -c # Where # is the card number of your headset. That should let you set the volume.

GypsyPants 05-04-2009 04:12 PM

This is what I get in my terminal

_______________________________________
/ You never hesitate to tackle the most \
\ difficult problems. /
---------------------------------------
\
\ \_\_ _/_/
\ \__/
(oo)\_______
(__)\ )\/\
||----w |
|| ||
ivan-desktop ~ # arecord -l
**** List of CAPTURE Hardware Devices ****
card 0: I82801DBICH4 [Intel 82801DB-ICH4], device 0: Intel ICH [Intel 82801DB-ICH4]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: I82801DBICH4 [Intel 82801DB-ICH4], device 1: Intel ICH - MIC ADC [Intel 82801DB-ICH4 - MIC ADC]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: I82801DBICH4 [Intel 82801DB-ICH4], device 2: Intel ICH - MIC2 ADC [Intel 82801DB-ICH4 - MIC2 ADC]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: I82801DBICH4 [Intel 82801DB-ICH4], device 3: Intel ICH - ADC2 [Intel 82801DB-ICH4 - ADC2]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: Headset [Logitech USB Headset], device 0: USB Audio [USB Audio]
Subdevices: 1/1
Subdevice #0: subdevice #0
ivan-desktop ~ #


Card: Intel 82801DB-ICH4 │
│ Chip: Analog Devices AD1981B │
│ View: [Playback] Capture All │
│ Item: Master [dB gain=-9.00, -9.00] │
│ │
│ ┌──┐ ┌──┐ ┌──┐ ┌──┐ ┌──┐ ┌──┐ │
│ │ │ │ │ │ │ │ │ │ │ │ │ │
│ │ │ │ │ │ │ │ │ │ │ │ │ │
│ │▒▒│ │▒▒│ │ │ │▒▒│ │ │ │▒▒│ >
│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │ │ │▒▒│ >
│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ >
│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ >
│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ >
│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ >
│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │
│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │
│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │
│ ├──┤ ├──┤ ├──┤ ┌──┐ ├──┤ ├──┤ ┌──┐ ├──┤ │
│ │OO│ │OO│ │OO│ │OO│ │OO│ │OO│ │OO│ │OO│ │
│ └──┘ └──┘ └──┘ └──┘ └──┘ └──┘ └──┘ └──┘ │
│ 81<>81 81 71<>71 81<>81 61<>61 81<>81 │
│ < Master >Master M Headphon Headphon PCM Line Line Jac CD │
└──────────────────────────────────────────────────────────────────────────────┘


all of em are above... what does this mean?

GypsyPants 05-04-2009 04:43 PM

line and jack can't be configured, it doesn't let me put anything up, is this why there is no sound coming from my logitech headset? Nvm, i put the card number as 0 when logitech was 1, it shows it does have volume as for speaker and mic... but still no sound...

Hangdog42 05-04-2009 05:12 PM

The alsamixer output you posted is for the Intel chipset (I'm guessing that is your onboard sound). Try running alsamixer -c 1, which should point to your USB headset.

GypsyPants 05-04-2009 05:17 PM

Quote:

Originally Posted by Hangdog42 (Post 3530112)
The alsamixer output you posted is for the Intel chipset (I'm guessing that is your onboard sound). Try running alsamixer -c 1, which should point to your USB headset.

I did, and speaker was up but mic was down, and still no music, hangdog42, you mind giving me your msn if you have it? I really want to get this solved.

Hangdog42 05-05-2009 07:25 AM

Quote:

you mind giving me your msn if you have it?
Sorry, this is the only place I give help due to constraints on my time.


From what you've posted so far, your headset might be functional. Maybe it is time to look at the software you're using to play music. Does it have the ability to select output?

GypsyPants 05-05-2009 02:37 PM

I don't know its exaile music player..

Hangdog42 05-05-2009 02:53 PM

Quote:

I don't know its exaile music player..
Then look in the menus and see if there is some sort of settings or options. I've never used exaile, so I'm not going to be much help.

The other place to look is in your System or Preferences menu for the Sound settings and see if you can make your headset the default. I know those are there in the Gnome interface, I'm not sure where in XFCE it would be.


All times are GMT -5. The time now is 05:17 PM.