LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 11-03-2015, 05:58 PM   #1
jgr2
LQ Newbie
 
Registered: Nov 2015
Location: Baton Rouge, LA
Distribution: Mint 17.2 Cinnamon
Posts: 3

Rep: Reputation: Disabled
Logitech Trackman Wheel USB


After a varying period of idle, my Logitech TrackMan Wheel, Model T-BB18 wired USB, goes crazy, moving all over and even outside the desktop, wildly opening calendar, other apps and sprinkling many Untitled Folders on the desktop. Downloaded latest Linux driver for TrackMan to find file HIDPoint1-0.bin is the same as presently installed. Changed mouse to Microsoft optical wheel mouse and also to older model Logitech TrackMan Wheel, both with the same crazy mouse result. TrackMan Wheel is necessitated by small space on desk keyboard tray. XKILL does not shut down and the solution is manual computer power off.

Also, uninstalled Hibernate, reset input Method and Mouse (Acceleration and sensitivity of pointer size and speed).

Crazy mouse first happened in Linux Mint Cinnamon 16 64-bit on a dual boot to Windows. Then used KVM switch (PS/2 ports with USB to PS/2 adapter for USB mouse) connection between Windows and Linux Mint Cinnamon 17.0 32-bit on a Pentiom 4 with 2 MB RAM. Crazy Mouse happened again. Clean installed Linux Mint Cinnamon 17.2 on Linux Box; same crazy mouse after a day of configuration and copying files and programs.

Suggestions, please.
 
Old 11-03-2015, 08:13 PM   #2
jefro
Moderator
 
Registered: Mar 2008
Posts: 15,374

Rep: Reputation: 2198Reputation: 2198Reputation: 2198Reputation: 2198Reputation: 2198Reputation: 2198Reputation: 2198Reputation: 2198Reputation: 2198Reputation: 2198Reputation: 2198
Two mice do the same thing tends to exclude them.

You seem to feel that some issue on Mint 16 may have caused this so I'd try some live cd/dbd/usb of an older version then try the live media of the newest to see if it fails in this same time period.

Never hurts to double check that your connections are solid and fully inserted. Any plug or jack could be going bad.
 
Old 11-04-2015, 04:54 AM   #3
Philip Lacroix
Member
 
Registered: Jun 2012
Distribution: Slackware{,-current}, OpenBSD
Posts: 361

Rep: Reputation: 377Reputation: 377Reputation: 377Reputation: 377
Some time ago there were reports of mouse pointers going haywire when using PS/2 mice on KVM switches. A solution would be to set the psmouse module this way in /etc/modprobe.d/psmouse.conf:
Code:
options psmouse proto=imps
Back then I could solve this way a problem similar to the OPs. While the mouse used by the OP is USB, it is plugged in through a USB to PS/2 adapter, hence the above setting might still be relevant to the described issue.
 
1 members found this post helpful.
Old 11-12-2015, 03:03 PM   #4
jgr2
LQ Newbie
 
Registered: Nov 2015
Location: Baton Rouge, LA
Distribution: Mint 17.2 Cinnamon
Posts: 3

Original Poster
Rep: Reputation: Disabled
Logitech TrackMan Wheel USB

It locked again 11/09 after spending many hours on a document in Write. Firefox was open in 2 tabs, Nemo was open, computer idle for a few minutes when mouse started opening calendar & sprinkling 7 Unnamed folders on desktop, PC locked up, neither keyboard (Ctrl-Alt-Backspace) nor mouse would work. I could not get Philip Lacroix's suggestion done to add "/etc/modprobe.d/psmouse.conf" and it would not let me add a .conf folder or the "options psmouse proto=imps". I don't know how to do it in Terminal. Powered computer off with button and lost document. After that, I found LibreOffice Write backup was incorrectly set. Such is Linux for me.
jgr2
 
Old 11-12-2015, 03:35 PM   #5
Philip Lacroix
Member
 
Registered: Jun 2012
Distribution: Slackware{,-current}, OpenBSD
Posts: 361

Rep: Reputation: 377Reputation: 377Reputation: 377Reputation: 377
Quote:
Originally Posted by jgr2
It locked again 11/09 after spending many hours on a document in Write. (...) Powered computer off with button and lost document. After that, I found LibreOffice Write backup was incorrectly set. Such is Linux for me.
You should never assume that a program has an auto-save feature enabled by default. Especially when you work on the same document for a long time. With such premises, in a similar situation you would have lost your document anyway, with any operating system. That having been said, I find the "Ctrl-S" command quite straightforward.

Regarding your trackball issue, what I suggested above involves adding a file named "psmouse.conf" to the directory named "/etc/modprobe.d/". In that file you should put the line "options psmouse proto=imps", nothing else. You need root permissions in order to do that. Perhaps it won't solve your problem, but in my opinion it's worth trying.

EDIT: By the way, did you try unplugging the trackball and plugging it in again?

Last edited by Philip Lacroix; 11-12-2015 at 03:48 PM.
 
1 members found this post helpful.
Old 11-12-2015, 05:50 PM   #6
jefro
Moderator
 
Registered: Mar 2008
Posts: 15,374

Rep: Reputation: 2198Reputation: 2198Reputation: 2198Reputation: 2198Reputation: 2198Reputation: 2198Reputation: 2198Reputation: 2198Reputation: 2198Reputation: 2198Reputation: 2198
Did you try what I suggested?
 
Old 11-12-2015, 07:09 PM   #7
SaintDanBert
Senior Member
 
Registered: Jan 2009
Location: Austin, TX
Distribution: Mint-17.1 with Cinnamon & KDE
Posts: 1,478
Blog Entries: 3

Rep: Reputation: 95
Quote:
Originally Posted by jgr2 View Post
After a varying period of idle, my Logitech TrackMan Wheel, Model T-BB18 wired USB, goes crazy, moving all over and even outside the desktop, wildly opening calendar, other apps and sprinkling many Untitled Folders on the desktop.
...
I had a very similar situation. I discovered that most of the troubles "went away" when I disabled other pointing devices -- especially the trackpad which is built into my keyboard.

I created some scripts that I used to select which pointing device I wanted to use and to systematically disable the others. Like I said, most of the troubles "went away."

I found another issue while using a trackball that I've had "... like, ugh, forever..."
I have my keyboard and trackball on a keyboard tray. Vibrations of that tray would cause minor rotation of the trackball resulting in pointer dislocation. I played with various movement settings like acceleration and managed to reduce this trouble to a minimum. (grin, blush) I also tightened some desk hardware so that thing did not vibrate much if any.

I hope that this helps.
~~~ 0;-Dan
 
Old 11-19-2015, 01:01 PM   #8
jgr2
LQ Newbie
 
Registered: Nov 2015
Location: Baton Rouge, LA
Distribution: Mint 17.2 Cinnamon
Posts: 3

Original Poster
Rep: Reputation: Disabled
Logitexh TrackMan Wheel USB

Thanks to Philip, Your suggestion worked since 11/13 for 6 days now. It took this newbie 3 tries to make the file in Terminal to fix erratic and wild TrackMan Wheel after idle. Since 11/13 I had one computer lockup with several things open, but no wild and crazy mouse pointer or lost file as before. I set auto backup at 3 minutes in Writer. Many thanks,
JoeR
 
Old 11-19-2015, 01:40 PM   #9
ardvark71
LQ Veteran
 
Registered: Feb 2015
Location: Oregon, USA
Distribution: Lubuntu 14.04, Windows Vista
Posts: 5,150
Blog Entries: 3

Rep: Reputation: 691Reputation: 691Reputation: 691Reputation: 691Reputation: 691Reputation: 691
Quote:
Originally Posted by jgr2 View Post
Thanks to Philip, Your suggestion worked since 11/13 for 6 days now.
Hi Joe...

Glad it's working! If you would, please mark this thread as "SOLVED" by clicking on "Thread Tools" directly above your initial post. Thanks!

Regards...
 
Old 11-19-2015, 04:18 PM   #10
Philip Lacroix
Member
 
Registered: Jun 2012
Distribution: Slackware{,-current}, OpenBSD
Posts: 361

Rep: Reputation: 377Reputation: 377Reputation: 377Reputation: 377
Hi Joe. You're welcome, I'm glad that you could solve the problem, and I hope your TrackMan Wheel will be stable from now on. BTW, I had the same issue a few days ago after a fresh OS install. After setting psmouse.conf the problem disappeared once again.

Philip

Last edited by Philip Lacroix; 11-19-2015 at 04:21 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Logitech Cordless Trackman Wheel hacker supreme LinuxQuestions.org Member Success Stories 1 08-04-2007 03:44 AM
Logitech TrackMan Wheel USB on RH9 Lleb_KCir Linux - Hardware 1 03-31-2004 10:13 PM
debian / 2.6.3 / usb mouse (logitech trackman) Kallewoof Debian 7 03-16-2004 12:06 PM
Logitech Cordless USB wheel Fred Affe Linux - Newbie 7 10-17-2003 01:50 PM
Logittech/USB/Cordless Trackman Wheel Mouse justaguynsrq Linux - Hardware 0 06-25-2003 08:54 PM


All times are GMT -5. The time now is 06:18 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration