LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-26-2003, 09:46 PM   #1
Selos
Member
 
Registered: Aug 2003
Location: Germany
Distribution: Debian
Posts: 59

Rep: Reputation: 15
logitech optical mouseman - the wheel doesn't work


i have a wheel mouse from logitech, but the wheel does not work *g*
i tried different settings an then i killed my mouse so it was wild clicking arround an i had to reconfig my X-Window hehe. anyone who knows help? i is very annoying to scroll the websites that are long with my whole hand :/
 
Old 08-26-2003, 10:43 PM   #2
mcd
Member
 
Registered: Aug 2003
Location: Boulder, CO
Distribution: Slackware, RHEL, CentOS
Posts: 825

Rep: Reputation: 33
hi selos, i have the same mouse

you have to edit the etc/X11/X86config file under the Pointer's Input section to include the following options:

Identifier "Mouse1"
Driver "mouse"
Option "Buttons" "5"
Option "ZAxisMapping" "4 5"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/mouse"

they may be in any order, but the important ones are the protocol, buttons and ZAxisMapping. basically, you tell the system that scrolling the wheel up = button 4 and down = button 5.

try that, it should work.
 
Old 08-26-2003, 10:57 PM   #3
Selos
Member
 
Registered: Aug 2003
Location: Germany
Distribution: Debian
Posts: 59

Original Poster
Rep: Reputation: 15
you mean etc/X11/XF86Config i hope, because there is no X86Config

and i hope it should be look like this:

Code:
Section "InputDevice"
     Identifier "Mouse0"
     Driver "mouse"
     Option "Protocol" "PS/2"
     Option "Device" "/dev/psaux"
     Option "ZAxisMapping" "4 5"
     Option "Emulate3Buttons" "no"
     Identifier "Mouse1"
     Driver "mouse"
     Option "Buttons" "5"
     Option "ZAxisMapping" "4 5"
     Option "Protocol" "IMPS/2"
     Option "Device" "/dev/mouse"
EndSection
 
Old 08-27-2003, 03:36 AM   #4
mcd
Member
 
Registered: Aug 2003
Location: Boulder, CO
Distribution: Slackware, RHEL, CentOS
Posts: 825

Rep: Reputation: 33
doh! sorry for the typo.

looks like you've got support for two mice, is that what you want/need?
 
Old 08-27-2003, 10:10 AM   #5
Selos
Member
 
Registered: Aug 2003
Location: Germany
Distribution: Debian
Posts: 59

Original Poster
Rep: Reputation: 15
hm no i don't think so, i only use this logitech mouse and that's it so you mean i should instead of adding the entry editing the existing mouse0 entry?
 
Old 08-27-2003, 01:43 PM   #6
mcd
Member
 
Registered: Aug 2003
Location: Boulder, CO
Distribution: Slackware, RHEL, CentOS
Posts: 825

Rep: Reputation: 33
well, you've got 2 mice configured, a normal PS/2 mouse (mouse0) and the logitech (mouse1). if you only use the one, i would comment out the first entry. i found that my mouse worked fine under the old settings, but the wheel only activate when i used the IMPS/2 protocol.

there should be a way to select which mouse to use, but unfortunately i don't know how, so if you figure it out let me know - it's often worth having a second, normal mouse configured in case USB goes down, or the batteries die.
 
Old 08-27-2003, 03:15 PM   #7
Selos
Member
 
Registered: Aug 2003
Location: Germany
Distribution: Debian
Posts: 59

Original Poster
Rep: Reputation: 15
now i have it looking like this:

Code:
Section "InputDevice"
#	Identifier  "Mouse0"
#	Driver      "mouse"
#	Option	    "Protocol" "PS/2"
#	Option	    "Device" "/dev/psaux"
#	Option	    "ZAxisMapping" "4 5"
#	Option	    "Emulate3Buttons" "no"
	Identifier "Mouse1"
	Driver "mouse"
	Option "Buttons" "5"
	Option "ZAxisMapping" "4 5"
	Option "Protocol" "IMPS/2"
	Option "Device" "/dev/mouse"
EndSection
is this correct so?
and when will the changes be aktive? reboote?
 
Old 08-27-2003, 03:29 PM   #8
MasterC
LQ Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 64
You can just restart X for the changes to take effect, this is linux after all, no need for a reboot...

CTRL ALT BACKSPACE should restart X

Cool
 
Old 08-27-2003, 03:38 PM   #9
Selos
Member
 
Registered: Aug 2003
Location: Germany
Distribution: Debian
Posts: 59

Original Poster
Rep: Reputation: 15
yes but i want to be sure that these changes are correct and won't disbale my mouse or crash any system
 
Old 08-27-2003, 03:40 PM   #10
MasterC
LQ Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 64
Yeah, I'd change the "Identifier" to Mouse0 though, as this is your first mouse, and Linux tends to count from 0.

Cool
 
Old 08-27-2003, 03:48 PM   #11
Selos
Member
 
Registered: Aug 2003
Location: Germany
Distribution: Debian
Posts: 59

Original Poster
Rep: Reputation: 15
hm a showed it a friend of minw who is using gentoo and he said that the /dev/mouse wouldn't work and i should use /dev/psaux instead.. and now i am really confused
 
Old 08-27-2003, 03:51 PM   #12
MasterC
LQ Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 64
Gentoo uses DevFS, RedHat uses actual devices (IIRC) so it's up to you which one to use, I actually use:
/dev/input/mice

To find one you like, try this:
cat /dev/mouse
And move your mouse around. If characters pop up, you are probably good to go. Now try cat /dev/psaux and see if characters pop up, if both work, you can probably use both, and see which one works better (if either) for you.

Cool
 
Old 08-27-2003, 03:57 PM   #13
Selos
Member
 
Registered: Aug 2003
Location: Germany
Distribution: Debian
Posts: 59

Original Poster
Rep: Reputation: 15
hm lol i think i'm to stupid ;(

i go to the terminal and type cat /dev/mouse and nothing happens...
so i close this terminal and open a new one and type in cat /dev/psaux and .. nothing happens...
in both cases i was moving my mouse around

newby@work
 
Old 08-27-2003, 03:59 PM   #14
MasterC
LQ Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 64
I don't get anything from /dev/psaux, but from /dev/mouse I do Feel free to try that with other devices as well, check /dev/input and give a few of those a try.

Remember to do it as root

Cool
 
Old 08-27-2003, 04:03 PM   #15
Selos
Member
 
Registered: Aug 2003
Location: Germany
Distribution: Debian
Posts: 59

Original Poster
Rep: Reputation: 15
yes i am logged in as root, otherwise i would not have been able to change the X86Config file

but what confuses me, the mous0 worked with psaux but when i make this cat thing in the terminal like you told me, nothing happens.. and anywhere do caharcters pop-up (whatever this means )
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Help with logitech cordless mouseman optical nivek7 Linux - Hardware 0 05-07-2004 08:33 PM
Logitech Mouseman Optical Duel Sensor does not work limdeswein Linux - Hardware 8 02-13-2004 07:42 PM
Logitech MouseMan Wheel Optical in Fedora Core 1, kernel 2.6 panickedthumb Linux - Hardware 15 02-03-2004 04:14 PM
Logitech Optical Mouseman & MDK 9.1 BobbyF-UK Linux - Newbie 0 08-19-2003 05:58 PM
Logitech mouseman wheel beeb Linux - Newbie 3 02-14-2003 09:23 AM


All times are GMT -5. The time now is 09:05 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration