LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 04-04-2004, 06:18 PM   #1
elamigo2004
Member
 
Registered: Apr 2004
Location: HELL
Distribution: Phlak / Knoppix / Puppy
Posts: 98

Rep: Reputation: 15
Talking Login to ROOT with Debian?


Hey, how do you login to root with Debian Linux (specifically Phlak)? I think I'm not logged in correctly, because it's not showing the contents of my other partitions in the file manager. Thanks. Please be nice, I'm a newbie.
 
Old 04-04-2004, 06:26 PM   #2
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 23,000
Blog Entries: 11

Rep: Reputation: 893Reputation: 893Reputation: 893Reputation: 893Reputation: 893Reputation: 893Reputation: 893
If you're a newbie you don't want to be logged
in as root, particularly not in a graphical environment,
and specially not in any kind of file-manager.



Cheers,
Tink
 
Old 04-04-2004, 06:42 PM   #3
GT_Onizuka
Member
 
Registered: Aug 2003
Location: Atlanta
Distribution: Debian, OS X
Posts: 711

Rep: Reputation: 30
If you need to become root (to install a program or something) do so (as Tinkster said) NOT in the GUI, but through the terminal using su.

At the command line you would:
$ su
[enter root password]
BAM, you are now root. Only use root when you need it, as it is hazardous to your system.
 
Old 06-05-2009, 03:38 PM   #4
Heru-kun
LQ Newbie
 
Registered: Apr 2008
Posts: 23

Rep: Reputation: 16
I'm pretty much having the same issue, i need to change permissions to my normal user to access ntfs partitions, i tried search in forums but nothing works for me. i have 2 ntfs partitions which i cannot format bcs i need them that way and therefore i need to access them from all my OSes, i can indeed mount them as supersuser from terminal, but i cannot access the folder via visual, which is what i want to do... if there's no need to do it and you know a way, would be great if you can post it here...
 
Old 06-05-2009, 03:42 PM   #5
Quakeboy02
Senior Member
 
Registered: Nov 2006
Distribution: Debian Squeeze 2.6.32.9 SMP AMD64
Posts: 3,245

Rep: Reputation: 121Reputation: 121
Do NOT login as root. If you need to have root do something, use the "sudo" command in a termal, or if you need to have it done by a GUI, run the GUI program with "gksu" (I assume kde has something similar). But, DO NOT login to your X session as root. If you do, you will eventually pay a very big price due to lost files, broken file systems, and/or borked permissions. Don't Do It.
 
Old 06-05-2009, 03:44 PM   #6
Heru-kun
LQ Newbie
 
Registered: Apr 2008
Posts: 23

Rep: Reputation: 16
Indeed, i know that's very dangerous, so i'm still trying to find a way in order not to.
I'm using debian, so i don't really use sudo, i become superuser whenever i need to do something that needs to, but i still can't add the permissions to my NORMAL user to access the folder where i mounted the ntfs partition visually in my file manager, any suggestions?
 
Old 06-05-2009, 03:53 PM   #7
Quakeboy02
Senior Member
 
Registered: Nov 2006
Distribution: Debian Squeeze 2.6.32.9 SMP AMD64
Posts: 3,245

Rep: Reputation: 121Reputation: 121
My mistake for not looking at the date on the original post. Please do not open up old threads and steal them for your own. Open an new thread and I will try to help you. I will not respond further in this thread.

Last edited by Quakeboy02; 06-05-2009 at 03:56 PM.
 
Old 06-05-2009, 03:59 PM   #8
Heru-kun
LQ Newbie
 
Registered: Apr 2008
Posts: 23

Rep: Reputation: 16
Sorry, you're right. Here it goes:

# /etc/fstab: static file system information.
#
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc defaults 0 0
/dev/sda1 / ext3 errors=remount-ro 0 1
/dev/sda4 /home/kiki/Files ntfs defaults 0 2
/dev/sda5 none swap sw 0 0
/dev/hda /media/cdrom0 udf,iso9660 user,noauto 0 0

The line in red is where i mount automatically the HD into a folder, and it mounts it without any probs, the only thing i don't know, is how to grant permissions (to my normal user, in this case kiki) to access that folder, when i try to open it in nautilus, says:

The folder contents could not be displayed.
You do not have the permissions necessary to view the contents of "Files".

I also added my user to sudoers file in order to use sudo... but still don't know how to grant the permissions to the user from terminal.
 
Old 06-05-2009, 04:39 PM   #9
farslayer
Guru
 
Registered: Oct 2005
Location: Willoughby, Ohio
Distribution: linuxdebian
Posts: 7,232
Blog Entries: 5

Rep: Reputation: 189Reputation: 189
http://wiki.debian.org/NTFS

install ntfs-3g

aptitude update
aptitude install ntfs-3g


follow the examples in the debian wiki to create a proper /etc/fstab entry and mount the partition


As Quakeboy said, you really should start a NEW thread for each issue you are working on, rather than resurrecting a really old thread, which in this case is 5 years old..


Cheers !!
 
Old 06-06-2009, 10:09 AM   #10
Heru-kun
LQ Newbie
 
Registered: Apr 2008
Posts: 23

Rep: Reputation: 16
Sorry, but the title and everything was pretty much what i wanted to say, so instead of duplicating i thought it would be better just to enlarge it a little...
 
Old 09-26-2010, 01:20 AM   #11
glent
LQ Newbie
 
Registered: Sep 2010
Location: U.S.A
Distribution: Debian, Puppy
Posts: 3

Rep: Reputation: Disabled
Lightbulb

"If you're a newbie you don't want to be logged
in as root, particularly not in a graphical environment,
and specially not in any kind of file-manager."

-bullsh!t-

Greetings,
I am new to this forum but I wanted to respond to this particular thread. I see over and over on the web dire warnings all the time from "old" linux gurus about logging in as root and how you may damage the system and use SU instead ad infinitum. I would like to point something out. Many of us out here in puter land have multiple systems to play with. These pc's are not production computers but are merely toys with which to learn. I have several pc's here at the house and I use some of them for new linux distros in order to learn. It does not matter whether or not the system gets hosed, I will rebuild it again if I screw it up. In fact, I learn a lot that way. All the dire warnings get tiresome. The little box next to me as I type was recently loaded with the latest Debian/Gnome and when I am done with it I may load something else entirely. I just wanted to point this out. I think when "newbies" post a question about how to login as root, it would be better to provide the explanation followed by a "not so dire" warning.
Thanks, just my 2 cents.

Grok on...

Now, that being said, the easiest way is to reconfigure the login screen to allow administrator logins. Reboot, at the login prompt, click on Actions (bottom of screen). Choose "Configure Login Manager". Enter the root password. Scroll to where it says Security and put a check mark next to "Allow Local System Administrator Login". Close. Now log in as root. Disregard the warning. Hack away. If you blow it up, try another distro, I suggest Zorin.
 
Old 11-20-2010, 07:02 PM   #12
dionysis
LQ Newbie
 
Registered: Nov 2010
Location: London, UK
Distribution: Ubuntu 11.04, Ubuntu 11.10, Ubuntu 12.04
Posts: 2

Rep: Reputation: 0
@glent

I just installed Debian in my desktop as secondary OS. The reason is to learn how to use Linux.
I totally agree with your point of view, as it is my responsibility if i f*&k up my system.This forum as the most of them on internet are to provide suggestions on how to solve problems that people like me (newbies) are dealing with.

That said, I would like to thank you for your solution. It worked perfectly for me.

And last I would like to point out that I most probably f&@ked it up. But this is the joy of learning.

Thank you and I would like to thank all the people that are sharing their knowledge with us the newbies.

Regards,

Dionysis
 
Old 11-20-2010, 09:59 PM   #13
frankbell
Guru
 
Registered: Jan 2006
Location: Virginia, USA
Distribution: Slackware, Mageia, Mint
Posts: 8,098

Rep: Reputation: 1538Reputation: 1538Reputation: 1538Reputation: 1538Reputation: 1538Reputation: 1538Reputation: 1538Reputation: 1538Reputation: 1538Reputation: 1538Reputation: 1538
I am going to second what glent said.

In one way, I guess that warning persons not to log in as root indicates how far Linux has come. Used to be, you couldn't get it working unless you could log in as root to tweak everything up. But . . . .

[RANT MODE ON]

Logging in as root is not inherently dangerous. It is unwise, in that, if you get an intrusion while logged in as root, the intrusion has the run of the computer, but it is not dangerous in and of itself.

It's doing stupid stuff that is inherently dangerous. If you do your homework and take advantage of the resources available on line and, if you have a local LUG, in person, you can avoid stupid stuff.

One of the things that really irritates me about some Linux distributions, including distros that I use quite well thank you, is that they make logging in as root difficult or impossible. They are ipso facto assuming that their users are not competent.

Sorry, my computer belongs to me, not to the distro.

[RANT MODE OFF]

I started with Slackware.

elamigo2004, install Slackware. It will let you log in as root. Upon installation, it forces you to create a root password. Once you boot the computer and login as root, use adduser [username] to add a regular user. Use root to do root stuff and user to do user stuff (like posting at LQ).

If you learn your way around Slackware, no other distro will ever intimidate you.

Learn and enjoy.

Last edited by frankbell; 11-20-2010 at 10:00 PM. Reason: spelling
 
Old 11-21-2010, 05:36 AM   #14
Nylex
LQ Addict
 
Registered: Jul 2003
Location: London, UK
Distribution: Slackware
Posts: 7,464

Rep: Reputation: Disabled
This thread was started in 2004. I doubt the OP cares any more..
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
wrong login shell prevent root login cefs99 Linux - Security 4 05-31-2006 09:28 AM
How to login to debian with root user? solutionseeker Linux - Newbie 2 01-29-2005 10:39 AM
Debian 3 root login problems everest Linux - Software 3 06-26-2004 04:48 PM
I have re-installed MK 9.2 but cannot login as user, login as root works. bobinglis Mandriva 2 02-22-2004 12:39 PM
can only login as root? user login doesnt work..? anyone? hacking_4_b33r Linux - General 1 02-06-2004 12:40 AM


All times are GMT -5. The time now is 08:05 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration