LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 05-04-2004, 02:37 PM   #1
ipsrus
LQ Newbie
 
Registered: May 2004
Posts: 2

Rep: Reputation: 0
Login problems after account is created


Hello,

Recently loaded Fedora Core 2 Test 2 on my laptop. Trying to add a new account and here's the command I executed as root:

useradd -c "Oracle Software Owner" -g oinstall -G dba oracle

Command got executed without any errors. When I log out and try to log in as "oracle", I get this message:

"Your home directory is listed as: /home/oracle - but it does not appear to exists. Do you want to log in with the / (root) directory as your home directory? It is unlikely anything will work unless you use a failsafe session"

Also, when I am logged in as root and "su" to oracle, I get a message:
"Would you like to enter a security context? (Y/N)". After I respond with a "N", it lets me login without any problems.

The directory /home/oracle exists, and everything else looks OK. I am stumped. Would appreciate any feedback from users who have had similar problems/issues.

Thanks,
 
Old 05-04-2004, 02:45 PM   #2
Mara
Moderator
 
Registered: Feb 2002
Location: Grenoble
Distribution: Debian
Posts: 9,536

Rep: Reputation: 148Reputation: 148
You probably have two scripts: 'useradd' and 'adduser'. Useradd is more low-level, it just adds the user. Adduser creates the home dir and makes a basic setup
The home directory problem may be caused by the fact that /home/oracle may be unaccessible fot your new user. Check permissions, probably owner of this dir is set to someone else.
 
Old 05-04-2004, 03:11 PM   #3
ipsrus
LQ Newbie
 
Registered: May 2004
Posts: 2

Original Poster
Rep: Reputation: 0
Problem persists

Thanks for the response.

I tried adding a brand new account using the GUI interface under GNOME environment. Selected "System Setting" -> "Users and Groups" -> "Add User". Successfully added, but when I log out and log in as the user, I get the same message.

Also confirmed home directory got created, checked permissions etc. Everything look OK.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
I cant login using an user I haveve created! ssobeht Slackware 2 08-20-2004 08:02 AM
Problems with console login on newly created root filesystem (for PXEboot) holandes777 Linux - General 1 08-05-2004 05:11 PM
Logging in as root after ¨normal" account created Xalies Linux - Newbie 2 08-02-2004 01:36 AM
I can't login with newly created user r_ibsen Linux - Newbie 2 06-19-2004 08:32 AM
Created a user account on slackware and now I cant enter root shirokiba Linux - Newbie 2 04-18-2004 07:44 PM


All times are GMT -5. The time now is 11:29 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration