LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-18-2008, 04:56 PM   #1
r_avital
LQ Newbie
 
Registered: Oct 2006
Posts: 25

Rep: Reputation: 15
Login problem - Debian Etch AMD64


Hello all,

A strange problem on a system on which I've just installed Debian 4.01 AMD64 (the system is an AMD64 box):

I just restarted the system, and I'm prompted for a login in text mode. A few lines above the prompt, there is a line that reports that kdm has been started. But for some reason, the boot process doesn't go to the graphical screen where I can select the kind of session I want, and log in.

I can log in with my user credentials, no problem, only in this text mode. Once I've done that, I can also login as root. But I can't get to a KDE login.

Any ideas?

Thanks in advance
 
Old 02-18-2008, 05:29 PM   #2
{Spitfire}
LQ Newbie
 
Registered: Feb 2008
Posts: 1

Rep: Reputation: 0
you can still login to graphical mode issuing the startx or X command! If there are errors, the commands should report the same. Otherwise, post the contents of /var/log/Xorg.0.log. May be that will help.
 
Old 02-18-2008, 07:26 PM   #3
r_avital
LQ Newbie
 
Registered: Oct 2006
Posts: 25

Original Poster
Rep: Reputation: 15
Thank you Spitfire,

Almost complete newbie here, so I don't know how to capture the output from one machine in text mode and paste it here, but I can kvm between the two systems, so I'll post what I got.

I ran startx, and got the following response:

==============================================
Backtrace:

0: /usr/bin/X11/X(xf86SigHandler+06d) [0x4720bd]
1: /lib/libc.so.6 [0x2b4158450110]
2: /lib.libc.so.6(__ctype_tolower_loc+0x25) [0x2b415844a2c5]
3: /usr/bin/x11/X(xf86nameCompare+0xfe) [0x4a4d4e]
4: /usr/bin/x11/X(InitInput+0103) [0x45ea83]
5: /usr/bin/x11/X(main+0x337) [0x430e87]
6: /lib/libc.so.6(__libc_start_main+0xda) [0x2b415843d4ca]
7: /usr/bin/x11/X(FontFileCompleteXLFD+0xa2) [0x43029a]

Fatal server error:
Caught signal 11. Server aborting

XIO: Fatal error 104 (Connection reset by peer) on X server ":0.0"
after 0 requests (0 known processes) with 0 events remaining

=============================================

I also did look at the log. There was nothing in there prefixed with (EE) which would indicate an error.

Does any of this help?

Again, thanks in advance
 
Old 02-18-2008, 07:33 PM   #4
rickh
Senior Member
 
Registered: May 2004
Location: Albuquerque, NM USA
Distribution: Debian-Lenny/Sid 32/64 Desktop: Generic AMD64-EVGA 680i Laptop: Generic Intel SIS-AC97
Posts: 4,250

Rep: Reputation: 61
# aptitude keep-all
# aptitude install xserver-xorg xorg kde-core

If that doesn't change anything, ...

# dpkg-reconfigure xserver-xorg

Depending on your video card, pick an xorg driver ... nv, ati, vesa, sis, etc

Last edited by rickh; 02-18-2008 at 07:34 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
debian amd64 etch and Intel EFI kpachopoulos Debian 1 09-28-2007 10:11 AM
Debian Etch i386 not keeping time, AMD64 does mhansen Debian 3 03-20-2007 09:21 PM
New Debian AMD64 Etch install - need help to run Quake 4 demo BigVig Debian 1 10-15-2006 03:24 PM
Installed Debian AMD64 Etch and missing packages occurs shrabok Debian 1 09-05-2006 01:19 AM
Debian AMD64 Etch cannot install KDE shrabok Debian 4 07-07-2006 11:10 PM


All times are GMT -5. The time now is 06:35 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration