LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 08-04-2010, 06:14 AM   #1
EarlInLevelland
LQ Newbie
 
Registered: Jul 2010
Location: Levelland, Texas
Distribution: Mint 13
Posts: 12

Rep: Reputation: 1
Login Keyring?


Hello,

I am nothing if not a Linux newbie, so hope I'm asking this in the right place. I'm using Ubuntu 10.04 LTS and recently started getting a pop-up similar to the following at every boot up:
-----------------------
Login keyring failed
Your login keyring did not succeed.
Enter login keyring here: _______________
-----------------------
That's not [exactly] what it says, but very similar. I should probably add that I have not set up any different 'user profiles' or whatever they're called, but am the only one using this PC...at least, at the present time. Again, this only started a couple of weeks ago and I don't know what I did to start it nor what to do to stop it. I guess it's not extremely painful to have to type my password in every time, but a PITA nevertheless. Any ideas? TIA!

<>< Earl
 
Click here to see the post LQ members have rated as the most helpful post in this thread.
Old 08-04-2010, 12:50 PM   #2
jasohl
Member
 
Registered: Oct 2006
Location: Seattle, Washington
Distribution: Gentoo, LinuxMint, Arch Linux
Posts: 99

Rep: Reputation: 18
Can you provide [exactly] what it says? And does this happen after you log in or before? Or does your account auto-login?
If its the Gnome keyring, it stores passwords, like for wireless and such. You setup a master password which secures the others.
I have seen similar situations when people use auto-login and have wireless setup. In those cases when you start up, wireless tries to connect. The keyring then asks your "permission" to use the wireless password.
 
Old 08-04-2010, 01:17 PM   #3
tealio
LQ Newbie
 
Registered: Aug 2010
Location: Atlanta, GA
Distribution: Ubuntu 10.04
Posts: 23

Rep: Reputation: 18
Click 'Applications'
Click 'Accessories'
Click 'Passwords and Encryption Keys'

-or-

Press 'ALT-F2'
Then type in 'seahorse'

-then-

Right click 'Passwords: login'
Select 'Change Password'

-then-

Change the password to blank. This will allow autologin to use your wireless password, start remote desktop, etc.
 
2 members found this post helpful.
Old 08-04-2010, 01:29 PM   #4
tredegar
LQ 5k Club
 
Registered: May 2003
Location: London, UK
Distribution: Debian "Jessie"
Posts: 6,017

Rep: Reputation: 369Reputation: 369Reputation: 369Reputation: 369
Earl,

You can set things back to "normal" by going to /home/earl/.gnome2/keyrings and deleting the file default.keyring

Notice the "dot" in the filepath: the .gnome2 directory is "hidden". Go to Places... Home then press <CTRL><h> to make the hidden directories be listed.

I hate these keyring managers (KDE has "wallet") and if I cannot uninstall them, I found that if you enter a blank password, they generally go away after asking "Shall I store the password somewhere?".
If I get burgled I'll have to phone my ISP and set things up again.
 
1 members found this post helpful.
Old 08-06-2010, 12:41 PM   #5
EarlInLevelland
LQ Newbie
 
Registered: Jul 2010
Location: Levelland, Texas
Distribution: Mint 13
Posts: 12

Original Poster
Rep: Reputation: 1
Quote:
Originally Posted by jasohl View Post
Can you provide [exactly] what it says? And does this happen after you log in or before? Or does your account auto-login?
If its the Gnome keyring, it stores passwords, like for wireless and such. You setup a master password which secures the others.
I have seen similar situations when people use auto-login and have wireless setup. In those cases when you start up, wireless tries to connect. The keyring then asks your "permission" to use the wireless password.
I wrote it down this time. The title bar of the window says "Unlock Login Keyring"

First line says "Enter password to unlock your login keyring."

Second line says "The login keyring did not get unlocked when you logged into your computer."

Last line says "Password: ___________________"
Two buttons underneath this say "Cancel" and "OK"

I enter the password I had to set up when installing Ubuntu and press OK. Then everything's fine.
 
Old 08-06-2010, 12:54 PM   #6
EarlInLevelland
LQ Newbie
 
Registered: Jul 2010
Location: Levelland, Texas
Distribution: Mint 13
Posts: 12

Original Poster
Rep: Reputation: 1
Thanks Tealio. I don't know what I just did, but following your steps below appear to have solved the problem. I just rebooted and the pesky box didn't pop up. Those things which I understand about Linux and Ubuntu are still far outweighed by those which I don't. :-) Now to figure out how to mark this problem "Solved"...


Quote:
Originally Posted by tealio View Post
Click 'Applications'
Click 'Accessories'
Click 'Passwords and Encryption Keys'

-or-

Press 'ALT-F2'
Then type in 'seahorse'

-then-

Right click 'Passwords: login'
Select 'Change Password'

-then-

Change the password to blank. This will allow autologin to use your wireless password, start remote desktop, etc.
 
Old 01-20-2012, 03:44 PM   #7
chandramani_yadav
Member
 
Registered: Jan 2007
Location: Vienna
Distribution: Redhat
Posts: 47

Rep: Reputation: 19
i don't see it as solution because it saves password clear text which is security risk.
 
Old 05-16-2012, 11:48 PM   #8
dizzydan77
LQ Newbie
 
Registered: May 2012
Posts: 1

Rep: Reputation: Disabled
Workaround for Login Keyring on auto login

Another way to get around the 'unlocked key ring' request, without compromising other stored passwords is to create an additional Password Key ring just for the VNC remote login password.

Instead of removing the password for the main Key ring, create a new "Password Keyring" by opening "Passwords and Encryption Keys" from "Applications > Accessories".

Select "File > New..." and click "Password Keyring".
Now just add the VNC Key ring entry to the new Password Keyring folder. This should be something like vino.local:5900. Once you've added the entry, you will need to copy additional attributes into it. The best way to do this, I found, was to copy them from your original keyring file onto the new one you've created. These are located in your home directory under ".gnome\keyrings\*.keyring". Make sure you removed the password for your initial Keyring in "Passwords and Encryption Keys" otherwise you will not be able to read it's contents. Once open, just copy the additional attributes for the 'vino.local:5900' entry (or whatever entry VNC is name under). Add them to the keyring file you just created.

Once this is done, you can go back and assign a password to your main keyring to encrypt its contents again. Do not assign any password to the key ring folder you just created.

By leaving this entry open, the system will be able to retrieve the VNC password when you attempt to login remotely. Once you are in, you can then manually unlock the secure Key ring by right-clicking on it and clicking "unlock".

You can add any entries to this unsecured Keyring folder for anything that is giving you problems on auto-login (wireless network, etc.) while maintaining all other keys secure.

Hope this helps, and if anyone has found a better workaround or any vulnerability in this approach, please feel free to point this out.

dan
 
Old 09-19-2012, 03:12 AM   #9
Weatherlawyer
LQ Newbie
 
Registered: Jul 2012
Location: Earth
Distribution: Zorin
Posts: 8

Rep: Reputation: Disabled
Quote:
Originally Posted by dizzydan77 View Post
... and if anyone has found a better workaround or any vulnerability in this approach, please feel free to point this out.
I have this problem but only with Chrome.
I think itcame as the default browser with this OS (Zorin) which says a lot about Google and security. I dont use it much as I think Googles shouldn't be shaping my searches or storing my search patterns.

And I don't trust them with much else for that matter.

So why is it only happening in Chrome?
 
  


Reply

Tags
autologin, gnome, keyring, seahorse, ubuntu


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
keyring jmaloy Debian 4 08-29-2014 01:01 PM
GNOME - Automatic Login/Keyring Patz2009 Linux - Software 0 08-24-2009 01:11 PM
Keyring annoyances for wifi access after gdm login Cyberman Debian 1 07-18-2009 09:24 AM
Unlock keyring at login for NetworkManager and wireless in KDE michael.guerrero Linux - Software 0 05-08-2009 02:50 PM
keyring. What is it ? Mike Davies Linux - Newbie 7 09-28-2008 09:51 PM


All times are GMT -5. The time now is 09:02 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration