LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 05-31-2007, 02:22 PM   #1
Greebstreebling
Member
 
Registered: Nov 2005
Location: Swansea, Wales, UK
Distribution: debian
Posts: 235

Rep: Reputation: 30
Smile login as root using kde


Dear folks I have just started to use KDE desktop and it's all been working fine, I've configured it etc, but today I needed to login as root and it wouldn't let me.

Formerly when I used Gnome I did not have this problem; can I configure kde to let me in as root?

Thanks
Greeb
 
Old 05-31-2007, 02:36 PM   #2
pljvaldez
LQ Guru
 
Registered: Dec 2005
Location: Somewhere on the String
Distribution: Debian Wheezy (x86)
Posts: 6,094

Rep: Reputation: 271Reputation: 271Reputation: 271
I think you need to modify the settings in kdm (or gdm) to allow root login. By default Debian disallows gui root logins.
 
Old 05-31-2007, 02:56 PM   #3
bigjohn
Senior Member
 
Registered: Jun 2002
Location: UK .
Distribution: *buntu (usually Kubuntu)
Posts: 2,682
Blog Entries: 9

Rep: Reputation: 45
Quote:
Originally Posted by Greebstreebling
Dear folks I have just started to use KDE desktop and it's all been working fine, I've configured it etc, but today I needed to login as root and it wouldn't let me.

Formerly when I used Gnome I did not have this problem; can I configure kde to let me in as root?

Thanks
Greeb
Just checked this out, the line that I had to modify is in the /etc/kde3/kdm/kdmrc file (well it is in this debian sid based sidux I'm using) that then you need to find the line that says "allow Root login=false" and change the false to true.

I tried just logging out then back in, but it didn't change my login page options so I logged out of the system and restarted the PC, it showed up Ok then.

So I'm presuming that it should also work for you

regards

John
 
Old 06-01-2007, 11:59 AM   #4
Red Barchetta
Member
 
Registered: Mar 2007
Distribution: Mandriva Free
Posts: 41

Rep: Reputation: 15
There is no real reason to HAVE to login to a GUI desktop as the root user, however, there are times when I myself find it easier to. But I would STRONGLY advise not using KDE as the root user (I use Gnome if I really want a graphic desktop as root).
But if you are using the KDE login screen, to allow this, the file to alter is kdmrc
The easiest way I have found to alter that file is, login as any user that is allowed to use the su command from a terminal.
1.) open a terminal window, and navigate to the path containing the file kdmrc with the cd command.

2.) Issue the command su

3.) command kwrite kdmrc

What you are looking for is AllowRootLogin= set that to true, and save the file.
That should do it....
 
Old 06-01-2007, 03:23 PM   #5
bigjohn
Senior Member
 
Registered: Jun 2002
Location: UK .
Distribution: *buntu (usually Kubuntu)
Posts: 2,682
Blog Entries: 9

Rep: Reputation: 45
Quote:
Originally Posted by Red Barchetta
There is no real reason to HAVE to login to a GUI desktop as the root user, however, there are times when I myself find it easier to. But I would STRONGLY advise not using KDE as the root user (I use Gnome if I really want a graphic desktop as root).
But if you are using the KDE login screen, to allow this, the file to alter is kdmrc
The easiest way I have found to alter that file is, login as any user that is allowed to use the su command from a terminal.
1.) open a terminal window, and navigate to the path containing the file kdmrc with the cd command.

2.) Issue the command su

3.) command kwrite kdmrc

What you are looking for is AllowRootLogin= set that to true, and save the file.
That should do it....
Well since my recent hard drive failure, it's the first time I haven't bothered to have a graphical root login i.e. I always used to get it with KDE, but since ?????? the inception of kde 3.4 (though it might have been 3.3) when it was disabled by default, I ended up changing "it" to allow.

This time I've changed it back to disabled, though I'd have thought that the only "real reason" necessary is that Greebstreebling "wants" that facility. Hell, afterall, linux _IS_ about choice, though I can see the "plus" side of your arguement.

These days I just start konqueror or whatever in "root mode", so I've found that it defeats the point of having the whole of graphical KDE available to root. I should point out that this was a habit of mine, a throw back to when I had windows - I felt more comfortable doing root stuff in a GUI, though I don't feel that because I now know how to get round it, that it's necessarily a "better" way of doing any necessary root stuff.

Hence IMO is one of those "tomaytoes/tomartoes" things!

regards

John
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
root login via kde login screen linuxmandrake Linux - Newbie 2 10-09-2005 12:30 PM
KDE 3.4 no root login!? lefty.crupps SUSE / openSUSE 2 04-28-2005 04:47 AM
cant login root after kde 3.4 update YellowFin Linux - Software 7 04-10-2005 04:32 PM
kde 3.3 no root login efi360 Linux - Software 9 01-15-2005 08:32 PM
KDE: cannot login as root claudiu_t Linux - General 1 01-26-2004 01:55 PM


All times are GMT -5. The time now is 02:16 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration