LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 07-18-2003, 05:40 PM   #1
badboyz2525
LQ Newbie
 
Registered: Jul 2003
Location: utah
Distribution: debian
Posts: 6

Rep: Reputation: 0
Log Out & sound server


i've had debian 3.0 rev1 loaded on my computer for a few days now and seems to be working fine. with the exception of the sound server.

message:
sound server informational message

error while initializing the sound server
device / dev/dsp cant be opened (permission denied)

the sound server will continue,useing the null output device

Is this a package that is not working or my sound card? and how to fix?

i have only installed the basic packages including x server,sound server,file server,unix server web server,and c+

dos'nt look like i have any multimedia packages installed

in menu: preferences/sound/ none of the packages seem to put out any audio


2nd

Log Out
If i log out from the kde desktop it takes me to a log in screen and dos'nt give me a option to shut down. If i turn off my comp.its an unclean mounting

iIf I go to the root konsole and poweroff with -i or -f i loose all my preferences in kde.

Log off HOW?

Thanks
Mark

Last edited by badboyz2525; 07-18-2003 at 06:58 PM.
 
Old 07-26-2003, 05:56 AM   #2
MasterC
LQ Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 64
2. I've got no idea...

1. This is the normal message when a user doesn't have permissions to access the soundcard. There are a multitude of options on setting up permissions for access, and I prefer the one that seems most secure to me.

First up:
create a group called sound (as root):
groupadd sound
Add your user to that group:
usermod -G sound (I believe, see man usermod for more info)
And then own the device to that group:
chown /dev/dsp /dev/mixer /dev/audio root.sound
And make sure group sound has permissions to use the device (I believe w and x are what they need, this is all from memory, my appologies if you have to tinker a bit ):
chmod 730 /dev/dsp /dev/mixer /dev/audio

And test. See if it works now.

If not, you may have to tinker with the permissions a bit, it might be w and x, or if you aren't too concerned you could always:
chmod 770
Instead

Cool
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
How to log conversation between server in /var/log/messages? juris Linux - Software 1 11-23-2004 10:54 AM
Xandros delux 2.0 When I try to run Sound server Control ,Media Player & Sound Record Jesta Linux - Distributions 0 05-15-2004 10:35 PM
SNort&log JuBeC Linux - Security 1 05-04-2004 10:33 PM
kde-3.1.4 & artswrapper & no ac3-sound passtrough BlinkEye Linux - Software 0 12-05-2003 05:00 PM
xine1_rc2 & kxine source install problems in RH 9.0 & SB live found but no sound Dominik Linux - Software 2 12-02-2003 04:15 AM


All times are GMT -5. The time now is 11:03 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration