LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-22-2008, 01:05 PM   #1
WillingToLikeLinux
Member
 
Registered: Sep 2008
Posts: 90

Rep: Reputation: 16
lock symbol on document directory (Ubuntu)


My ubuntu has a lock symbol on the document directory. Is there any way to get rid of this?
 
Old 10-22-2008, 01:07 PM   #2
WillingToLikeLinux
Member
 
Registered: Sep 2008
Posts: 90

Original Poster
Rep: Reputation: 16
And I also can't add a document file I made via OpenOffice in the Documents directory. I have to put it in the Desktop directory for now.
 
Old 10-22-2008, 01:11 PM   #3
forrestt
Senior Member
 
Registered: Mar 2004
Location: Cary, NC, USA
Distribution: Fedora, Kubuntu, RedHat, CentOS, SuSe
Posts: 1,288

Rep: Reputation: 99
Run "ll -d ~/Documents" and post the output back here.

Let us know,

Forrest
 
Old 10-22-2008, 01:36 PM   #4
farslayer
LQ Guru
 
Registered: Oct 2005
Location: Willoughby, Ohio
Distribution: linuxdebian
Posts: 7,232
Blog Entries: 5

Rep: Reputation: 190Reputation: 190
forrestt, what are those first two characters in your command ?

I can see the permissions info with
Code:
username@it-etch:~$ ls -dl ~/documents
drwxr-xr-x 9 username username 4096 2008-10-16 10:59 /home/username/documents
Your command is new to me, man isn't providing any clues or entry, and the command fails with a bash error, so I'm curious.

thanks
 
Old 10-22-2008, 01:37 PM   #5
jay73
LQ Guru
 
Registered: Nov 2006
Location: Belgium
Distribution: Ubuntu 11.04, Debian testing
Posts: 5,019

Rep: Reputation: 130Reputation: 130
sudo chown -R username.username directory
 
Old 10-22-2008, 02:14 PM   #6
forrestt
Senior Member
 
Registered: Mar 2004
Location: Cary, NC, USA
Distribution: Fedora, Kubuntu, RedHat, CentOS, SuSe
Posts: 1,288

Rep: Reputation: 99
Sorry, ll is an alias to "ls -l". I thought it was standard in Ubuntu but perhaps not. Anyway, the permissions on that directory look fine. If the file you are trying to save is already there and you are trying to overwrite it, then the permissions of that file will also need to allow you to write to it. Now, you have stated "documents" directory and "Documents" directory. There is a difference. Jay73's command should fix your problem, but it may need to be:

sudo chown -R username.username Directory

HTH

Forrest
 
Old 10-22-2008, 02:33 PM   #7
farslayer
LQ Guru
 
Registered: Oct 2005
Location: Willoughby, Ohio
Distribution: linuxdebian
Posts: 7,232
Blog Entries: 5

Rep: Reputation: 190Reputation: 190
forest I was not the OP. I was just asking about your use of ll, which being an alias makes sense. (it may be standard in Ubuntu, I don't know I run Debian)

we just need to see the output from WillingToLikeLinux to see if HIS permissions are correct..

Thanks for clearing up my query though
 
Old 10-22-2008, 02:38 PM   #8
forrestt
Senior Member
 
Registered: Mar 2004
Location: Cary, NC, USA
Distribution: Fedora, Kubuntu, RedHat, CentOS, SuSe
Posts: 1,288

Rep: Reputation: 99
OK, I think I need more coffee. That or new eyes.
 
Old 10-22-2008, 07:20 PM   #9
WillingToLikeLinux
Member
 
Registered: Sep 2008
Posts: 90

Original Poster
Rep: Reputation: 16
I'm still not used to terminals. Though I'm still learning it right now.

Can we do this via GUI? All I know is that the "folder access" in the "owner" section is access files. That's all I can say.
 
Old 10-22-2008, 07:23 PM   #10
jay73
LQ Guru
 
Registered: Nov 2006
Location: Belgium
Distribution: Ubuntu 11.04, Debian testing
Posts: 5,019

Rep: Reputation: 130Reputation: 130
Try this: type sudo nautilus. That should give you a GUI file manager with administrator powers.
 
Old 10-22-2008, 07:47 PM   #11
norobro
Member
 
Registered: Feb 2006
Distribution: Debian Sid
Posts: 647

Rep: Reputation: 249Reputation: 249Reputation: 249
Farslayer,

Not trying to be a smart a**, but Debian has aliases ( among them is ll ) in /etc/skel/.bashrc:
Code:
# some more ls aliases
#alias ll='ls -l'
#alias la='ls -A'
#alias l='ls -CF'
As you can see, initially they are commented out.
 
Old 10-22-2008, 08:07 PM   #12
WillingToLikeLinux
Member
 
Registered: Sep 2008
Posts: 90

Original Poster
Rep: Reputation: 16
Quote:
Originally Posted by jay73 View Post
Try this: type sudo nautilus. That should give you a GUI file manager with administrator powers.
It came out like this:

Quote:
Initializing nautilus-share extension
seahorse nautilus module initialized

** (nautilus:6665): WARNING **: Unable to add monitor: Operation not supported
Nautilus-Share-Message: Called "net usershare info" but it failed: 'net usershare' returned error 255: net usershare: cannot open usershare directory /var/lib/samba/usershares. Error No such file or directory
Please ask your system administrator to enable user sharing.
Somehow I think I'm doing this wrong in the first place.
 
Old 10-22-2008, 09:21 PM   #13
jay73
LQ Guru
 
Registered: Nov 2006
Location: Belgium
Distribution: Ubuntu 11.04, Debian testing
Posts: 5,019

Rep: Reputation: 130Reputation: 130
Same message here - but it does pop up the root file browser window...
 
Old 10-22-2008, 11:05 PM   #14
farslayer
LQ Guru
 
Registered: Oct 2005
Location: Willoughby, Ohio
Distribution: linuxdebian
Posts: 7,232
Blog Entries: 5

Rep: Reputation: 190Reputation: 190
Quote:
Originally Posted by norobro View Post
Farslayer,

Not trying to be a smart a**, but Debian has aliases ( among them is ll ) in /etc/skel/.bashrc:
Code:
# some more ls aliases
#alias ll='ls -l'
#alias la='ls -A'
#alias l='ls -CF'
As you can see, initially they are commented out.
I'm familiar with what an alias is used for, so once it was stated that is what his command was, it all became clear. but like you said they are commented out by default in Debian and I just type those commands long form, so Im not used to seeing ll as a command.

Thanks for the heads up though.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Unable to lock the administration directory (Ubuntu) Braynid Linux - Newbie 2 12-27-2010 10:46 PM
Konqueror freezes when I try to access user document directory. GlennsPref Mandriva 7 02-18-2008 12:17 PM
Ubuntu Symbol bjb_nyj101 Ubuntu 8 05-02-2007 02:16 AM
Ubuntu App Symbol bjb_nyj101 Linux - Desktop 1 04-29-2007 12:39 PM
how do i create a document, then a directory and save the document in it. jtdodge Linux - Newbie 9 06-15-2005 11:03 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 12:39 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration