LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-28-2006, 01:00 AM   #1
itz2000
Member
 
Registered: Jul 2005
Distribution: Fedora fc4, fc7, Mandrake 10.1, mandriva06, suse 9.1, Slackware 10.2, 11.0, 12.0,1,2 (Current)]
Posts: 732

Rep: Reputation: 30
lock session via terminal?


How do I lock the session (so the Screensaver + password will appear) via terminal?
My current option is to click on the MandrivaStart button --> Lock Session, but I'd like to know how can I make such thing via terminal!


Thanks!
 
Old 03-28-2006, 02:30 AM   #2
heema
Senior Member
 
Registered: Sep 2003
Location: Egypt
Distribution: Arch
Posts: 1,528

Rep: Reputation: 47
try
xscreensaver-command -lock
 
Old 03-28-2006, 04:22 AM   #3
itz2000
Member
 
Registered: Jul 2005
Distribution: Fedora fc4, fc7, Mandrake 10.1, mandriva06, suse 9.1, Slackware 10.2, 11.0, 12.0,1,2 (Current)]
Posts: 732

Original Poster
Rep: Reputation: 30
Code:
[zuki@nfs ~]$ xscreensaver-command -lock
xscreensaver-command: no screensaver is running on display :0.0
so it's possible but it doesn't work, what shall I do now?
 
Old 03-28-2006, 05:07 AM   #4
ethics
Senior Member
 
Registered: Apr 2005
Location: London
Distribution: Arch - Latest
Posts: 1,522

Rep: Reputation: 45
run xscreensaver

See if the screensaver daemon is running, if not start it, pick a screensaver
 
Old 03-28-2006, 07:26 AM   #5
itz2000
Member
 
Registered: Jul 2005
Distribution: Fedora fc4, fc7, Mandrake 10.1, mandriva06, suse 9.1, Slackware 10.2, 11.0, 12.0,1,2 (Current)]
Posts: 732

Original Poster
Rep: Reputation: 30
Thanks! it works now!
 
Old 03-28-2006, 08:01 AM   #6
ethics
Senior Member
 
Registered: Apr 2005
Location: London
Distribution: Arch - Latest
Posts: 1,522

Rep: Reputation: 45
You may need to add a startup script that enables xscreensaver every bootup, i did.
 
Old 03-28-2006, 10:16 AM   #7
itz2000
Member
 
Registered: Jul 2005
Distribution: Fedora fc4, fc7, Mandrake 10.1, mandriva06, suse 9.1, Slackware 10.2, 11.0, 12.0,1,2 (Current)]
Posts: 732

Original Poster
Rep: Reputation: 30
how do I do that?
 
Old 04-06-2006, 12:01 PM   #8
itz2000
Member
 
Registered: Jul 2005
Distribution: Fedora fc4, fc7, Mandrake 10.1, mandriva06, suse 9.1, Slackware 10.2, 11.0, 12.0,1,2 (Current)]
Posts: 732

Original Poster
Rep: Reputation: 30
? what shall I write to enable xscreensaver?

now, I do every boot up

xscreensaver
then I click on Settings --> File --> Restart Deamon --> File --> Quit

then I can do
xscreensaver-command -lock

other solution maybe?

Thanks!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Switching back to the Mandrake 9.1 desktop from terminal rdesktop terminal session marc218 Linux - General 6 02-08-2007 02:45 PM
User Session Lock dutch1918 SUSE / openSUSE 3 05-04-2006 04:01 PM
Session will not lock Xswitch SUSE / openSUSE 3 01-31-2006 05:07 PM
KDE 3.3.2 lock session pete123 Linux - Software 0 12-26-2004 12:38 PM
Lock the current terminal session? kipbenson4 Linux - Newbie 1 08-14-2003 09:04 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 11:07 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration