LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-07-2008, 12:16 AM   #31
gankoji
Member
 
Registered: Nov 2007
Location: Southern California
Distribution: Slackware-13.0 x86_64, Slackware 12.2, slackware64-current
Posts: 225

Rep: Reputation: 35

Sorry, I meant lampp stopssl. After you do that, SSL should be stopped and http:// should be working. but since https:// doesn't even work now, stopping SSL isn't going to fix your problem. Have you tried installing XAMPP as root as someone mentioned earlier? I didn't see your response to that.

Your index page that loads after a fresh install of XAMPP has a meta tag that redirects the browser to the /opt/lampp/htdocs/xampp/ folder and pages. The problem is not with the pages that are in that directory. It more than likely has something to do with your firewall config.

Please post the contents of your /etc/hosts.allow and /etc/hosts.deny files .
 
Old 02-07-2008, 01:30 AM   #32
billymayday
LQ Guru
 
Registered: Mar 2006
Location: Sydney, Australia
Distribution: Fedora, CentOS, OpenSuse, Slack, Gentoo, Debian, Arch, PCBSD
Posts: 6,678

Rep: Reputation: 122Reputation: 122
Steps as I do it

Code:
~$ su -
(password entered)
~# cd /usr/src
/usr/src# wget http://www.apachefriends.org/download.php?xampp-linux-1.6.5a.tar.gz
(wait for 52M download - I always download source to /usr/src - some people probably say it's the wrong spot
/usr/src# tar xvfz xampp-linux-1.6.5a.tar.gz -C /opt
(extraction happening)
/usr/src# /opt/lampp/lampp start
(start-up messages)
In firefox http://localhost
XAMPP screen asking for language - resolves to http://localhost/xampp/splash.php
Note that I can also navigate to https://localhost

So it seems to work fine for me

I haven't done a lot in Ubuntu, so my install should be pretty clean (you can probably tell I don't use it a lot)

I certainly have messages in my log files (/opt/lampp/logs - access_log and error_log are both there - the error_log has some ssl related stuff in it)

Last edited by billymayday; 02-07-2008 at 01:43 AM.
 
Old 02-07-2008, 01:39 AM   #33
SimbaSpirit
Member
 
Registered: Feb 2008
Posts: 109

Original Poster
Rep: Reputation: 15
we're on to page three, I don't feel so bad xD.

gankoji: stopping SSL then trying to resolve http://localhost did not work, was a good idea though.

Hosts.allow:

Quote:
# /etc/hosts.allow: list of hosts that are allowed to access the system.
# See the manual pages hosts_access(5) and hosts_options(5).
#
# Example: ALL: LOCAL @some_netgroup
# ALL: .foobar.edu EXCEPT terminalserver.foobar.edu
#
# If you're going to protect the portmapper use the name "portmap" for the
# daemon name. Remember that you can only use the keyword "ALL" and IP
# addresses (NOT host or domain names) for the portmapper, as well as for
# rpc.mountd (the NFS mount daemon). See portmap(8) and rpc.mountd(8)
# for further information.
#
Hosts.deny: entirely commented, looks pretty benign

Quote:
# /etc/hosts.deny: list of hosts that are _not_ allowed to access the system.
# See the manual pages hosts_access(5) and hosts_options(5).
#
# Example: ALL: some.host.name, .some.domain
# ALL EXCEPT in.fingerd: other.host.name, .other.domain
#
# If you're going to protect the portmapper use the name "portmap" for the
# daemon name. Remember that you can only use the keyword "ALL" and IP
# addresses (NOT host or domain names) for the portmapper, as well as for
# rpc.mountd (the NFS mount daemon). See portmap(8) and rpc.mountd(8)
# for further information.
#
# The PARANOID wildcard matches any host whose name does not match its
# address.

# You may wish to enable this to ensure any programs that don't
# validate looked up hostnames still leave understandable logs. In past
# versions of Debian this has been the default.
# ALL: PARANOID
Billymayday, I swear you must have been right over my shoulder lol, thats exactly what I did.

I'm not sure exactly how you define splash screen, a big picture?

I can go to http://filefarm.selfip.com now (my addy), and it takes me to a login prompt, I supply the info and it takes me to a screen saying Wecome to XAMPP for Linux 1.6.5a!, with a side bar on the left:
Welcome
Status
Security
Documentation
Components

Demos

Tools:
phpMyAdmin
phpSQLiteAdmin
webalizer

so I can access that page, just not via localhost.

I just tried to ping localhost and 127.0.0.1 from terminal, both resulted in 100% packet loss, so I think that problem is more ubuntu related and less xampp related... That said, in what file is 127.0.0.1 mapped to localhost? Logic tells me resolv.conf, but that file simply says
Quote:
# generated by NetworkManager, do not edit!

nameserver 192.168.1.100
nameserver 209.165.131.12
nameserver 209.165.131.13
should I add "localhost 127.0.0.1" ?

Thanks for your continued help

-SS

(also just started a new thread: http://www.linuxquestions.org/questi...5/#post3048732)

Last edited by SimbaSpirit; 02-07-2008 at 01:43 AM.
 
Old 02-07-2008, 01:48 AM   #34
billymayday
LQ Guru
 
Registered: Mar 2006
Location: Sydney, Australia
Distribution: Fedora, CentOS, OpenSuse, Slack, Gentoo, Debian, Arch, PCBSD
Posts: 6,678

Rep: Reputation: 122Reputation: 122
Not resolv.conf - hosts
Can you please post the contents of /etc/hosts. It should look something like

Code:
bill@meriweather:~$ cat /etc/hosts
127.0.0.1 localhost
127.0.1.1 meriweather.deleted.com

# The following lines are desirable for IPv6 capable hosts
::1 ip6-localhost ip6-loopback
fe00::0 ip6-localnet
ff00::0 ip6-mcastprefix
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters
ff02::3 ip6-allhosts
127.0.0.1 meriweather # added by Apache Friends XAMPP
If you don't have the line

127.0.0.1 Localhost, add it, because this is neede by all sorts of networking functions

Otherwise, looks like you're cooking!

Last edited by billymayday; 02-07-2008 at 01:51 AM.
 
Old 02-07-2008, 02:04 AM   #35
SimbaSpirit
Member
 
Registered: Feb 2008
Posts: 109

Original Poster
Rep: Reputation: 15
It looks very similar yes:

Quote:
127.0.0.1 localhost
127.0.1.1 FileFarm

# The following lines are desirable for IPv6 capable hosts
::1 ip6-localhost ip6-loopback
fe00::0 ip6-localnet
ff00::0 ip6-mcastprefix
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters
ff02::3 ip6-allhosts
why is yours xyz.com? Will I need to do that to host webpages?

-SS
 
Old 02-07-2008, 02:10 AM   #36
SimbaSpirit
Member
 
Registered: Feb 2008
Posts: 109

Original Poster
Rep: Reputation: 15
Is there a file that supersedes the host file??
 
Old 02-07-2008, 02:22 AM   #37
billymayday
LQ Guru
 
Registered: Mar 2006
Location: Sydney, Australia
Distribution: Fedora, CentOS, OpenSuse, Slack, Gentoo, Debian, Arch, PCBSD
Posts: 6,678

Rep: Reputation: 122Reputation: 122
I really don't get this. If you are sitting at the machine that has xampp on it and type in localhost in the browser, it should be coming up. Only thing I can think of is the /etc/host.conf file, which should look something like

Code:
order hosts,bind
I have a domain (actually more than one), so my network is set up with a fully qualified domain name, so each machine is machine_name.domain.name. Some things (Postfix for example) expect a FQDN to function properly. I don't think it will matter for you hosting a site, but it's neater and you'll own the name anyway.

Perhaps your lack of a FQDN is why you don't have the same last line in your /etc/hosts. gethost or a similar function may not work properly without it.

Last edited by billymayday; 02-07-2008 at 02:24 AM.
 
Old 02-07-2008, 02:45 AM   #38
SimbaSpirit
Member
 
Registered: Feb 2008
Posts: 109

Original Poster
Rep: Reputation: 15
I'm glad I'm not the only one so perplexed by this.. I realize how painfully simple this is supposed to be.

/etc/host.conf:

Quote:
# The "order" line is only used by old versions of the C library.
order hosts,bind
multi on
Can you tell me the steps to setting up a FQDN? If I can get it to work I would very much prefer that over <me>.selfip.com... I'll likely be hosting my business pages on it and it would be much more professional to have <me>.<mybiz>.com

I'm starting to think it may be more of a programming error and less of a misconfiguration...
-SS
 
Old 02-07-2008, 04:10 AM   #39
billymayday
LQ Guru
 
Registered: Mar 2006
Location: Sydney, Australia
Distribution: Fedora, CentOS, OpenSuse, Slack, Gentoo, Debian, Arch, PCBSD
Posts: 6,678

Rep: Reputation: 122Reputation: 122
There are a few questions here really.

1. Buying a domain. This you can do through a variety of sources. Try going to http://www.internic.com/ and have a look at the registrar list.

2. Next, you will need to set your domain name up with a domain name server. I've used zoneedit.com and they will DNS up to 5 or so domains free. Seems to work well, and I know there are lots of other DNS services out there, only I haven't used them.

3. Setting the domain name on you machine. This I'm not sure how to do in Ubuntu (I've booted into something else now), but there's probably something like /etc/sysconfig/network as in RHEL

Maybe someone else knows the answer, or perhaps this will help

http://www.cyberciti.biz/faq/linux-s...-of-my-server/

Note that Ubuntu is derived from Debian, so I'd gues the Debian form would work.

Question before you do this. Do you have a static IP?
 
Old 02-07-2008, 11:10 AM   #40
SimbaSpirit
Member
 
Registered: Feb 2008
Posts: 109

Original Poster
Rep: Reputation: 15
Yes I do have a static IP, and I guess I'll wait til I get everything working before I look into that... it seems every time I turn it on there's a new problem...
 
Old 02-08-2008, 12:16 AM   #41
SimbaSpirit
Member
 
Registered: Feb 2008
Posts: 109

Original Poster
Rep: Reputation: 15
Did the testing on your ubuntu box reveal anything?
 
Old 02-08-2008, 01:21 AM   #42
billymayday
LQ Guru
 
Registered: Mar 2006
Location: Sydney, Australia
Distribution: Fedora, CentOS, OpenSuse, Slack, Gentoo, Debian, Arch, PCBSD
Posts: 6,678

Rep: Reputation: 122Reputation: 122
Not quite sure what you mean. As I said before, everything seemed to work fine for me.

My hunch if that without having set a FQDN for your machine (it doesn't have to be an external domain name) that XAMPP has had a bit of difficulty installing. Note that your setup seems to be working fine except that you have to enter your hostname rather than localhost into you browser.

Are you expecting it to do something more?
 
Old 02-08-2008, 05:10 AM   #43
SimbaSpirit
Member
 
Registered: Feb 2008
Posts: 109

Original Poster
Rep: Reputation: 15
In the end I was hoping to have a file server / webpage hoster / email server...

There is no free alternative for an FQDN then? It seems like you wouldn't need to go that far just to set up a file server...

Can you find a URL to a tutorial for the FQDN? I'd rather someone who knew what they were talking about find one lol
 
Old 02-08-2008, 05:16 AM   #44
billymayday
LQ Guru
 
Registered: Mar 2006
Location: Sydney, Australia
Distribution: Fedora, CentOS, OpenSuse, Slack, Gentoo, Debian, Arch, PCBSD
Posts: 6,678

Rep: Reputation: 122Reputation: 122
You can call your machine what you want - mypc.example.com - if you want. WOn't work from the net (example.com) but will work fine for a local network. Even if you buy a domain name, it doesn't have to match you server's name
 
Old 02-09-2008, 12:29 AM   #45
SimbaSpirit
Member
 
Registered: Feb 2008
Posts: 109

Original Poster
Rep: Reputation: 15
Alright if you go to http://pride.selfip.com it'll webhop you to ftp://filefarm.selfip.com, which will be handled by proftpd.

Does http://filefarm.selfip.com count as a FQDN?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
My hostname is NOT resolving correctly cucolin@ Linux - Networking 5 08-29-2007 10:22 AM
Message from syslogd@localhost localhost kernel: Disabling IRQ #21 ylts Linux - Hardware 0 02-26-2005 08:01 AM
howto map localhost correctly? computerdaves Fedora 10 02-08-2005 03:54 PM
network up, but not resolving correctly. BrianK Linux - Networking 8 07-06-2004 02:37 PM
/etc/hosts resolving before DNS resolving ? markraem Linux - Networking 4 11-02-2003 04:54 AM


All times are GMT -5. The time now is 03:05 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration