LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-05-2008, 03:27 PM   #16
billymayday
LQ Guru
 
Registered: Mar 2006
Location: Sydney, Australia
Distribution: Fedora, CentOS, OpenSuse, Slack, Gentoo, Debian, Arch, PCBSD
Posts: 6,678

Rep: Reputation: 122Reputation: 122

I don't like suggesting reinstallation - it doesn't necessarily fix problems.

There must be something in the logs somewhere.


Try to access http://localhost again.

From a terminla, go to /var/logs (I assume that's the ubuntu location)

do

ls -l

and see what's been modified since you tried to access xampp ( you may have your logs in a subdirectory)

If anything's changed, use

tail /var/log/logfile_name

Also, try

ps aux | grep httpd

and it should tell you what configutation file apache is using


See how you go

Edit:

Double check tail /opt/lampp/logs/

Last edited by billymayday; 02-05-2008 at 03:37 PM.
 
Old 02-05-2008, 03:49 PM   #17
LinuxCrayon
Member
 
Registered: Nov 2007
Location: Georgia, USA
Distribution: FreeBSD
Posts: 274

Rep: Reputation: 31
Another thing that hasn't been mentioned is the need to restart services. If you've made changes to configuration files, you typically need to restart the applicable service. I'm not sure if this has any bearing to your situation or not.

That aside, billymayday's advice is excellent.
 
Old 02-06-2008, 02:46 AM   #18
SimbaSpirit
Member
 
Registered: Feb 2008
Posts: 109

Original Poster
Rep: Reputation: 15
Hey thanks for your replies. Unfortunately I kept pressing f5 to look for responses and didn't notice it continued on to page 2. I already reinstalled ubuntu, its updating now. I will reinstall XAMPP and see if the problem reoccurs, if it does I'll have the logs billy suggested tonight or early tomorrow.
 
Old 02-06-2008, 03:27 AM   #19
SimbaSpirit
Member
 
Registered: Feb 2008
Posts: 109

Original Poster
Rep: Reputation: 15
This post should seriously narrow down possibilities.
This is ALL I have done:

Install Ubuntu 7.10
Install updates (automated - I didn't screw with anything)
Enable nvidia driver
edit /boot/grub/menu.lst to allow me to boot to xp
edit /etc/network/interfaces to give me a static IP (192.168.1.100)
Set password for root account.
Install XAMPP following the instructions as per http://www.apachefriends.org/en/xampp-linux.html

So I guess it's either a flaw in design, or in the instructions.
http://localhost, http://localhost/xampp, https://localhost, http://127.0.0.1, and 127.0.0.1 all time out.

Now for the logs you requested:

I went to /var/log and typed ls -l, then tried to access http://localhost then typed ls -l again, and there was no changes, no new entries.

ps aux | grep httpd returned:

Quote:
root 8762 0.0 1.1 27100 15420 ? Ss 00:13 0:00 /opt/lampp/bin/httpd -k start -DSSL -DPHP5
nobody 8833 0.0 0.8 24324 10996 ? S 00:13 0:00 /opt/lampp/bin/httpd -k start -DSSL -DPHP5
nobody 8834 0.0 0.9 27100 12604 ? S 00:13 0:00 /opt/lampp/bin/httpd -k start -DSSL -DPHP5
nobody 8835 0.0 0.9 27100 12584 ? S 00:13 0:00 /opt/lampp/bin/httpd -k start -DSSL -DPHP5
nobody 8836 0.0 0.9 27100 12584 ? S 00:13 0:00 /opt/lampp/bin/httpd -k start -DSSL -DPHP5
nobody 8837 0.0 0.9 27100 12584 ? S 00:13 0:00 /opt/lampp/bin/httpd -k start -DSSL -DPHP5
nobody 8838 0.0 0.9 27100 12584 ? S 00:13 0:00 /opt/lampp/bin/httpd -k start -DSSL -DPHP5
simba 8926 0.0 0.0 2972 756 pts/0 R+ 00:25 0:00 grep httpd

Last edited by SimbaSpirit; 02-06-2008 at 03:28 AM.
 
Old 02-06-2008, 05:10 AM   #20
billymayday
LQ Guru
 
Registered: Mar 2006
Location: Sydney, Australia
Distribution: Fedora, CentOS, OpenSuse, Slack, Gentoo, Debian, Arch, PCBSD
Posts: 6,678

Rep: Reputation: 122Reputation: 122
Correct me if I'm wrong here, but if you are doing this in Ubuntu, and you get to the part in the instructions that say

Code:
Step 2: Installation
After downloading simply type in the following commands:

   1. Go to a Linux shell and login as the system administrator root:

      su

   2. Extract the downloaded archive file to /opt:

      tar xvfz xampp-linux-1.6.5a.tar.gz -C /opt

      Warning: Please use only this command to install XAMPP. DON'T use any Microsoft Windows tools to extract the archive, it won't work.

      Warning 2: already installed XAMPP versions get overwritten by this command.

That's all. XAMPP is now installed below the /opt/lampp directory.
I'm pretty sure that Ubuntu disables the root account by default and only allows you to use sudo and not su into the root account.

This would mean that you installed everything as a user other than root.

What did happen when you typed "su"?

Now (again, assuming I have a clue, which frankly is a big assumption), you would need to take this into account and instead type

Code:
   1. Go to a Linux shell and login as the system administrator root:

      su (Don't bother - shouldn't work )

   2. Extract the downloaded archive file to /opt:

      sudo tar xvfz xampp-linux-1.6.5a.tar.gz -C /opt (note the addition of sudo at start)

      
That's all. XAMPP is now installed below the /opt/lampp directory.
Give that a go

Anyone more familiar with Ubuntu, please comment

Last edited by billymayday; 02-06-2008 at 05:20 AM.
 
Old 02-06-2008, 05:17 AM   #21
billymayday
LQ Guru
 
Registered: Mar 2006
Location: Sydney, Australia
Distribution: Fedora, CentOS, OpenSuse, Slack, Gentoo, Debian, Arch, PCBSD
Posts: 6,678

Rep: Reputation: 122Reputation: 122
Actually, can you also post the output of

ls -l /opt

and

ls -l /opt/lampp
 
Old 02-06-2008, 05:19 AM   #22
billymayday
LQ Guru
 
Registered: Mar 2006
Location: Sydney, Australia
Distribution: Fedora, CentOS, OpenSuse, Slack, Gentoo, Debian, Arch, PCBSD
Posts: 6,678

Rep: Reputation: 122Reputation: 122
Something else to try - I don't recall if Ubuntu has SELinux enabled, but if nothing else is working, try

sudo setenforce 0

then try connecting to localhost
 
Old 02-06-2008, 07:23 AM   #23
LinuxCrayon
Member
 
Registered: Nov 2007
Location: Georgia, USA
Distribution: FreeBSD
Posts: 274

Rep: Reputation: 31
I'm pretty sure Ubuntu doesn't use SELinux. I think it has it but doesn't enable it by default.
 
Old 02-06-2008, 11:07 AM   #24
SimbaSpirit
Member
 
Registered: Feb 2008
Posts: 109

Original Poster
Rep: Reputation: 15
By typing (I believe it was) su passwd, I was prompted to set password for root, then by typing "su" in terminal I *am* root, not just using privs that sudo provides, and I can also sign in as user: root pass: what I set

Output of logs:

ls -l /opt:

Quote:
total 4
drwxr-xr-x 20 root root 4096 2007-12-25 01:15 lampp
ls -l /opt/lampp:

Quote:
total 152
drwx------ 2 root root 4096 2004-02-10 20:43 backup
drwxr-xr-x 3 root root 12288 2007-12-25 01:16 bin
drwxr-xr-x 2 root root 4096 2004-07-14 06:04 cgi-bin
drwxr-xr-x 3 root root 4096 2005-10-16 04:43 error
drwxr-xr-x 9 root root 4096 2007-12-22 04:39 etc
drwxr-xr-x 4 nobody root 4096 2007-11-14 02:43 htdocs
drwxr-xr-x 3 root root 4096 2003-05-30 15:38 icons
-rwxr-xr-x 1 root root 14870 2007-12-10 12:59 lampp
drwxr-xr-x 10 root root 4096 2007-12-25 01:15 lib
drwxr-xr-x 2 root root 4096 2006-04-26 09:46 libexec
drwxr-xr-x 37 root root 4096 2006-03-14 07:06 licenses
drwxr-xr-x 2 root root 4096 2008-02-06 00:13 logs
drwxr-xr-x 2 root root 4096 2007-12-25 01:15 modules
drwxr-xr-x 10 root root 4096 2007-12-25 01:13 phpmyadmin
drwxrwxrwx 2 root root 4096 2007-07-15 08:20 phpsqliteadmin
-rw-rw-r-- 1 root root 50805 2007-12-25 01:15 RELEASENOTES
drwxr-xr-x 2 root root 4096 2007-12-25 01:16 sbin
drwxr-xr-x 15 root root 4096 2007-12-22 04:33 share
drwxr-xr-x 3 root root 4096 2005-01-18 11:21 tmp
drwxr-xr-x 5 root root 4096 2008-02-06 00:13 var
Typing sudo setenforce 0 returns that setenforce isn't a command.

Hope that helps

-SS

Last edited by SimbaSpirit; 02-06-2008 at 11:19 AM.
 
Old 02-06-2008, 11:24 AM   #25
SimbaSpirit
Member
 
Registered: Feb 2008
Posts: 109

Original Poster
Rep: Reputation: 15
Just wanted to call this back to attention since it went unaddressed earlier and may have something to do with all this,

When I navigate to /opt/lampp/htdocs and open index.html with firefox, I get "Problem Loading Page" "Firefox can't find the file at /XAMPP/"

Is firefox refusing to load localhost because its returning an error? Just a thought.
I'll whip up a little sample page in its place when I get home in a couple of hours.
-SS
 
Old 02-06-2008, 01:41 PM   #26
billymayday
LQ Guru
 
Registered: Mar 2006
Location: Sydney, Australia
Distribution: Fedora, CentOS, OpenSuse, Slack, Gentoo, Debian, Arch, PCBSD
Posts: 6,678

Rep: Reputation: 122Reputation: 122
I'll try loading xampp onto a ubuntu box tonight if I have a chance and see what happens

In the meantime, did you try things before

/opt/lampp/lampp security

and can you try

/opt/lampp/lampp stopssl
/opt/lampp/lampp start

Last edited by billymayday; 02-06-2008 at 01:48 PM.
 
Old 02-06-2008, 02:05 PM   #27
SimbaSpirit
Member
 
Registered: Feb 2008
Posts: 109

Original Poster
Rep: Reputation: 15
I did do the security check last time, but not since I reloaded ubuntu, so whatever the problem is its not related to that. I tried with and without ssl, still no go.

I hope you find something out tonight

-SS
 
Old 02-06-2008, 08:46 PM   #28
SimbaSpirit
Member
 
Registered: Feb 2008
Posts: 109

Original Poster
Rep: Reputation: 15
Established a workaround

Alright http://localhost and all that still doesn't take me to xampp, however, I decided to open up /opt/lampp/etc/httpd.conf and simply add "Servername FileFarm", restart XAMPP, and browse to filefarm.selfip.com (the address I selected from dyndns.org), and it accessed the XAMPP pages, and I was able to set securities and all from there.

Then I tried to put Servername localhost, 127.0.0.1 yahda yahda, and nothing is fixing http://localhost's resolution.

Hope this helps narrow it down a bit.
 
Old 02-06-2008, 08:53 PM   #29
gankoji
Member
 
Registered: Nov 2007
Location: Southern California
Distribution: Slackware-13.0 x86_64, Slackware 12.2, slackware64-current
Posts: 225

Rep: Reputation: 35
I think you're missing a very critical part to the output of /sbin/lampp start

It says that you are starting Apache WITH SSL. This means that your site is being hosted through SSL. Try resolving

https://localhost

or https://127.0.0.1

This will more than likely prompt you for your SSL login, which you should have created on installation. If you can't remember your login, try removing SSL by issuing

lampp stop ssl

Then http://localhost should work.

Happy Hunting :-)
 
Old 02-06-2008, 09:17 PM   #30
SimbaSpirit
Member
 
Registered: Feb 2008
Posts: 109

Original Poster
Rep: Reputation: 15
*points to entry #4*

Tried it, https doesn't work either

"lampp stop ssl" stops all of lamp, it doesn't read past stop.

Last edited by SimbaSpirit; 02-07-2008 at 01:04 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
My hostname is NOT resolving correctly cucolin@ Linux - Networking 5 08-29-2007 10:22 AM
Message from syslogd@localhost localhost kernel: Disabling IRQ #21 ylts Linux - Hardware 0 02-26-2005 08:01 AM
howto map localhost correctly? computerdaves Fedora 10 02-08-2005 03:54 PM
network up, but not resolving correctly. BrianK Linux - Networking 8 07-06-2004 02:37 PM
/etc/hosts resolving before DNS resolving ? markraem Linux - Networking 4 11-02-2003 04:54 AM


All times are GMT -5. The time now is 08:43 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration