LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 01-22-2002, 03:05 AM   #1
da Perp
Member
 
Registered: Oct 2001
Location: the Netherlands
Distribution: Bear Linux (LFS 3.3)
Posts: 171

Rep: Reputation: 30
locale


Every time when i make certain programs, everything installs and goes well, but perl starts bitching about my locale settings, namely the ones for en_US.Im running mandrake 7.2 now, my redhat cd's are dirty and i cant install it anymore. When I installed mandrake I specified that i wanted to support dutch and english languages, so I dont know why it's complaining. I also installed more recent locale rpm's including the english ones. It's still bitching about locale settings. Does anybody have any suggestions how i might solve this?
 
Old 01-22-2002, 06:44 AM   #2
Mik
Senior Member
 
Registered: Dec 2001
Location: The Netherlands
Distribution: Ubuntu
Posts: 1,316

Rep: Reputation: 46
Usually there are three environment variables you can set for that. LANG, LC_CTYPE and LC_ALL. I've got mine set to US english so they are as follows:

LANG = en
LC_CTYPE = en_US
LC_ALL =

Usually all you would have to do is make sure the LANG variable is set. You might want to add this to your startup scripts if it's not set properly.
 
Old 01-22-2002, 07:02 AM   #3
da Perp
Member
 
Registered: Oct 2001
Location: the Netherlands
Distribution: Bear Linux (LFS 3.3)
Posts: 171

Original Poster
Rep: Reputation: 30
cool. you understand my problem. where and how can i set this?

Last edited by da Perp; 01-22-2002 at 07:03 AM.
 
Old 01-22-2002, 07:27 AM   #4
da Perp
Member
 
Registered: Oct 2001
Location: the Netherlands
Distribution: Bear Linux (LFS 3.3)
Posts: 171

Original Poster
Rep: Reputation: 30
Do I have to edit a file? Do i have to issue certain shell commands, and if so, how do i initiate them at startup?
 
Old 01-22-2002, 07:49 AM   #5
da Perp
Member
 
Registered: Oct 2001
Location: the Netherlands
Distribution: Bear Linux (LFS 3.3)
Posts: 171

Original Poster
Rep: Reputation: 30
mik, help please?
 
Old 01-22-2002, 10:02 AM   #6
therion12
Member
 
Registered: Dec 2001
Location: chicago, IL
Distribution: Gentoo 1.4_rc1
Posts: 913

Rep: Reputation: 30
Sorry, i can't help you becuase your linux version is too old.
 
Old 01-22-2002, 10:35 AM   #7
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,374

Rep: Reputation: 1962Reputation: 1962Reputation: 1962Reputation: 1962Reputation: 1962Reputation: 1962Reputation: 1962Reputation: 1962Reputation: 1962Reputation: 1962Reputation: 1962
Quote:
Originally posted by therion12
Sorry, i can't help you becuase your linux version is too old.
What the hell is the point of saying that? stop posting such utterly stupid posts.

perp, i don't know where those variables are set, but you could proabbly get away with setting them in /etc/rc.local. try it, assuming you knwo what you want to set them to, if they get overridden, move to /etc/bashrc for example

Last edited by acid_kewpie; 01-22-2002 at 10:37 AM.
 
Old 01-23-2002, 01:45 AM   #8
da Perp
Member
 
Registered: Oct 2001
Location: the Netherlands
Distribution: Bear Linux (LFS 3.3)
Posts: 171

Original Poster
Rep: Reputation: 30
therion you moron....im running kernel 2.4.16,XFree4.1.0,and a lot of other upgraded stuff... you can barely tell it's mandrake 7.2...what does it matter anyway that it's mandrake 7.2?

thanks acid, im working on it. I tried some stuff yesterday but nothing really worked. working on it......
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
locale: Cannot Set LC_ALL to default locale: No such file or directory. asym Linux - General 10 03-24-2013 08:35 PM
How to change the locale by setting the system default locale letdoit Slackware 6 08-18-2011 03:34 AM
"locale not supported by Xlib, locale set to C" Irad Linux - Software 3 06-25-2006 03:59 PM
C locale and system locale johnnydangerous Fedora 4 04-11-2005 03:37 PM
Locale cinnix Linux - General 4 07-13-2001 12:03 AM


All times are GMT -5. The time now is 09:28 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration