LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 07-25-2005, 03:20 PM   #1
tcamp
LQ Newbie
 
Registered: Dec 2004
Posts: 9

Rep: Reputation: 0
Loading modules for tape drive on boot-up


I'm a relative newbie, let loose on Fedora core 4. For my tape drive to work properly, I need the SG module to be loaded, and the module ST to NOT be loaded. Currently I find that ST is automatically being loaded on boot-up and I would like to prevent this. Does anyone know which file I need to change to prevent the ST module from being loaded?

Having a fairly clean Fedora 4 install, I don't have a /etc/rc.modules file or any *.module files in /etc/sysconfig/modules.

I have tried to understand the rc.sysinit script but it goes over my head!

Thanks for any suggestions.
 
Old 07-25-2005, 05:16 PM   #2
jailbait
LQ Guru
 
Registered: Feb 2003
Location: Blue Ridge Mountain
Distribution: Debian Jessie, Linux Mint 17
Posts: 7,751

Rep: Reputation: 272Reputation: 272Reputation: 272
"Does anyone know which file I need to change to prevent the ST module from being loaded?"

I think that FC4 does this in /etc/modprobe.conf. If that is true then you can both remove the ST module load and add the SG module load in /etc/modprobe.conf.

---------------------------
Steve Stites
 
Old 07-25-2005, 05:29 PM   #3
tcamp
LQ Newbie
 
Registered: Dec 2004
Posts: 9

Original Poster
Rep: Reputation: 0
Thanks Steve.

I looked at my modprobe.conf file, but all it contains is:

alias eth0 8139too
alias scsi_hostadapter aic7xxx
alias snd-card-0 snd-fm801
options snd-card-0 index=0
options snd-fm801 index=0
remove snd-fm801 { /usr/sbin/alsactl store 0 >/dev/null 2>&1 || : ; }; /sbin/modprobe -r --ignore-remove snd-fm801
alias usb-controller uhci-hcd

I can't see any reference to the ST module being loaded here. Any other ideas?

Thanks,

Tim
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
No Modules loading at boot. mpyusko Slackware 11 09-25-2006 04:39 PM
Loading modules at boot paddyjoy Linux - Newbie 2 06-27-2005 10:23 PM
loading modules at boot Davidian1024 Linux From Scratch 3 06-25-2004 01:19 AM
disable modules from loading on boot spyderusa11 Fedora 1 05-23-2004 06:58 PM
loading modules at boot schatoor Linux - General 2 11-29-2002 05:16 AM


All times are GMT -5. The time now is 12:28 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration