LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 07-10-2004, 03:15 PM   #1
ncp100
LQ Newbie
 
Registered: Jun 2004
Posts: 9

Rep: Reputation: 0
Loading linux modules on Bootup


I have an ATA/133 ide controller card (ITE8212) which I am trying to load on bootup. I can load the driver manually by doing a insmod -f iteraid.o. But when modprobe loads it on boot up it does not force the module to load and hence it does not recognize the controller. Does anyone know how I can force modprobe to load the iteraid driver.

Thanks
 
Old 07-10-2004, 03:30 PM   #2
MasterC
LQ Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 64
Re: Loading linux modules on Bootup

Quote:
Originally posted by ncp100
... But when modprobe loads it on boot up it does not force the module to load and hence it does not recognize the controller. Does anyone know how I can force modprobe to load the iteraid driver.

Thanks
I am confused. If modprobe loads it on bootup, then why are you having to load it again... Anyway, depending on the distro you may have what's called an rc.local file. It will likely located in the /etc directory or a sub directory within /etc It's a text file that you can place your own startup requests in, they will be executed last. So:
/sbin/modprobe iteraid.o
Should suffice as a single line in that file.

Cool
 
Old 07-11-2004, 10:16 AM   #3
ncp100
LQ Newbie
 
Registered: Jun 2004
Posts: 9

Original Poster
Rep: Reputation: 0
Sorry, it was confusing...what I meant to say was the iteraid.o does not load on bootup. Only way to load it is by saying "insmod -f iteraid.o", but when I say "modprobe iteraid" it just tries to load it without the -f parameter. My only hard drive is on this controller, so if the controller does not load the hard drive is not recogized, then I have to boot thro the slackware CD and then load the drivers from the floppy. I have compiled the new kernels, but it still wont work on bootup because I need to force the module to load. I will check out the rc.local file and see if there is a way to force the module.

Thanks
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Loading modules in Live Knoppix Linux Budman21901 Linux - Newbie 1 01-03-2005 08:11 AM
Loading up modules at bootup? apachedude SUSE / openSUSE 4 12-02-2004 05:56 AM
Loading modules error after loading compiled kernel td0l2 Linux - Newbie 12 07-28-2004 12:10 PM
Loading linux modules on Bootup ncp100 Linux - Hardware 3 07-11-2004 01:01 PM
Mandrake linux 9.2 ismod failed during installation (loading of 3rd party modules) micro_sucks Linux - General 0 12-15-2003 02:01 AM


All times are GMT -5. The time now is 12:18 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration