LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 10-05-2008, 09:31 PM   #1
JohnLocke
Member
 
Registered: Jun 2004
Location: Denver, Colorado
Distribution: Ubuntu
Posts: 221

Rep: Reputation: 30
loading dual boot ubuntu: lost access to everything (no boot at all)


Ok, I'm completely lost. Here's the steps I took:

I had a machine with windows xp on it and two hard drives. I cleaned one of the hard drives (the one without xp, sdb) and unpartitioned it.

Then I put ubuntu (8.04, I think) into the drive and installed to sdb (let it do the automatic guided install on sdb since the entire disk was blank).

When it told me to take the disk out and reboot, I got a grub prompt. No bootloader menu, just the prompt. I don't really know how to use that, so I thought I'd boot back onto the live cd and see what I could see.

But I couldn't boot back onto the live cd, nothing happens, just a blinking cursor after the initial bios boot.

Ok, I figured I'd go back to the grub prompt and try to figure that out, but when I boot to the hard drive now, I just get the blinky cursor also.

So I'm completely lost. Would it make sense at this point to try and put an xp disk in and do a recovery (if it boots from xp)?
 
Old 10-05-2008, 09:39 PM   #2
rabbit2345
Member
 
Registered: Apr 2007
Location: 中国上海
Distribution: openSUSE 11.3
Posts: 368

Rep: Reputation: 40
try doing a reinstall of ubuntu, it sounds like something got screwed up during the installation.

as for your second question, it would be a waste of time to pop in an xp recover disk. windows does not have the tools needed for recovery in linux, and is very weak compared to linux. xp can't install grub, and ntldr can't see linux stuff, so that doesn't fix the bootloader prblem.

if after the reinstall things still don't work, them come post here again.


good luck,
rabbit2345 ^_^
 
Old 10-05-2008, 09:44 PM   #3
JohnLocke
Member
 
Registered: Jun 2004
Location: Denver, Colorado
Distribution: Ubuntu
Posts: 221

Original Poster
Rep: Reputation: 30
Quote:
Originally Posted by rabbit2345 View Post
try doing a reinstall of ubuntu, it sounds like something got screwed up during the installation.

as for your second question, it would be a waste of time to pop in an xp recover disk. windows does not have the tools needed for recovery in linux, and is very weak compared to linux. xp can't install grub, and ntldr can't see linux stuff, so that doesn't fix the bootloader prblem.

if after the reinstall things still don't work, them come post here again.


good luck,
rabbit2345 ^_^

Thanks, but the problem /beyond/ that is that I can't get the ubuntu live cd to boot either. Everything (and I haven't tried xp yet) just gives me a blank, blinking cursor. I'll come back to it tomorrow. For now I need to stop staring into the blinking white light.
 
Old 10-05-2008, 10:41 PM   #4
sjw1010
LQ Newbie
 
Registered: Oct 2008
Location: Vancouver / Honolulu
Distribution: Kubuntu
Posts: 2

Rep: Reputation: 0
Hi,

it sounds like your system is set to boot to the harddisk first.
when you wiped the drive the bios booted from CDROM only after it had checked your harddisk and found nothing, now it is trying to boot from hard disk but having problems

you can

1) change you bios settings to boot form CD first and then re install your O/S. but you could get the same problem again

2) you can edit your grub, as the system boots up you will see a grub output that tells you to press ESC to enter main menu

look what you have listed there you should have 3 ubuntu kernel then one with recovery mode and a mem test , the top one is usually default and the one it is trying to boot.
with the top one selected press e
the screen will change and show you the settings i think you will find that the settings are pointing to the wrong drive there will be root=/dev/sda1 you should change this bit to read root=/dev/sdb1 as you said you installed to sdb.
then follow the prompts to get back to main menu and then try booting it

that should work!

thats what happened to me when i tried to install from the live CD, also got a lot of other problems, i now only ever install from the server disk. but it was along time ago since i tried the rate *ubuntu evolves it could be fixed now.

if this is not the case it may be worth taking a note of what it says in the grub settings so you can post here
 
Old 10-05-2008, 10:45 PM   #5
JohnLocke
Member
 
Registered: Jun 2004
Location: Denver, Colorado
Distribution: Ubuntu
Posts: 221

Original Poster
Rep: Reputation: 30
Quote:
Originally Posted by sjw1010 View Post
Hi,

it sounds like your system is set to boot to the harddisk first.
when you wiped the drive the bios booted from CDROM only after it had checked your harddisk and found nothing, now it is trying to boot from hard disk but having problems

you can

1) change you bios settings to boot form CD first and then re install your O/S. but you could get the same problem again

2) you can edit your grub, as the system boots up you will see a grub output that tells you to press ESC to enter main menu

look what you have listed there you should have 3 ubuntu kernel then one with recovery mode and a mem test , the top one is usually default and the one it is trying to boot.
with the top one selected press e
the screen will change and show you the settings i think you will find that the settings are pointing to the wrong drive there will be root=/dev/sda1 you should change this bit to read root=/dev/sdb1 as you said you installed to sdb.
then follow the prompts to get back to main menu and then try booting it

that should work!

thats what happened to me when i tried to install from the live CD, also got a lot of other problems, i now only ever install from the server disk. but it was along time ago since i tried the rate *ubuntu evolves it could be fixed now.

if this is not the case it may be worth taking a note of what it says in the grub settings so you can post here
Well, this is the problem. I don't /get/ a grub menu. I have tried booting from the CD (with the bios settings), hd1, hd2, and even from floppy. I get jack every single time (blinking cursor).

I mean, I can't even seem to get it to the point that I /could/ re-load linux from scratch.

Not sure at all what could be causing it, or how to get to a point where I can either see the live CD or see grub again.
 
Old 10-05-2008, 11:43 PM   #6
sjw1010
LQ Newbie
 
Registered: Oct 2008
Location: Vancouver / Honolulu
Distribution: Kubuntu
Posts: 2

Rep: Reputation: 0
ok,

when you turn the computer on you should get some text on the screen and an instruction on how to get in to the BIOS.

it is usually hit del or escape or F12 each motherboard is different some even say press a certain key to boot from CD

you need to get it to boot from CD so if it asks for a key to do that hit that key
if not you need to hit the specified key to "enter setup"

once in the BIOS look through the menus for something that will say boot order
and set the cdrom to be the first boot device

then save your settings (usually F10) and then reboot and then the machine should boot from your CD (removable media) (with your linux CD in the drive)


if this isnt working. as your turn your computer on do you get any text output before it goes to the blinking white cursor? you should get messages that come up and go off the screen before it freezes at the cursor, what do they say?
 
Old 10-06-2008, 08:05 AM   #7
JohnLocke
Member
 
Registered: Jun 2004
Location: Denver, Colorado
Distribution: Ubuntu
Posts: 221

Original Poster
Rep: Reputation: 30
Quote:
Originally Posted by sjw1010 View Post
ok,

when you turn the computer on you should get some text on the screen and an instruction on how to get in to the BIOS.

it is usually hit del or escape or F12 each motherboard is different some even say press a certain key to boot from CD

you need to get it to boot from CD so if it asks for a key to do that hit that key
if not you need to hit the specified key to "enter setup"

once in the BIOS look through the menus for something that will say boot order
and set the cdrom to be the first boot device

then save your settings (usually F10) and then reboot and then the machine should boot from your CD (removable media) (with your linux CD in the drive)


if this isnt working. as your turn your computer on do you get any text output before it goes to the blinking white cursor? you should get messages that come up and go off the screen before it freezes at the cursor, what do they say?
Yes, I've been able to get into the bios just fine and I can set it to boot first from CD, hdd, whatever. Nothing seems to change anything (which has me a little worried)

I get the normal post messages that tell me the memory is fine, the cpu is up and running, that it found the hard drives and the cdrom and dvdrom, and the next thing that comes up, where normally it would begin booting from whichever device I've selected, is a blinking cursor.
 
Old 10-07-2008, 01:52 AM   #8
simonwil
LQ Newbie
 
Registered: Apr 2006
Location: Manchester(UK), Vancouver (Ca), Hawaii(USA)
Distribution: Kubuntu
Posts: 4

Rep: Reputation: 0
i used to get problems like this with an old computer i had that had 2 ATA drives in it, usually when i upgraded

things i would try

download and burn a fresh copy of the OS (just to make sure the image/media is good)

if you have a USB CDROM and your system can boot from USB i would try booting from it

then i dont know how comfortable you are with going inside your computer, but i would try disconnecting one of the hard disks and try booting from CD with just one (try each one individualy...but remember you may need to change jumpers)

i think you will find working through these that you will get it to boot up. if it is a hard disk problem you can probably fix it once you are booted if its not hardware.
 
Old 10-07-2008, 02:02 AM   #9
linuxlover.chaitanya
Senior Member
 
Registered: Apr 2008
Location: Nagpur, India
Distribution: Cent OS 5/6, Ubuntu Server 10.04
Posts: 4,627

Rep: Reputation: Disabled
On which hdd did you install the grub? Or did you install it in the first place? By default Ubuntu will install in the mbr of the hdd in this case sdb.
As this hdd is set to secondary you wont be able to boot. just change the jumper settings for hdd to make your sdb to sda and try booting. If your grub and os are in place you will boot into Ubuntu. Then edit menu.lst to add the windows in grub.
 
Old 10-07-2008, 09:41 AM   #10
JohnLocke
Member
 
Registered: Jun 2004
Location: Denver, Colorado
Distribution: Ubuntu
Posts: 221

Original Poster
Rep: Reputation: 30
Quote:
Originally Posted by linuxlover.chaitanya View Post
On which hdd did you install the grub? Or did you install it in the first place? By default Ubuntu will install in the mbr of the hdd in this case sdb.
As this hdd is set to secondary you wont be able to boot. just change the jumper settings for hdd to make your sdb to sda and try booting. If your grub and os are in place you will boot into Ubuntu. Then edit menu.lst to add the windows in grub.
This is, I think, closest to the problem, though I'm not sure if it explains why I can't boot into windows.

You're correct that I installed ubuntu to sdb while leaving windows on sda. To my discredit, I let ubuntu do it's own guided install, which means I have no freaking clue where it put various partitions, but more importantly, the MBR.

My best guess right now is that it installed the MBR to sda, while installing ubuntu to sdb, but something went wrong with the MBR.

On the other hand, I had /some/ success last night, and it was all related to jumpers.

I was most concerned with losing data on the windows drive, so I pulled that and went to put it in another machine (to copy data to a third drive). I suddenly couldn't get that second machine to boot. Came to find out, after testing a lot of jumper settings, that some hard drives are /very/ picky about having NO jumper set on them rather than being set to master.

So I was able to set the second machine up to copy data last night, which is a major improvement.

I've tried booting to just one drive or the other, and no luck previously, but now that I know these jumper settings, I'll try again tonight.

This still doesn't explain why, when I removed /both/ hard drives completely, I couldn't boot to the live CD. That still gets me but hopefully putting the hard drives in rectifies this somehow.
 
Old 10-07-2008, 10:29 PM   #11
JohnLocke
Member
 
Registered: Jun 2004
Location: Denver, Colorado
Distribution: Ubuntu
Posts: 221

Original Poster
Rep: Reputation: 30
Ok, I'm going to close this thread since this problem is resolved (and open a new one about bootloaders)

Don't know exactly what was going on, but it was a generic Award bios. I found somewhere deep within it a silly option that said something to the effect of, "enable this to reset defaults if hardware changes were made and OS no longer boots."

Interesting, so I set that and it got a little further to booting to the CD.

Then I went in and told the bios to reload the "safe" defaults, and bam! It works.

So thanks all for the help, but this was a crazy stupid bios problem. Don't know why linux helped exacerbate it, but there you have it.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How to make XP boot as default OS in WinXP-Ubuntu dual boot system svin Ubuntu 14 11-04-2009 04:49 PM
dual boot fedora & vista - boot error - "GRUB loading stage 2" ans Fedora 1 08-20-2007 03:35 AM
XP won't boot, loops back to GRUB: dual-boot XP and Ubuntu dan2010 Linux - Newbie 4 08-08-2007 12:09 PM
Resized Linux Partition on Dual Boot - Lost Boot RationalRabbit Linux - Newbie 14 12-29-2005 01:02 AM
Need help fixing boot problem on Ubuntu/WinXp dual-boot Ay-Karamba! Linux - General 5 09-06-2005 09:20 PM


All times are GMT -5. The time now is 07:47 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration