LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices



Reply
 
Search this Thread
Old 04-05-2010, 06:34 AM   #1
prpednek
LQ Newbie
 
Registered: Mar 2010
Location: India
Distribution: RHEL
Posts: 22

Rep: Reputation: 16
loading driverdisk in isolinux.cfg


Hi,
I am trying to accomplish a kickastart installation of RHEL5.4. I am loading a driverdisk[megasr] which has been copied to the RHEl5.4 ISO image root directory. I am trying to do this as to run the installation without any additional fdd's.

My isolinux.cfg is as follows :

default linux ks=cdrom:/ks.cfg
prompt 1
timeout 600
display boot.msg
F1 boot.msg
F2 options.msg
F3 general.msg
F4 param.msg
F5 rescue.msg
label linux
kernel vmlinuz
append initrd=initrd.img dd=cdrom:/megasr-13.12.1009.2009-1-rhel50-u4-all.img
label text
kernel vmlinuz
append initrd=initrd.img text
label ks
kernel vmlinuz
append ks initrd=initrd.img
label local
localboot 1
label memtest86
kernel memtest
append -


My ks.cfg is as follows :

install
cdrom
key --skip
lang en_US.UTF-8
keyboard us
xconfig --startxonboot
network --device eth0 --bootproto dhcp
rootpw --iscrypted $1$RByT0rMh$Q7lvC55bQOHunY5B0HR..1
firewall --enabled --port=22:tcp
authconfig --enableshadow --enablemd5
selinux --enforcing
timezone --utc America/New_York
bootloader --location=mbr --driveorder=hda --append="rhgb quiet"
# The following is the partition information you requested
# Note that any partitions you deleted are not expressed
# here so unless you clear all partitions first, this is
# not guaranteed to work
clearpart --linux --drives=hda
part /boot --fstype ext3 --size=100 --ondisk=hda
part pv.6 --size=0 --grow --ondisk=hda
volgroup VolGroup01 --pesize=32768 pv.6
logvol / --fstype ext3 --name=LogVol00 --vgname=VolGroup01 --size=1024 --grow
logvol swap --fstype swap --name=LogVol01 --vgname=VolGroup01 --size=1024 --grow --maxsize=2048

%packages
@admin-tools
@base
@core
@development-libs
@development-tools
@dialup
@editors
@gnome-desktop
@gnome-software-development
@games
@graphical-internet
@graphics
@java
@legacy-software-support
@office
@printing
@sound-and-video
@text-internet
@web-server
@x-software-development
@base-x
kexec-tools
fipscheck
device-mapper-multipath
sgpio
imake
emacs
libsane-hpaio
mesa-libGLU-devel
xorg-x11-utils
xorg-x11-server-Xnest
xorg-x11-server-Xvfb
-sysreport


Basically I want the megasr drivers get loaded as installation begins before the default ahci drivers, but currently it is unable to load them as I guess they are not being detected from the argument in isolinux.cfg. Any pointers???

Any help is much appreciated.

Thanks,
Prasad.

Last edited by prpednek; 04-05-2010 at 10:41 AM. Reason: command to be verified
 
Old 04-05-2010, 10:04 PM   #2
kbp
Senior Member
 
Registered: Aug 2009
Posts: 3,758

Rep: Reputation: 644Reputation: 644Reputation: 644Reputation: 644Reputation: 644Reputation: 644
You don't seem to be using the 'driverdisk' option in your kickstart file...

http://www.redhat.com/docs/manuals/e...2-options.html

cheers
 
Old 04-06-2010, 04:02 AM   #3
prpednek
LQ Newbie
 
Registered: Mar 2010
Location: India
Distribution: RHEL
Posts: 22

Original Poster
Rep: Reputation: 16
Hi KBP,
Wouldn't reference to the driverdisk in the isolinux.cfg suffice ?? or do we also need to mention the same in the kickstart configuration??

Could you please let me know what extra needs to be added. Also the driver diskette is the one marked in bold above using the dd option in the isolinux.cfg

Thanks,
Prasad.

Quote:
Originally Posted by kbp View Post
You don't seem to be using the 'driverdisk' option in your kickstart file...

http://www.redhat.com/docs/manuals/e...2-options.html

cheers

Last edited by prpednek; 04-06-2010 at 04:26 AM.
 
  


Reply

Tags
megasr, rhel54


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Grub2 and isolinux.cfg niravshah Linux - Newbie 10 07-23-2009 07:15 PM
isolinux.cfg - can not have a prompt and timeout Bluesuperman Slackware 3 09-28-2008 06:34 AM
isolinux.cfg whats wrong here? FreddyF Linux - Newbie 1 12-28-2005 02:27 PM
ISOLINUX : Loading spec packet failed, trying to andyoye Linux - Hardware 1 04-14-2004 04:49 PM


All times are GMT -5. The time now is 12:01 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration