LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 12-24-2010, 02:29 PM   #1
mazz75
LQ Newbie
 
Registered: Dec 2010
Posts: 1

Rep: Reputation: 0
Loaded Kernel modules on virtual server and CSF confusion


Hi all, I wonder if anyone can suggest what is happening on my Centos virtual server (ps I'm having a great time re-learning Linux after a large gap and usually try and find out myself but this has me confused)

First thing I did was install Tomcat and try and change the port to 80 using iptables -nat and it complained a kernel module was missing. Instead setup Apache to redirect requests so that's now working

I then tried to install CSF firewall and the validation perl script returned fatal errors so I assumed OK my virtual server Kernel is restricted and used denyhosts instead which is working great

Here's the confusion..
I later retried the csftest script and it now works including all the iptables and nat stuff that fataled before. I've not rebooted or changed anything except run denyhosts and the postgres daemon + ended a few daemons that I didn't need (eg pickup,tlsmgr,courier,postfix,qmgr,saslauthd)

Running lsmod returns nothing and /proc/modules is zero bytes so I'm not able to tell what is loaded?

I'm tempted to try and get Tomcat redirecting via iptables and see what happens but if it works I don't like that something seems to have changed..

Oh.. before I ran it direct as root now I'm SU into root from another login

Maybe the sky gods at 1and1 saw what I was up to and intervened...

Thanks for any clues

Martin
 
Old 12-24-2010, 04:36 PM   #2
wpeckham
Member
 
Registered: Apr 2010
Location: USA
Distribution: Debian, Ubuntu, Fedora, RedHat, DSL, Puppy, CentOS, Knoppix
Posts: 807

Rep: Reputation: 175Reputation: 175
virtual confusion

You did not mention what version of CentOS or what kind or version of virtualization you are using.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Kernel modules are not getting loaded BenjaminLost Linux - Newbie 8 11-29-2010 03:43 AM
Dynamically loaded modules and statically loaded modules in linux gauthamk Linux - Software 1 05-18-2008 05:28 PM
kernel: No module symbols loaded - kernel modules not enabled. Qucho Debian 9 05-26-2004 03:50 AM
how do I disable kernel modules from being loaded hdagelic Linux - General 1 04-09-2004 04:53 AM
Kernel 2.6.5 -> no modules loaded Spheerke Debian 4 04-07-2004 10:05 PM


All times are GMT -5. The time now is 05:03 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration