LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 04-21-2005, 09:53 AM   #1
coldsalmon
Member
 
Registered: Mar 2005
Location: USA
Distribution: Kubuntu Breezy
Posts: 79

Rep: Reputation: 15
load modules at boot


Hi,

I'm trying to load my necessary hardware modules at boot instead of running hotplug every time. My goal is a faster boot. I know how to use lsmod to list the modules that are currently running, but how do I add those to the kernel at boot to replace hotplug? I'm running Slack 10.1 with the 2.4 kernel.

Thanks,

--C
 
Old 04-21-2005, 11:20 AM   #2
Crashed_Again
Senior Member
 
Registered: Dec 2002
Location: Atlantic City, NJ
Distribution: Ubuntu & Arch
Posts: 3,503

Rep: Reputation: 57
Ummm...lets see 2.4 series uses /etc/modules.conf I think. You should be able to add the modules you want to load at boot time in that file.
 
Old 04-21-2005, 02:11 PM   #3
coldsalmon
Member
 
Registered: Mar 2005
Location: USA
Distribution: Kubuntu Breezy
Posts: 79

Original Poster
Rep: Reputation: 15
Do I just copy the names directly from lsmod and just make a list in modules.conf, or is there special syntax? Also, If I decide to upgrade to 2.6 kernel, how does that operate?

Thanks so much,

--C
 
Old 04-21-2005, 02:18 PM   #4
snowtigger
Member
 
Registered: Mar 2005
Location: england
Distribution: slackware, win2k
Posts: 364

Rep: Reputation: 34
Have a look at /etc/rc.d/rc/modules
Unless you have already changed it, there is some info in there

 
Old 04-21-2005, 04:36 PM   #5
coldsalmon
Member
 
Registered: Mar 2005
Location: USA
Distribution: Kubuntu Breezy
Posts: 79

Original Poster
Rep: Reputation: 15
Okay, finally got it. In case anyone else is having the same problem, here's what I did:

I appended the lsmod output to modules.conf

$ lsmod >> /etc/modules.conf

Then I edited it to make all the new lines look like:

/sbin/modprobe MODULENAME

Then I disabled hotplug by renaming /etc/rc.d/rc.hotplug to _rc.hotplug

It now takes me 23 seconds from bootloader to console login, and about 30 seconds to the xcfe desktop with xdm. I finally beat M$ for boot time! Gotta love Slackware

--C

Gateway 450ROG laptop
Pentium M 1.4 GHz
512MB SDRAM
Slackware 10.1
Kubuntu Hoary Hedgehog
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Load modules at boot martincho Linux - Networking 2 11-27-2004 10:12 AM
Modules don't seem to load on boot ViNsAniTy Linux - Newbie 4 04-21-2004 12:40 PM
Setting up modules to load on boot up Dopeskills Mandriva 2 01-21-2004 09:14 PM
modules dont load at boot time killer_bunny Linux - General 1 12-23-2003 10:59 PM
modules.conf doesnt load 8211.o at boot toastermaker Linux - Newbie 4 12-11-2003 04:36 PM


All times are GMT -5. The time now is 06:43 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration