LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-24-2006, 05:26 AM   #1
Sapient
Member
 
Registered: Oct 2003
Location: San Luis Obispo, CA
Distribution: SuSE
Posts: 196

Rep: Reputation: 30
Alias Directive / Apache


Simple question. I am trying to do this:

ln -s http://www.hingedmind.com/squirrelma.../src/index.php mindmail

No matter what permissions I set for index.php (777 root:root) When I try http://www.hingedmind.com/mailmind/

I get:

Forbidden

You don't have permission to access /mindmail/ on this server.

Additionally, a 403 Forbidden error was encountered while trying to use an ErrorDocument to handle the request.

Thanks

Last edited by Sapient; 01-30-2006 at 02:44 PM.
 
Old 01-24-2006, 06:20 AM   #2
marozsas
Senior Member
 
Registered: Dec 2005
Location: Campinas/SP - Brazil
Distribution: SuSE, RHEL, Fedora, Ubuntu
Posts: 1,397
Blog Entries: 1

Rep: Reputation: 64
The command ln is designed to link files on a local file system. The url http://www.hingedmind.com/squirrelma.../src/index.php is not a file neither local.

The right way to do that using KDE (others display managers can do similar) is open the url in konqueror and drag-and-drop the tiny icon in front of the url in location bar to the desktop and choose link here.

After that you can access the page just clicking on the icon in Desktop.

regards,
 
Old 01-24-2006, 06:25 AM   #3
Sapient
Member
 
Registered: Oct 2003
Location: San Luis Obispo, CA
Distribution: SuSE
Posts: 196

Original Poster
Rep: Reputation: 30
Quote:
Originally Posted by marozsas
The command ln is designed to link files on a local file system. The url http://www.hingedmind.com/squirrelma.../src/index.php is not a file neither local.

The right way to do that using KDE (others display managers can do similar) is open the url in konqueror and drag-and-drop the tiny icon in front of the url in location bar to the desktop and choose link here.

After that you can access the page just clicking on the icon in Desktop.

regards,

Thanks for the response Marozzsas.
I am not looking for a short-cut. I am looking for a link so that my mail users d not have to type the actual path.

i.e. http://www.hingedmind.com/squirrelma.../src/login.php ---> http://www.hingedmind.com/mindmail

I am beginning to think this is an Apache question....
 
Old 01-24-2006, 06:29 AM   #4
nx5000
Senior Member
 
Registered: Sep 2005
Location: Out
Posts: 3,307

Rep: Reputation: 55
Yes that's an apache question, exactly.

You need to use an Alias directive

if the destination is out of DocumentRoot you also need to put this directory somewhere in the configuration (I can't remember the exact direcctive for this one sorry)

edit:
look here
http://www.linuxquestions.org/questi...d.php?t=406893

Last edited by nx5000; 01-24-2006 at 06:47 AM.
 
Old 01-24-2006, 08:24 AM   #5
Sapient
Member
 
Registered: Oct 2003
Location: San Luis Obispo, CA
Distribution: SuSE
Posts: 196

Original Poster
Rep: Reputation: 30
Apache directive

What am I doing wrong here?

I simply want to go here http://www.hingedmind.com/folder/mail/login.php ---> when this is typed http://www.hingedmind.com/webmail

Alias /webmail/ "/srv/www/htdocs/hingedmind/folder/mail/"
<Directory "/srv/www/htdocs/hingedmind/folder/mail">
Options Indexes MultiViews
AllowOverride None
Order allow,deny
Allow from all
DirectoryIndex index.php
</Directory>
 
Old 01-24-2006, 09:19 AM   #6
nx5000
Senior Member
 
Registered: Sep 2005
Location: Out
Posts: 3,307

Rep: Reputation: 55
Code:
<Directory "/srv/www/htdocs/hingedmind/folder/mail/">
He's very picky about directory names

I think this is the problem.
 
Old 01-24-2006, 09:45 AM   #7
Sapient
Member
 
Registered: Oct 2003
Location: San Luis Obispo, CA
Distribution: SuSE
Posts: 196

Original Poster
Rep: Reputation: 30
I changed a few things. Still no luck. I get an "Object not found" error in the browser when I attempt to http://www.hingedmind.com/webmail. Also the URL changes to

http://www.hingedmind.com/index.php

Alias /webmail "/srv/www/htdocs/hingedmind/folder/mail/"
<Directory "/srv/www/htdocs/hingedmind/folder/mail/">
Options Indexes Includes FollowSymLinks SymLinksifOwnerMatch ExecCGI MultiViews
DirectoryIndex index.php redirect.php login.php
AllowOverride None
Order allow,deny
Allow from all
</Directory>
 
Old 01-24-2006, 09:55 AM   #8
nx5000
Senior Member
 
Registered: Sep 2005
Location: Out
Posts: 3,307

Rep: Reputation: 55
Are you sure the destination exists and you can access it?
I mean, assuming Documentroot is /srv/www/htdocs/hingedmind , it seems that
http://www.hingedmind.com/folder/mail/
does not work (took the permission to go on your website
?
 
Old 01-24-2006, 09:55 AM   #9
KimVette
Senior Member
 
Registered: Dec 2004
Location: Lee, NH
Distribution: OpenSUSE, CentOS, RHEL
Posts: 1,794

Rep: Reputation: 46
You need to enable the FollowSymLinks option. See:

http://httpd.apache.org/docs/1.3/mod/core.html
 
Old 01-24-2006, 10:01 AM   #10
nx5000
Senior Member
 
Registered: Sep 2005
Location: Out
Posts: 3,307

Rep: Reputation: 55
as I said in a previous post , I think you only need a directory directive if it is outside your docroot.
Its been a while I've not used the amazing apache, so correct me if Im wrong..
 
Old 01-24-2006, 06:13 PM   #11
Sapient
Member
 
Registered: Oct 2003
Location: San Luis Obispo, CA
Distribution: SuSE
Posts: 196

Original Poster
Rep: Reputation: 30
Thanks KimVette and nx5000,
I should explain a little more about the configuration. I used obscure names to keep it simple. I want to call squirrelmail from the browser http://www.hingedmind.com/minmail

The actual path is srv/www/htdocs/hingedmind/squirrelmail-1.4.5/src or http://www.hingedmind.com/squirrelma.../src/login.php

The document root is /srv/www/hrdocs/hingedmind (I should change this to /srv/www/htdocs for virtual hosting). This does put squirrelmail within the document root (to answer your queston nx5000).

Current configuration: I looked at the directives page and in particular FollowSymLinks and it was enabled earlier (unless I am not seeing what you are pointing to).

Alias /mindmail "/srv/www/htdocs/hingedmind/squirrelmail-1.4.5/src"

<Directory "/srv/www/htdocs/hingedmind/squirrelmail-1.4.5/src">
Options Indexes FollowSymLinks
DirectoryIndex index.php redirect.php login.php
AllowOverride None
Order allow,deny
Allow from all
</Directory>
 
Old 01-25-2006, 05:44 AM   #12
Sapient
Member
 
Registered: Oct 2003
Location: San Luis Obispo, CA
Distribution: SuSE
Posts: 196

Original Poster
Rep: Reputation: 30
Perhaps a virtual host is needed.
 
Old 01-25-2006, 06:01 AM   #13
nx5000
Senior Member
 
Registered: Sep 2005
Location: Out
Posts: 3,307

Rep: Reputation: 55
No need for virtual host.

What you did should work, I don't get it.
Did you look at the logs?

*IF* you use the other method of a symbolical link (you have minmail a link to squirelmail/src) then the FollowSymLink has to be for the documentRoot , not for the destination!
 
Old 01-25-2006, 06:21 AM   #14
Sapient
Member
 
Registered: Oct 2003
Location: San Luis Obispo, CA
Distribution: SuSE
Posts: 196

Original Poster
Rep: Reputation: 30
Apache2 Error Log: (this is all that is showing in any logs).

[Wed Jan 25 04:14:39 2006] [error] [client 24.176.227.138] client denied by server configuration: /srv/www/squirrelmail-1.4.5

hmmm the path is weird...
 
Old 01-25-2006, 10:20 PM   #15
Sapient
Member
 
Registered: Oct 2003
Location: San Luis Obispo, CA
Distribution: SuSE
Posts: 196

Original Poster
Rep: Reputation: 30
I am not sure why the logs are reflecting that path. Should the root directory go up a level?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Wireless Network Link Established - No webpage though mrh7184 Linux - Wireless Networking 6 10-04-2005 11:49 PM
OpenBSD 3.6 install D-Link 300T / D-Link DFE 528TX lesleyb *BSD 2 04-01-2005 06:29 PM
Wake on Lan - Link on b4 power up, No Link light after shutdown? Mark007 Linux - Networking 0 11-20-2004 08:16 PM
Help with webpage lockejr Linux - General 16 03-28-2003 09:16 AM
eth1... failed; no link present. Check Link? illegalien Linux - Networking 3 11-03-2002 10:46 PM


All times are GMT -5. The time now is 08:32 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration