LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 04-23-2006, 12:27 AM   #1
blazted
Member
 
Registered: Nov 2004
Distribution: Red Hat Version 9 / Attempting to use Gentoo
Posts: 48

Rep: Reputation: 15
Linux Wireless Help


I am trying to set up my Linux Ethernet with my wireless connection at home. I am using Fedora Core. The network card has installed with no problem. I actually installed this quite a while ago and never bothered with setting up the connection. Now I dont have a wired port and need the wireless but I have not used Linux in over 6 months so am quite a bit rusty.

So I go to my network settings and I have two listigs there. One is eth0 and the other is wifi0. I go and edit the properties for my wifi0 connection and leave all settings defualt then go to wireless and change the SSID specified and set it to my home network name. I leave the channel and transmit to default (1 and auto) then in the KEy enter my encryption key I have set for my wireless network at home. I then save the config and activate.

Immediately I get a error message saying
"Error for Wireless request "Set Mode (8B06)"
Set failed on device wifi0:Invalid argument"
"Error for Wireless request "Set Mode (8B2A)"
Set failed on device wifi0:Invalid argument"

Determining IP information for wifi0.... failed

I dont know what to do here. I am very rusty of my linux and dont knwo what to set.

Thanks in advance.

Edit: When I go to a terminal and use the ifconfig I get a command not found. I just updated my core to version 5. I do not have any other NIC card except for my wireless.

Last edited by blazted; 04-23-2006 at 12:36 AM.
 
Old 04-23-2006, 12:56 AM   #2
celejar
Member
 
Registered: Oct 2003
Location: New York
Distribution: Debian Sid
Posts: 185

Rep: Reputation: 30
Ifconfig may not be in the path of non-root users. You'll need to be root to change anything via ifconfig, but to just get the card info try /sbin/ifconfig (or wherever ifconfig is on your system - try 'apropos ifconfig' or 'which ifconfig').
What chipset is the wirelss card? What does 'iwconfig wifi0' show?
 
Old 04-23-2006, 01:06 AM   #3
blazted
Member
 
Registered: Nov 2004
Distribution: Red Hat Version 9 / Attempting to use Gentoo
Posts: 48

Original Poster
Rep: Reputation: 15
I am not sure the chipset of the card. Its been a while and I know it works and looks like Linux is seeing it and reading it fine.

Using iwconfig wifi0 I get a Access point Invalid and Encryption Key Off and a Invalid MISC of 1797. These are the only points I can see that make sense. The rest is the db and stuff. I entered a Encryption key and SSID in the properties of the network card. I dont know why this is showing this?

Sorry if I am confused. I have to work with Windows at work and i am rusty at this and have totally forgot a lot of my Linux.

Edit: When I set my SSID to Auto I get a message saying

"Error for Wireless request "Set Mode (8B06)"
Set failed on device wifi0:Invalid argument"
"Error for Wireless request "Set Mode (8B2A)"
Set failed on device wifi0:Invalid argument"

Determining IP information for wifi0.... dhclient
(32596) is already running - exiting
exiting
failed.

I have tried the setup both on et0 and wifi0 and the same results.

Last edited by blazted; 04-23-2006 at 01:15 AM.
 
Old 04-23-2006, 02:14 AM   #4
celejar
Member
 
Registered: Oct 2003
Location: New York
Distribution: Debian Sid
Posts: 185

Rep: Reputation: 30
I don't know what is going on; some of this stuff could depend on the driver, which is why I asked for the chipset. Try reading your driver's docs. Sorry that I have nothing better to say.
 
Old 04-25-2006, 12:46 AM   #5
blazted
Member
 
Registered: Nov 2004
Distribution: Red Hat Version 9 / Attempting to use Gentoo
Posts: 48

Original Poster
Rep: Reputation: 15
The wireless card i have is a Dell 4800 LT made by Aironet. The back says Cisco Systems PCIC4805LT.

I dont know if it installed correctly as I forgot how to check to see if it is in Linux. Its not like Windows where you can check the properties.

Thanks for the help.
 
Old 04-25-2006, 07:21 AM   #6
mjjzf
Member
 
Registered: Feb 2004
Location: Valby, Denmark / Citizen of the Web
Distribution: Slackware 14.1
Posts: 879

Rep: Reputation: 39
You should be able to see the chipset, if you run /sbin/lspci - and it shows up on the list.
 
Old 04-25-2006, 09:39 AM   #7
MoonMind
Member
 
Registered: May 2005
Location: Switzerland
Distribution: Ubuntu
Posts: 448

Rep: Reputation: 38
OSourceDiplomat is right. However, I guess there are several problems you need to solve in a reasonable order (I don't want to sound patronising, but I'll try to cover it extensively - please bear with me).

As far as I can see, you tried most of the following steps, but something may have gone wrong somewhere. It's also possible that iwconfig can't talk to your card - indicating that there's indeed a driver/kernel module problem. Try this procedure:

1) Be root; I don't know how your system is set up, but this means either using the su command and entering your root password or using sudo with or without password, depending on your system. Whichever you choose, make sure to work in a consistent way (you needn't logout and login again as root). Well, you'll know how to do that.

2) Use lspci (OSourceDiplomat gave the path just in case) to determine the exact chipset your adaptor is using. This will help you find out if the kernel module is loaded and/or available on (or for) your system.

3.) Use lsmod to determine if the appropriate kernel module (driver) is loaded.

3.1) If not, you can try to load it with modprobe <yourmodule>. You can look for it in /lib/modules/<yourkernel>/net/wireless or /lib/modules/<yourkernel>/drivers/net - or any other appropriate subdirectory of /lib/modules/<yourkernel>. If it's not present on your system, this won't work and you'll need to get the driver (an existing kernel module or a set of such modules) first via your distributions package management or downloading it, possibly compiling it for your kernel. Look here for more information: http://tools.cisco.com/support/downl...utype=wireless.

3.2) You can also install ndiswrapper. In this case you'll also have to get hold of a suitable WinDoze driver for your wireless adaptor. The rest is done according to man ndiswrapper (it's really easy). But since there are kernel modules for Aironet cards, I'd rather recommend to stick to 3)

4) Use iwconfig wifi0 to have a look at the current setup of your wifi connection. If the driver's there, you'll see some basic configuration information, nothing spectacular (you more or less reported on that already). If you see some cryptic error codes, the driver's still missing. This means: Go back to 3)

5.1) Use iwconfig wifi0 essid <youressid>. This is a) necessary if it's not set and b) a good test if things work correctly (you did something similar already). If things fail here, it's time to look for further advice (which you did). If in doubt, go back to 3)

5.2) Use iwconfig wifi0 mode <yourmode>.

5.3) Use iwconfig wifi0 channel <yourchannel>.

5.4) Use iwconfig wifi0 key <yourkeymode> <yourkey>.

(You can do 5.1 to 5.4 in one sweep, but in order to determine what goes wrong where, I'd do it step by step. You may also need additional steps here, depending on your setup.)

6) Use ifconfig wifi0 up; if this fails, you might have to use ifconfig eth0 down first, but this shouldn't be the case (but it might if you're already connected to your LAN via ethernet). See 10) though.

7) Use dhclient wifi0; if you get another error message, you might have to do kill <dhclient-pid> first (it's given in the error message IIRC - one of your posts shows that). If you're not sure about the PID, use ps -ef | less to find it. If dhclient works correctly, you're online.

Last edited by MoonMind; 04-27-2006 at 06:04 PM.
 
Old 04-26-2006, 11:03 PM   #8
blazted
Member
 
Registered: Nov 2004
Distribution: Red Hat Version 9 / Attempting to use Gentoo
Posts: 48

Original Poster
Rep: Reputation: 15
Doing a lspci gives me a Aironet Wireles Cisco Aeronet 340 80
2.11b Wirless Lan Adapter/Aironet PC4800.

I dont know what I am looking for in lsmod. I see a airo 64609 0 in there so I am assuming this is what I am looking for.

Going into wirless directory I have a airo_cs.ko and a airo.ko

But when I do a modprobe on either one I get a module not found error.

Not sure what to do here? I got this card because it is supposed to be compatable with Linux and my friend said it should work. Not sure why it isnt working here.

Thank you
 
Old 04-27-2006, 04:03 PM   #9
blazted
Member
 
Registered: Nov 2004
Distribution: Red Hat Version 9 / Attempting to use Gentoo
Posts: 48

Original Poster
Rep: Reputation: 15
Bump for any help.

I tried these with what i have even though I dont think it is setup

.2) Use iwconfig mode <yourmode>.

5.3) Use iwconfig channel <yourchannel>.

5.4) Use iwconfig key <yourkeymode> <yourkey>.

But when I do a iwconfig Managed or Auto it gives me error. What are the modes here to use and what are the channel options to use?
 
Old 04-27-2006, 05:00 PM   #10
AwesomeMachine
Senior Member
 
Registered: Jan 2005
Location: USA and Italy
Distribution: Debian testing/sid; OpenSuSE; Fedora
Posts: 1,829

Rep: Reputation: 257Reputation: 257Reputation: 257
You probably picked up another wireless network with your wireless card when you were setting it up. This happens from time to time. You have to go in the wireless card configuration and delete the other wireless network from the configuration. Then, set up connection to your router if it isn't already done. I've had this happen. It is a total trip.
 
Old 04-27-2006, 06:04 PM   #11
MoonMind
Member
 
Registered: May 2005
Location: Switzerland
Distribution: Ubuntu
Posts: 448

Rep: Reputation: 38
blazted:

I'm very sorry, the 5.x entries contained a stupid error - I forgot the mention the interface! I've corrected that above; generally, it should read:

iwconfig <yourinterface> <command> <option> (<yourinterface> being "wifi0" IIRC)

Here's a full man page for iwconfig: http://www.die.net/doc/linux/man/man8/iwconfig.8.html

Your kernel drivers are loaded (that's the "airo" entry in lsmod you mentioned - I'm not sure if "airo_cs" is needed or not); so AwesomeMachine's idea's not at all bad. But please, try the corrected iwconfig commands first - if the recipe doesn't work, I'd like to find out why.

Last edited by MoonMind; 04-27-2006 at 06:25 PM.
 
Old 04-27-2006, 10:48 PM   #12
blazted
Member
 
Registered: Nov 2004
Distribution: Red Hat Version 9 / Attempting to use Gentoo
Posts: 48

Original Poster
Rep: Reputation: 15
Thank you for the help.

I have tried using the iwconfig command to set my settings.

The iwconfig wifi0 mode Mananged worked
The iwconfig wifi0 essid (ESSID) worked
The iwconfig wifi0 channel does not work. I tried setting it to auto but it still gives me a error I dont know what frequency to set it to but everything I try fails.

The iwconfig key (MY WEP KEY) seem to work but doesn't. I am using a 26 ASCII Key that was generated by Router. When I do iwconfig wifi0 (WEP KEY) It takes it. I also havw tried using iwconfig wifi0 key SMY WEP KEY) and this gives me a invalid argument error. Just setting a ASCI key seems to work but when I do a iwconfig I see Encryption Key set to off still. My Frequency is set to 2.412. My Access point still says Invalid. I dont know what to set this too.
 
Old 04-28-2006, 11:19 AM   #13
MoonMind
Member
 
Registered: May 2005
Location: Switzerland
Distribution: Ubuntu
Posts: 448

Rep: Reputation: 38
That's odd, but now I recall having had that WEP problem, too when I was testing PCLinuxOS 0.93 miniME lately. From what happened there (the problem went away after changing WLAN adapters), I consider it possible that you're still not over that driver issues you suffered from. So maybe trying out some other adapter/pc card would reveal something, but I can't tell if that's an option for you.

If I'm not mistaken, only one of the two available kernel modules for the Aironet adapter was displayed as used by lsmod - for me, it looks as if some part of the functionality wasn't available. I don't know what airo_cs would do, though...

The 26 ASCII character version of the key is the one you should be using, so that's not the problem (I guess), it's more part of a solution (I hope). So for the moment, stick to it (even if it's not [yet] working).

About the "channel" thing: The man page of iwconfig has some information about frequencies and channels - if you use freq instead of channel, you can set your frequency (instead of a channel number).
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
wireless on Linux dying when I bring another wireless device in the LAN sal_paradise42 Linux - Wireless Networking 5 11-14-2004 04:38 AM


All times are GMT -5. The time now is 12:52 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration