LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-22-2004, 04:56 AM   #1
paschim
Member
 
Registered: Apr 2004
Location: UK, south london
Posts: 51

Rep: Reputation: 15
linux sound configure


Can anyone tell me how (what commands) will i configure sound card in suse9

Thanks.
 
Old 10-22-2004, 06:59 AM   #2
Peacedog
LQ Guru
 
Registered: Sep 2003
Location: Danville, VA
Distribution: Slackware, Windows, FreeBSD, OpenBSD, Mac OS X
Posts: 5,296

Rep: Reputation: 168Reputation: 168
I'm not a suse guy, have not had the pleasure of a suse install yet, but from reading, most suse users do this from yast. Could you post the output of /sbin/lspci -v, and lsmod please? Have you tried running a mixer and unmuting your sound?
good luck.
 
Old 10-22-2004, 10:29 AM   #3
paschim
Member
 
Registered: Apr 2004
Location: UK, south london
Posts: 51

Original Poster
Rep: Reputation: 15
Many thanks peacedog my lsmod is as follows
linux:~ # lsmod
Module Size Used by Not tainted
snd-seq 36656 1 (autoclean)
videodev 5696 0 (autoclean)
agpgart 42040 6 (autoclean)
isa-pnp 30664 0 (unused)
usbserial 18620 0 (autoclean) (unused)
parport_pc 26248 1 (autoclean)
lp 6208 0 (autoclean)
parport 22888 1 (autoclean) [parport_pc lp]
ipv6 209952 -1 (autoclean)
key 63256 0 (autoclean) [ipv6]
snd-intel8x0 19588 4
thermal 6148 0 (unused)
snd-pcm 65092 0 [snd-intel8x0]
snd-timer 15040 0 [snd-seq snd-pcm]
snd-ac97-codec 39608 0 [snd-intel8x0]
processor 8248 0 [thermal]
snd-mpu401-uart 3584 0 [snd-intel8x0]
snd-rawmidi 14208 0 [snd-mpu401-uart]
fan 1472 0 (unused)
snd-seq-device 4048 0 [snd-seq snd-rawmidi]
snd-page-alloc 6004 0 [snd-intel8x0 snd-pcm]
button 2380 0 (unused)
snd 35172 4 [snd-seq snd-intel8x0 snd-pcm snd-timer snd-ac97-codec snd-mpu401-uart snd-rawmidi snd-seq-device]
battery 5600 0 (unused)
soundcore 3588 0 [snd]
ac 1664 0 (unused)
st 27760 0 (autoclean) (unused)
sr_mod 13432 0 (autoclean)
sg 32224 0 (autoclean)
keybdev 1996 0 (unused)
mousedev 4084 0 (unused)
joydev 5120 0 (unused)
evdev 3584 0 (unused)
input 3360 0 [keybdev mousedev joydev evdev]
usb-uhci 22224 0 (unused)
ehci-hcd 16588 0 (unused)
usbcore 58668 1 [usbserial usb-uhci ehci-hcd]
raw1394 16592 0 (unused)
ieee1394 183364 0 [raw1394]
8139too 13932 1
mii 2320 0 [8139too]
ide-scsi 10000 0
scsi_mod 97108 4 [st sr_mod sg ide-scsi]
ide-cd 29664 0
cdrom 26752 0 [sr_mod ide-cd]
nls_iso8859-1 2812 3 (autoclean)
ntfs 74924 3 (autoclean)
reiserfs 199476 1
 
Old 10-22-2004, 10:34 AM   #4
paschim
Member
 
Registered: Apr 2004
Location: UK, south london
Posts: 51

Original Poster
Rep: Reputation: 15
my /sbin/lspci -v is as follows.

00:00.0 Host bridge: Intel Corp. 82845G/GL [Brookdale-G] Chipset Host Bridge (re
v 03)
Subsystem: Trigem Computer Inc.: Unknown device 3189
Flags: bus master, fast devsel, latency 0
Memory at ec000000 (32-bit, prefetchable) [size=64M]
Capabilities: [e4] #09 [1105]

00:02.0 VGA compatible controller: Intel Corp. 82845G/GL [Brookdale-G] Chipset I
ntegrated Graphics Device (rev 03) (prog-if 00 [VGA])
Subsystem: Trigem Computer Inc.: Unknown device 3189
Flags: bus master, fast devsel, latency 0, IRQ 11
Memory at f0000000 (32-bit, prefetchable) [size=128M]
Memory at e8000000 (32-bit, non-prefetchable) [size=512K]
Capabilities: [d0] Power Management version 1

00:1d.0 USB Controller: Intel Corp. 82801DB USB (Hub #1) (rev 02) (prog-if 00 [U
HCI])
Subsystem: Trigem Computer Inc.: Unknown device 3189
Flags: bus master, medium devsel, latency 0, IRQ 11
I/O ports at 1800 [size=32]

00:1d.1 USB Controller: Intel Corp. 82801DB USB (Hub #2) (rev 02) (prog-if 00 [U
HCI])
Subsystem: Trigem Computer Inc.: Unknown device 3189
Flags: bus master, medium devsel, latency 0, IRQ 10
I/O ports at 1820 [size=32]

00:1d.2 USB Controller: Intel Corp. 82801DB USB (Hub #3) (rev 02) (prog-if 00 [U
HCI])
Subsystem: Trigem Computer Inc.: Unknown device 3189
Flags: bus master, medium devsel, latency 0, IRQ 3
I/O ports at 1840 [size=32]

00:1d.7 USB Controller: Intel Corp. 82801DB USB2 (rev 02) (prog-if 20 [EHCI])
Subsystem: Trigem Computer Inc.: Unknown device 3189
Flags: bus master, medium devsel, latency 0, IRQ 9
Memory at e8080000 (32-bit, non-prefetchable) [size=1K]
Capabilities: [50] Power Management version 2

00:1e.0 PCI bridge: Intel Corp. 82801BA/CA/DB/EB PCI Bridge (rev 82) (prog-if 00
[Normal decode])
Flags: bus master, fast devsel, latency 0
Bus: primary=00, secondary=02, subordinate=02, sec-latency=32
I/O behind bridge: 00002000-00002fff
Memory behind bridge: e8100000-e81fffff

00:1f.0 ISA bridge: Intel Corp. 82801DB LPC Interface Controller (rev 02)
Flags: bus master, medium devsel, latency 0

00:1f.1 IDE interface: Intel Corp. 82801DB Ultra ATA Storage Controller (rev 02)
(prog-if 8a [Master SecP PriP])
Subsystem: Trigem Computer Inc.: Unknown device 3189
Flags: bus master, medium devsel, latency 0, IRQ 3
I/O ports at <unassigned>
I/O ports at <unassigned>
I/O ports at <unassigned>
I/O ports at <unassigned>
I/O ports at 1860 [size=16]
Memory at 30000000 (32-bit, non-prefetchable) [size=1K]

00:1f.3 SMBus: Intel Corp. 82801DB/DBM SMBus Controller (rev 02)
Subsystem: Trigem Computer Inc.: Unknown device 3189
Flags: medium devsel, IRQ 9
I/O ports at 1880 [size=32]

00:1f.5 Multimedia audio controller: Intel Corp. 82801DB AC'97 Audio Controller
(rev 02)
Subsystem: Trigem Computer Inc.: Unknown device 3189
Flags: bus master, medium devsel, latency 0, IRQ 9
I/O ports at 1c00 [size=256]
I/O ports at 18c0 [size=64]
Memory at e8080c00 (32-bit, non-prefetchable) [size=512]
Memory at e8080800 (32-bit, non-prefetchable) [size=256]
Capabilities: [50] Power Management version 2

02:02.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139 C+ (rev 10)
Subsystem: Trigem Computer Inc.: Unknown device 3189
Flags: bus master, medium devsel, latency 64, IRQ 9
I/O ports at 2000 [size=256]
Memory at e8110000 (32-bit, non-prefetchable) [size=256]
Capabilities: [50] Power Management version 2

02:0a.0 Ethernet controller: 3Com Corporation 3c905 100BaseTX [Boomerang]
Flags: bus master, medium devsel, latency 64, IRQ 11
I/O ports at 2400 [size=64]
Expansion ROM at <unassigned> [disabled] [size=64K]

02:0b.0 Communication controller: Conexant HSF 56k HSFi Modem (rev 01)
Subsystem: Mac System Co Ltd: Unknown device 8d8b
Flags: bus master, medium devsel, latency 64, IRQ 9
Memory at e8100000 (32-bit, non-prefetchable) [size=64K]
I/O ports at 2440 [size=8]
Capabilities: [40] Power Management version 2
 
Old 10-22-2004, 10:45 AM   #5
Peacedog
LQ Guru
 
Registered: Sep 2003
Location: Danville, VA
Distribution: Slackware, Windows, FreeBSD, OpenBSD, Mac OS X
Posts: 5,296

Rep: Reputation: 168Reputation: 168
It appears that the modules are all loaded. Have you tried any mixers, to see if your sound is muted? Have you tried different file formats?
good luck.
 
Old 10-22-2004, 05:09 PM   #6
paschim
Member
 
Registered: Apr 2004
Location: UK, south london
Posts: 51

Original Poster
Rep: Reputation: 15
Hi peacedog thanks again. May I know what is mixture and what other fileformatshould I change?

Isn't that iso9660 is a fileformat is a file format to CD's. Iam so glad and thankful to you peacedog. I atleast have a gut to go for linux now. some hope.

help me pls.
 
Old 10-22-2004, 05:13 PM   #7
Peacedog
LQ Guru
 
Registered: Sep 2003
Location: Danville, VA
Distribution: Slackware, Windows, FreeBSD, OpenBSD, Mac OS X
Posts: 5,296

Rep: Reputation: 168Reputation: 168
From a terminal issue alsamixer, or from the gui try kmix, or aumix. Your mixers work very much like the volume control in windows, but, with more fiunctionality. Once you've got one of them open, try unmuting the volume and raising it. Different file formats refer to *.wav, *.mp3, etc.
good luck.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Configure sound in FC 3 DanielTan Linux - Newbie 22 06-08-2005 07:55 PM
help configure my sound Squall__99 Mandriva 1 05-26-2005 08:19 PM
Keyboard and moust not working in linux after configure sound card 012633023 Linux - Newbie 11 01-25-2005 09:57 AM
how do I configure sound in 9.1? walterbyrd Slackware - Installation 2 04-11-2004 07:05 PM
can't configure sound card in Red Hat Linux 8.0 Help Me!! manjula_rajan Linux - Hardware 1 03-17-2004 01:52 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 12:08 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration