LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-15-2006, 10:45 AM   #1
squimmy
Member
 
Registered: Jun 2005
Posts: 49

Rep: Reputation: 15
Linux sluggish?


I am haveing a few niggling problems with my new linux installation, mepis. First of all,I better mention that the first distribution I tried to install was ubuntu, but the install froze at something about usb.rc, so when it came to running mepis I was very surprised when it said:

checking usb support
done.

Surprised but pleased.
Secondly the install took close to an hour, and whilst it was installing the the system was not responding at all. I couldn't move the mouse. Now I'm in an install, it is very sluggish. When it first boots into the desktop, the mouse is extremely sluggish and hard to control. Secondly, whenever I do anything mildly large, the system stops responging. i.e when extracting firefox, the system wasn't responding at all. This makes doing anything extremely difficult.

This is my third ever install of linux, and all three times I have had a hard time getting it to work properly. I don't know why, but I am determined to have a good working installation of linux.

So please tell me there is a way to speed things up, mepis is unusable like this, and my system specs are not to blame (amd 64 3200, 1gb ram,1gb swap,ati x800(squared))

Thank you.
 
Old 01-15-2006, 11:29 AM   #2
Brian1
LQ Guru
 
Registered: Jan 2003
Location: Seymour, Indiana
Distribution: Distribution: RHEL 5 with Pieces of this and that. Kernel 2.6.23.1, KDE 3.5.8 and KDE 4.0 beta, Plu
Posts: 5,700

Rep: Reputation: 62
When the system is up run the command top to see what app or daemon is a powerhog?
Also when top is running check your memory use and swap use?

If you just started up it should not really be using swap yet since you have a gig of real memory. Also a gig for swap is quite large these days. It used to be define to be twice the size as your real memeory. But that was in the days of 32 meg machines and ram cost was extremely expensive. 256meg swap would be quite good enough.

Are you installing a 64bit version of linux? or 32bit?
If trying 64bit you might install a 32 bit version to see if it works better?
It may just be some kind of conflict in the hardware.
Have you tried using a Live CD, ubuntu has a 64bit and a 32bit version. You might try both of them and run comparsion test to find out what is causing the sluggish ness.

Good luck
Brian1
 
Old 01-15-2006, 01:43 PM   #3
squimmy
Member
 
Registered: Jun 2005
Posts: 49

Original Poster
Rep: Reputation: 15
I am running the 32 bit version of mepis. Could it be something to do with my hard drive / partition because the only time it slowed down in the live cd was when installing or working with the hard drive.
 
Old 01-15-2006, 02:38 PM   #4
Brian1
LQ Guru
 
Registered: Jan 2003
Location: Seymour, Indiana
Distribution: Distribution: RHEL 5 with Pieces of this and that. Kernel 2.6.23.1, KDE 3.5.8 and KDE 4.0 beta, Plu
Posts: 5,700

Rep: Reputation: 62
Look into the command hdparm. Look it up here and on google for many options one could use.
 
Old 01-15-2006, 03:02 PM   #5
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 23,066
Blog Entries: 11

Rep: Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910
Quote:
Originally Posted by squimmy
So please tell me there is a way to speed things up, mepis is unusable like this, and my system specs are not to blame (amd 64 3200, 1gb ram,1gb swap,ati x800(squared))
What motherboard, chipset?


Cheers,
Tink
 
Old 01-16-2006, 08:59 AM   #6
sundialsvcs
LQ Guru
 
Registered: Feb 2004
Location: SE Tennessee, USA
Distribution: Gentoo, LFS
Posts: 7,151

Rep: Reputation: 2203Reputation: 2203Reputation: 2203Reputation: 2203Reputation: 2203Reputation: 2203Reputation: 2203Reputation: 2203Reputation: 2203Reputation: 2203Reputation: 2203
hdparm controls a lot of things about exactly how the system accesses the disk drive. These parameters are usually set-up during startup, in various ways depending on your system.

If you find that DMA is Off, this alone can make the computer operate like a slug.
 
Old 01-16-2006, 10:37 AM   #7
gri6507
LQ Newbie
 
Registered: Jun 2005
Location: Cleveland, OH
Distribution: PCLinuxOS
Posts: 22

Rep: Reputation: 15
ATI fglrx

I had something similar on my machine originally. It turned out that hardware acceleration for the video card was not turned on. You can check that by running "glxinfo" and look at the "direct rendering" line. If it says "No", then you don't have hardware acceleration.

I am not familiar with Mepis, but my guess would be that you are likely not running the fglrx driver. If your control center, you should be able to reselect your video driver to fglrx and everything should work. If however it does not, then it is likely that you don't have the fglrx kernel module installed (you should see an error message in /var/log/X*). If that's the case, then you must install the fglrx driver from ATI website (note, you will likely have to get the source code for your kernel version in order for that install to work - I believe that in Mepis, Synaptic should have that).
 
Old 01-16-2006, 02:30 PM   #8
squimmy
Member
 
Registered: Jun 2005
Posts: 49

Original Poster
Rep: Reputation: 15
hardware acceleration is not enabled. I have a 'odd' graphics card. I have an ati x800 gto squared,windows sees it as a x800/x850. I did try enablind fglrx, but got back a bunch of errors and I had to go through the live cd to return it to normal settings.

Is there a way I can somehow configure fglrx to work? Or should I download the latest version of it?

Thanks.
 
Old 01-16-2006, 02:58 PM   #9
gri6507
LQ Newbie
 
Registered: Jun 2005
Location: Cleveland, OH
Distribution: PCLinuxOS
Posts: 22

Rep: Reputation: 15
Just go through ATI's website and get their installer. (just make sure to read my note about the kernel source above)
 
Old 01-16-2006, 03:11 PM   #10
squimmy
Member
 
Registered: Jun 2005
Posts: 49

Original Poster
Rep: Reputation: 15
Before I go into this, does this involve recompiling the kernel?
 
Old 01-16-2006, 03:15 PM   #11
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 23,066
Blog Entries: 11

Rep: Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910
Before you go spending lots of time on the graphics: that wouldn't
explain why the install took so long; and it raises the issue of
the chipset, again. If you happened to be one of the unlucky sods
with a VT8251 southbridge your PATA drives (both CD/DVD and HDDs)
won't be running with DMA for starters (unless your installation
CD has a 2.6.15 kernel which fixes this ONE problem with that
chipset).


Cheers,
Tink
 
Old 01-16-2006, 04:03 PM   #12
squimmy
Member
 
Registered: Jun 2005
Posts: 49

Original Poster
Rep: Reputation: 15
Using a windows diagnostic program, this is my chipset:

http://xs64.xs.to/pics/06031/show_diag.PNG

Last edited by squimmy; 01-16-2006 at 04:04 PM.
 
Old 01-16-2006, 04:49 PM   #13
squimmy
Member
 
Registered: Jun 2005
Posts: 49

Original Poster
Rep: Reputation: 15
here is hdparm:

root@1[~]# hdparm -Tt /dev/hda

/dev/hda:
Timing cached reads: 3480 MB in 2.00 seconds = 1739.39 MB/sec
Timing buffered disk reads: 4 MB in 3.46 seconds = 1.16 MB/sec
root@1[~]# hdparm /dev/hda

/dev/hda:
multcount = 16 (on)
IO_support = 0 (default 16-bit)
unmaskirq = 0 (off)
using_dma = 0 (off)
keepsettings = 0 (off)
readonly = 0 (off)
readahead = 256 (on)
geometry = 19457/255/63, sectors = 312581808, start = 0
 
Old 01-16-2006, 05:02 PM   #14
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 23,066
Blog Entries: 11

Rep: Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910
Quote:
Originally Posted by squimmy
here is hdparm:

root@1[~]# hdparm -Tt /dev/hda

/dev/hda:
Timing cached reads: 3480 MB in 2.00 seconds = 1739.39 MB/sec
Timing buffered disk reads: 4 MB in 3.46 seconds = 1.16 MB/sec
root@1[~]# hdparm /dev/hda

/dev/hda:
multcount = 16 (on)
IO_support = 0 (default 16-bit)
unmaskirq = 0 (off)
using_dma = 0 (off)
keepsettings = 0 (off)
readonly = 0 (off)
readahead = 256 (on)
geometry = 19457/255/63, sectors = 312581808, start = 0
Well, the RED bit explains it, then ... :/


Cheers,
Tink
 
Old 01-16-2006, 05:04 PM   #15
squimmy
Member
 
Registered: Jun 2005
Posts: 49

Original Poster
Rep: Reputation: 15
Should I turn it on? How do I turn it on? Is it risky?

EDIT:: If I was to turn dma on, could it, in any way, corrupt data on my windows partitions, if I never write to them?

Thanks for the help! It's really appreciated!

Last edited by squimmy; 01-16-2006 at 05:20 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Sluggish linuxnubx Slackware 18 07-28-2004 04:27 AM
Sluggish performance w/ RH 7.3 theonlylivinggo Linux - Newbie 0 02-15-2004 09:13 PM
Linux sluggish !!! juby Linux - General 9 05-14-2003 01:44 AM
Sluggish Linux Kraggar Linux - Newbie 2 11-15-2001 03:01 PM
Why is my Linux so sluggish? Kraggar Linux - General 2 11-14-2001 08:05 PM


All times are GMT -5. The time now is 04:48 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration