LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-25-2003, 03:26 PM   #1
Spytap
LQ Newbie
 
Registered: May 2003
Posts: 13

Rep: Reputation: 0
Linux screen rez question


Okay, I just installed Red hat 9, and the scren rez by default is 1024x768. My monitor, however, is a Philips 170W 17" widescreen flat panel with a native resolution of 1280X768. I've tried going through the system settings, and editing my config file in the X11 folder, but nothing seems to work, it won't go tot he widescreen aspect ratio. now, admittedly, I don't really know much of what I'm doing (New to linux, under a week), so I'm asking if anyone knows how to force the system to run in 1280X768 mode?
 
Old 08-25-2003, 03:33 PM   #2
Skyline
Senior Member
 
Registered: Jun 2003
Distribution: Debian/other
Posts: 2,104

Rep: Reputation: 45
In /etc/X11/XF86Config in the the screen section under modes have you tried putting "1280x768" as the first entry - ie

Modes "1280x768" "800x600" "640x480"
 
Old 08-25-2003, 03:42 PM   #3
Spytap
LQ Newbie
 
Registered: May 2003
Posts: 13

Original Poster
Rep: Reputation: 0
Quote:
Originally posted by Skyline
In /etc/X11/XF86Config in the the screen section under modes have you tried putting "1280x768" as the first entry - ie

Modes "1280x768" "800x600" "640x480"
I did something similar, as it had [ "1024X768" "800x600" "640x480" ] (brackets mine) and I added "1280x768" in front of those three to make it [ "1280x768" "1024x768" "800x600" "640x480" ]
but that didn't seem to work, as the screensize remained at 1024x768. Am I only allowed three entries for that line?
 
Old 08-25-2003, 04:08 PM   #4
gizmogadgetus
Member
 
Registered: Aug 2003
Location: Texas
Distribution: Fedora Core 2
Posts: 71

Rep: Reputation: 15
Restarting X?

You might check the color depth you're running at versus these modeline entries. Those modelines are specific to their respective display sections in the XF86Config file. Check that each "Display" has this modeline first in the config file section. After you do this, try restarting X and see if that works
 
Old 08-31-2003, 04:21 PM   #5
Spytap
LQ Newbie
 
Registered: May 2003
Posts: 13

Original Poster
Rep: Reputation: 0
Well, I have the color settings right, as well as having gotten it to the point where the display settings window will show "1280x768" as an option, but it still won't actually go to the resolution of 1280x768. It says I need to restart the X server, but shouldn't a simple restart accomplish that or do I have to manually type a restart command in though the command line? This is a little bit frustrating for me because it shows my screen rez as an option, it just never actually switches to that resolution...
 
Old 08-31-2003, 06:35 PM   #6
gizmogadgetus
Member
 
Registered: Aug 2003
Location: Texas
Distribution: Fedora Core 2
Posts: 71

Rep: Reputation: 15
what do you mean by a simple restart? I usually just hit ctrl-alt-backspace to restart my XServer. There are other ways as well, but this seems easiest.
 
Old 08-31-2003, 06:46 PM   #7
Spytap
LQ Newbie
 
Registered: May 2003
Posts: 13

Original Poster
Rep: Reputation: 0
Quote:
Originally posted by gizmogadgetus
what do you mean by a simple restart? I usually just hit ctrl-alt-backspace to restart my XServer. There are other ways as well, but this seems easiest.
Tried that too, and though it still lists 1280x768 as an option, it doesn't actually change the rez to that...grrrrrrrrrr
 
Old 08-31-2003, 07:02 PM   #8
gizmogadgetus
Member
 
Registered: Aug 2003
Location: Texas
Distribution: Fedora Core 2
Posts: 71

Rep: Reputation: 15
try posting your XF86Config File, maybe someone can spot something
 
Old 09-01-2003, 04:44 AM   #9
Spytap
LQ Newbie
 
Registered: May 2003
Posts: 13

Original Poster
Rep: Reputation: 0
Quote:
Originally posted by gizmogadgetus
try posting your XF86Config File, maybe someone can spot something
Here it is in it's entirity; though I'll admit that as a noob, I understand little of it.

Section "ServerLayout"
Identifier "Default Layout"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"

# RgbPath is the location of the RGB database. Note, this is the name of the
# file minus the extension (like ".txt" or ".db"). There is normally
# no need to change the default.
# Multiple FontPath entries are allowed (they are concatenated together)
# By default, Red Hat 6.0 and later now use a font server independent of
# the X server to render fonts.
RgbPath "/usr/X11R6/lib/X11/rgb"
FontPath "unix/:7100"
EndSection

Section "Module"
Load "dbe"
Load "extmod"
Load "fbdevhw"
Load "glx"
Load "record"
Load "freetype"
Load "type1"
EndSection

Section "InputDevice"

# Specify which keyboard LEDs can be user-controlled (eg, with xset(1))
# Option "Xleds" "1 2 3"
# To disable the XKEYBOARD extension, uncomment XkbDisable.
# Option "XkbDisable"
# To customise the XKB settings to suit your keyboard, modify the
# lines below (which are the defaults). For example, for a non-U.S.
# keyboard, you will probably want to use:
# Option "XkbModel" "pc102"
# If you have a US Microsoft Natural keyboard, you can use:
# Option "XkbModel" "microsoft"
#
# Then to change the language, change the Layout setting.
# For example, a german layout can be obtained with:
# Option "XkbLayout" "de"
# or:
# Option "XkbLayout" "de"
# Option "XkbVariant" "nodeadkeys"
#
# If you'd like to switch the positions of your capslock and
# control keys, use:
# Option "XkbOptions" "ctrl:swapcaps"
# Or if you just want both to be control, use:
# Option "XkbOptions" "ctrl:nocaps"
#
Identifier "Keyboard0"
Driver "keyboard"
Option "XkbRules" "xfree86"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/input/mice"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "no"
EndSection

Section "InputDevice"

# If the normal CorePointer mouse is not a USB mouse then
# this input device can be used in AlwaysCore mode to let you
# also use USB mice at the same time.
Identifier "DevInputMice"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/input/mice"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "no"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "Philips 170W"
DisplaySize 370 220
HorizSync 30.0 - 64.0
VertRefresh 56.0 - 75.0
Option "dpms"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "radeon"
VendorName "Videocard vendor"
BoardName "ATI Radeon 8500LE"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Depth 16
Modes "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 24
Modes "1280x768" "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Section "DRI"
Group 0
Mode 0666
EndSection


I've also tried it where the subsection "display" reads:
SubSection "Display"
Depth 24
Modes "1280x768" "800x600" "640x480"
EndSubSection

...and that didn't work either.

Kinda frustrated at this point, because though I went out and bought three books on Linux to get started (and know Mac and Windows through and through), I can't even solve a simple problem like this...

Last edited by Spytap; 09-01-2003 at 04:50 AM.
 
Old 09-01-2003, 09:32 AM   #10
gizmogadgetus
Member
 
Registered: Aug 2003
Location: Texas
Distribution: Fedora Core 2
Posts: 71

Rep: Reputation: 15
Well, I don't see anything that just jumps out. You can try commenting out the DisplaySize 370 220 Line from the monitor section and you might try removing the Depth 16 Subsection from your Screen Section. I'll look at this some more, but nothing else really sticks out.
 
Old 09-01-2003, 03:41 PM   #11
Spytap
LQ Newbie
 
Registered: May 2003
Posts: 13

Original Poster
Rep: Reputation: 0
Thanks for the help, I appreciate it.
Is it possible that Linux at this point just doesn't work well enough with Widescreen monitors? Is it also possible, given the pervious statement, that it may be fixed/changed with the 2.6 kernel release?
 
Old 09-01-2003, 04:08 PM   #12
Kristic
LQ Newbie
 
Registered: Sep 2003
Distribution: RedHat9 / Mandrake 9.0
Posts: 19

Rep: Reputation: 0
Try changing the type of monitor you have, it may have not detected the right one and doesnt think your monitor supports that resolvtion and blocks it from being used. I had that problem just a few days ago
 
Old 09-26-2003, 07:03 PM   #13
skiloads
LQ Newbie
 
Registered: Sep 2003
Posts: 1

Rep: Reputation: 0
I was able to get 1280x768 up and going on my little Fujitsu.

I found the answer at http://www.geocities.com/aaahoopy
At the bottom of the page is the X configuration info that worked. The page talks about using RedHat 7.2 and editing the XF86Config-4 file. I'm using RedHat 9 which only has the XF86Config. I made the additions and edits to that file.

In the Section "Monitor" after the line Option "dpms" I added these lines:
Modeline "1024x768" 65 1024 1048 1184 1344 768 771 777 806 -hsync -vsync

Modeline "1280x1024" 108 1280 1328 1440 1688 1024 1025 1028 1066 +hsync +vsync

Modeline "1280x768" 108 1280 1328 1440 1688 768 771 777 806 +hsync -vsync

Next I changed the Modes line in the Section "Screen" to the following:
Modes "1280x768" "1024x768" "800x600"

After I rebooted I had the 1280x768 resolution I wanted.

Always make a backup first before making any edits in case you make a mistake.
 
Old 10-21-2003, 05:42 AM   #14
Spytap
LQ Newbie
 
Registered: May 2003
Posts: 13

Original Poster
Rep: Reputation: 0
YOU, sir, are a GOD!!!

In all seriousness, thank you so much.
Now, on to solving my mouse scrollwheel problem, and i'll consider myself set for the night
 
Old 03-02-2004, 10:25 AM   #15
Lucia
LQ Newbie
 
Registered: Mar 2004
Posts: 2

Rep: Reputation: 0
Hello!

does anyone know if the lines posted by skiloads to get the 1280x768 resolution work on Sony VAIO TR3A? In case, is there any risk to damage the LCD if I put wrong numbers in XF86Config?
I'm running Red Hat 9.0

Thanks
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
can't change screen rez in suse 9.3 from 640x480? murfman89 Linux - Newbie 3 07-02-2005 12:09 AM
Screen rez changes at log out mark_l_sanders Mandriva 1 10-20-2004 01:28 PM
KDE looks Distorted and Screen Rez ClericPreston Linux - Newbie 4 06-03-2004 02:55 AM
Changed monitor rez, now black screen? EnVoy Mandriva 3 11-18-2003 03:51 AM
error with my screen rez xylum Linux - General 5 08-11-2002 08:12 PM


All times are GMT -5. The time now is 10:37 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration