LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-03-2009, 06:50 PM   #1
peteyperson
Member
 
Registered: Jan 2009
Distribution: openSUSE 11.1, with KDE 4
Posts: 71

Rep: Reputation: 16
Linux openSUSE 11.1: How do you change digital clock to 12hrs?


I did it before, but cannot remember how.

Thanks for the help.
Petey
 
Old 02-03-2009, 07:18 PM   #2
rnturn
Senior Member
 
Registered: Jan 2003
Location: Illinois (Chicago area)
Distribution: Red Hat (8.0, RHEL5,6), CentOS, SuSE (10.x, 11.x, 12.2, 13.2), Solaris (8-10), Tru64, MacOS, Raspian
Posts: 1,108

Rep: Reputation: 64
Have you right-clicked on it? You should see a "Preferences..." option. Select that and change the clock from 24hr to 12hr. Then "Close".

The above is true for the panel clock under Gnome. I'm assuming it's similar for KDE as well.

Hope this helps...

--
Rick
 
Old 02-03-2009, 07:46 PM   #3
peteyperson
Member
 
Registered: Jan 2009
Distribution: openSUSE 11.1, with KDE 4
Posts: 71

Original Poster
Rep: Reputation: 16
Hi Rick,

I have 'Digital Clock Settings' but no option for 12 hours.

Petey

Quote:
Originally Posted by rnturn View Post
Have you right-clicked on it? You should see a "Preferences..." option. Select that and change the clock from 24hr to 12hr. Then "Close".

The above is true for the panel clock under Gnome. I'm assuming it's similar for KDE as well.

Hope this helps...

--
Rick
 
Old 02-03-2009, 09:58 PM   #4
jay73
LQ Guru
 
Registered: Nov 2006
Location: Belgium
Distribution: Ubuntu 11.04, Debian testing
Posts: 5,019

Rep: Reputation: 130Reputation: 130
I think rnturn meant right-clicking on the clock applet and then selecting "preferences".
 
Old 02-04-2009, 03:16 AM   #5
colucix
LQ Guru
 
Registered: Sep 2003
Location: Bologna
Distribution: CentOS 6.5 OpenSuSE 12.3
Posts: 10,509

Rep: Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976
1) Right-click on the clock
2) Select "Date And Time Format"
3) Select the "Times & Dates" tab
4) Change the Time Format selecting "HH:MM:SS" from the drop down menu
5) Click on Apply and/or Ok
6) Logout and Login, that is restart the X server.

In alternative to points 1) and 2) you can
1) Select Configure Desktop from the Geco menu
2) Select Regional & Accessibility from the menu on the left
3) Select Country/Region & Language from the menu on the left
4) Proceed as per points 3) to 6) above.
 
Old 02-04-2009, 01:29 PM   #6
peteyperson
Member
 
Registered: Jan 2009
Distribution: openSUSE 11.1, with KDE 4
Posts: 71

Original Poster
Rep: Reputation: 16
Second part worked like a charm. Option, hidden away!

Thanks so much.
Petey

Quote:
Originally Posted by colucix View Post
1) Right-click on the clock
2) Select "Date And Time Format"
3) Select the "Times & Dates" tab
4) Change the Time Format selecting "HH:MM:SS" from the drop down menu
5) Click on Apply and/or Ok
6) Logout and Login, that is restart the X server.

In alternative to points 1) and 2) you can
1) Select Configure Desktop from the Geco menu
2) Select Regional & Accessibility from the menu on the left
3) Select Country/Region & Language from the menu on the left
4) Proceed as per points 3) to 6) above.
 
Old 11-28-2010, 06:42 PM   #7
pwigsten
LQ Newbie
 
Registered: Nov 2009
Posts: 1

Rep: Reputation: 0
Changing to 12hr clock on OpenSUSE 11.3; KDE 4

Changing from the 24hr to 12hr clock is a little obscure. With the help of this thread, I got it done.

Here is what worked for me:

1. Click on Application Launcher
2. Launch "Configure Desktop" application
3. Under the Personal category click on "Regional and Language"
4. A new window should open "Country/Region & Language should open with the "Country/Region & Language" category highlighted.
5. Click on the "Time and Dates" tab. You will see Time Format.
6. Click the down arrow and select "pH:MM:SS AMPM" the 12 hour setting
7. Click the "Apply" button which should be active.
8. Restart your session. Logout and Login again. Your time should now display in the 12 hour format.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Digital Clock Settings Buhlz_I Linux - Desktop 1 10-13-2008 06:54 PM
Hardware Clock, Opensuse 11 x64 usaf_sp SUSE / openSUSE 1 09-17-2008 01:07 AM
openSUSE 10.2 clock issues karnaf SUSE / openSUSE 6 09-07-2007 07:36 AM
OpenSuSE 10.1 Clock Issues alan.me Linux - Software 3 10-18-2006 02:53 PM
Various clock issues: Clock shows wrong time only in Knoppmyth, & CMOS time change ? davidbix General 1 04-05-2006 10:58 PM


All times are GMT -5. The time now is 11:15 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration