LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 11-17-2008, 01:33 PM   #1
subashk80
LQ Newbie
 
Registered: Nov 2008
Location: Trichy,India
Distribution: Ubuntu,Open Solaris
Posts: 19

Rep: Reputation: 0
Wink Linux not booting after editing fstab...


I was not getting the windows drives mounted in my login. I am getting it mounted only in root login, so i edited the fstab file as one of my friend said as (\dev\hda7 \media\songs defaults 0 0). But now the linux itself is not booting. It stops with "loading ntfs version 3.1. What should i do ? help me plz!
 
Old 11-17-2008, 01:48 PM   #2
zQUEz
Member
 
Registered: Jun 2007
Distribution: Fedora, RHEL, Centos
Posts: 294

Rep: Reputation: 54
How far in the boot process do you get?
I expect you are getting through some of init before it "stops booting". What you could do is boot from a live cd, or the first cd of an installation, or a resuce cd, and simply drop to the command prompt and edit /etc/fstab removing (or commenting) that line. Reboot and confirm that you can now boot.

As far as the line you entered in fstab, you are missing the 3rd field that defines what fstype it is. I believe this is mandatory (though I could be wrong) which is why you are having problems. For example, your line should be something like: "\dev\hda7 \media\songs vfat defaults 0 0" or "\dev\hda7 \media\songs ntfs defaults 0 0".
 
Old 11-17-2008, 01:58 PM   #3
sycamorex
LQ Veteran
 
Registered: Nov 2005
Location: London
Distribution: Slackware64-current
Posts: 5,811
Blog Entries: 1

Rep: Reputation: 1191Reputation: 1191Reputation: 1191Reputation: 1191Reputation: 1191Reputation: 1191Reputation: 1191Reputation: 1191Reputation: 1191
Quote:
"\dev\hda7 \media\songs vfat defaults 0 0" or "\dev\hda7 \media\songs ntfs defaults 0 0".
Linux uses forward slash - /dev/hda7 /media/songs, etc
 
Old 11-17-2008, 02:06 PM   #4
AuroraCA
Member
 
Registered: Jul 2008
Location: Northern CA USA
Distribution: Ubuntu, Slackware, Gentoo, Fedora, Red Hat, Puppy Linux
Posts: 370

Rep: Reputation: 35
If you don't know what type of file system you have on your drive you can use "auto" in lieu of "fat32" or "ntfs"
Code:
\dev\hda7 \media\songs auto defaults 0 0
 
Old 11-17-2008, 02:17 PM   #5
paulsm4
LQ Guru
 
Registered: Mar 2004
Distribution: SusE 8.2
Posts: 5,863
Blog Entries: 1

Rep: Reputation: Disabled
forward slashes, folks:
Quote:
/dev/hda7 /media/songs defaults 0 0
Assuming you're able to log on to the system:
1. Look in /var/log/messages for any related errors
2. Fix (or comment out) the offending fstab entry and reboot

If you're not able to boot and/or log on, then:
1. Try booting from your install CD
2. Post back for details on how to mount your hard disk and fix the problem (when booting in "rescue mode" from install CD)
 
Old 11-22-2008, 02:37 PM   #6
subashk80
LQ Newbie
 
Registered: Nov 2008
Location: Trichy,India
Distribution: Ubuntu,Open Solaris
Posts: 19

Original Poster
Rep: Reputation: 0
hi thz guys i got it right!!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Editing Fstab linda Linux - General 4 09-03-2006 02:59 PM
fstab editing similar Linux - Newbie 4 03-15-2006 06:52 AM
editing /etc/fstab Mad Malc Linux - Newbie 6 09-19-2005 02:25 AM
editing the fstab nkoplm Linux - Newbie 1 06-30-2005 03:21 AM
Fstab editing Ando Linux - General 4 06-29-2003 06:17 PM


All times are GMT -5. The time now is 01:39 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration