LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 04-02-2004, 12:03 AM   #1
Stp45
LQ Newbie
 
Registered: Apr 2004
Posts: 2

Rep: Reputation: 0
Linux newbie - help on auto start for Lnx


I hate to admit it, but I've never used anything but the basic layout of Windows for the past eight years. I just built a new Pc for the first time, and installed Red Hat Linux 9 on it. Works fine, but past the Nvidia mobo startup screen, I have to press F1 and then wait for it to select Linux to boot, then run through all the parts, then pause for two minutes at my empty E drive, then finally finish. The manual really just wasn't in-depth enough for me to grasp, as I can't seem to get in to shell, where I need to put commands. Please help. This 5-minute interactive startup is killing me. So, how can I automate some of the startup and/or knock off the run through of system parts which is long in itself?
Much appreciated.

Last edited by Stp45; 04-02-2004 at 12:04 AM.
 
Old 04-02-2004, 02:36 AM   #2
ac1980
Member
 
Registered: Aug 2003
Location: Trento, Italy
Distribution: Debian testing
Posts: 394

Rep: Reputation: 30
Actually I don't think your problem is clear enought.
Let's see...
1. you turn on the pc
2. the bios performs some checks, than something goes wrong and it hangs. What's the last message above "press F1"?
3. you press F1 and it activates the bootloader (lilo or grub)
4. you choose "linux"
and then?

What's about E drive? That looks like a msdos name...
Anything that comes before the "loading kernel" is not under linux control, so what you should do is
1. enter you bios setup (usually pressing del at boot time)
2. (re-)install lilo or grub into /dev/hda. Refer to one of the many HowTos out there. beware a wrong boot manager setup can make your system unbootable

Regarding the "run through all the parts, then pause for two minutes at my empty E drive", please describe exactly what you see...

PS: to go to a text shell, press alt+ctrl+F1-F6; to return to XWindow press alt+ctrl+F7
 
Old 04-02-2004, 11:52 AM   #3
Stp45
LQ Newbie
 
Registered: Apr 2004
Posts: 2

Original Poster
Rep: Reputation: 0
1. you turn on the pc
2. Mobo startup screen requires a TAB to be pushed to bring me to BIOS screen
3. The BIOS says my flopy has failed, (I have to buy a new cable) and I press F1 to continue
4. In BIOS again, says press F4 for Raid Utility but it opens up a new thing and Verifies DMI Pool data, besides the the fact that F4 does nothing
5. Then brings me to select the Linux startup kernel, pressing enter boots it off of that, (the main and only one I have)
6. Long list of system checks occur on parts in DOS style, and it stops for a minute or two before displaying: hde: no response (status = 0Xfe) then still pausesfor another minute and displays it a second time, before continuing the startup
7. List of Red Hat chekcs comes up, all with green OKs on the left hand side of the screen, and it verifies it's in startup level 7
8. It waits a minute or two and checks for new hardware which takes a minute or so
9. Localhost login screen appears and then goes away after a second or two, and I'm finally brought into Red Hat.

Thanks, I'm going to be gone all weekend and have to leave now, so I should be able to update you with this on Monday or late Sunday, when I can get to doing these on my computer. Thanks again.
 
Old 04-02-2004, 12:15 PM   #4
citrus
Member
 
Registered: Dec 2003
Location: California
Distribution: Kubuntu 6.1
Posts: 548

Rep: Reputation: 30
well for your bios
you should be able to disable your floppy drive and your raid controler if your not useing either of them
then you should be able to enable something like fast system check or quick mode as a lot of bios's call it
 
Old 04-02-2004, 12:36 PM   #5
michaelk
Moderator
 
Registered: Aug 2002
Posts: 15,266

Rep: Reputation: 1624Reputation: 1624Reputation: 1624Reputation: 1624Reputation: 1624Reputation: 1624Reputation: 1624Reputation: 1624Reputation: 1624Reputation: 1624Reputation: 1624
2. No reason to enter the BIOS setup at every boot. Its only when you want to change the configuration.

3. You can disable the floppy interface in the BIOS so you do not have to press F1 during boot up.

4. No need to run RAID utility unless its required. If your not configured for RAID you might want to disable it in the BIOS.

5. grub i.e. the boot loader will automatically load the OS after the timeout value. You can shorten the time to zero by change the value in the /etc/grub.conf. I do not run RH so I'm sure someone will correct me if I'm wrong.

6. Is this the empty drive you are refering to? Does this drive function?

7. You can disable hardware checks at boot.

I suspect that once you fix the hardware problems it will not take long to boot.
 
Old 04-02-2004, 01:14 PM   #6
Patgod
LQ Newbie
 
Registered: Mar 2004
Location: Vermont
Distribution: Slackware 9.1
Posts: 16

Rep: Reputation: 0
I have a somewhat similar question, so i'll post it here. I want LILO to automatically boot linux, instead of making me hit enter. Mainly because i'm using a KVM switch, and my keyboard doesnt get recognized until linux actually boots.
 
Old 04-02-2004, 02:05 PM   #7
ac1980
Member
 
Registered: Aug 2003
Location: Trento, Italy
Distribution: Debian testing
Posts: 394

Rep: Reputation: 30
to patgod: edit your /etc/lilo.conf and add the following lines to the top:
default=linux (should match one of the entries)
timeout=20 (in 0.1 secs units)

then save and submit changes by running lilo as root

PS: you should then get "* linux added" as a response

Last edited by ac1980; 04-02-2004 at 02:07 PM.
 
Old 04-02-2004, 02:14 PM   #8
Patgod
LQ Newbie
 
Registered: Mar 2004
Location: Vermont
Distribution: Slackware 9.1
Posts: 16

Rep: Reputation: 0
Quote:
Originally posted by ac1980
to patgod: edit your /etc/lilo.conf and add the following lines to the top:
default=linux (should match one of the entries)
timeout=20 (in 0.1 secs units)

then save and submit changes by running lilo as root

PS: you should then get "* linux added" as a response
Thanks, i actually figured it out using KDE a few minutes ago, but i'm going to go into the file its self so i'll be able to do it in the future.

One more question, it asks me what video mode i want to use on bootup. something like "you have passed an undefined node, what do you want to use" with a time out of like 30 seconds. Any idea what that is/how to make it die?

I think it started after i set up xf86config and told it what modes my vid card could do

Last edited by Patgod; 04-02-2004 at 02:19 PM.
 
Old 04-02-2004, 06:09 PM   #9
ac1980
Member
 
Registered: Aug 2003
Location: Trento, Italy
Distribution: Debian testing
Posts: 394

Rep: Reputation: 30
I suppose a video mode is passed as a parameter to xsever by some initialization script (startx? init? X?) but this mode is not among allowed ones. Still the x-calling scripts are often messy and very distro-specific, so I'm not sure where you can change it. sorry.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
How do I auto start modules that aren't auto loaded on boot? darkbluedrew Debian 2 09-18-2005 10:10 AM
eth0 Auto Connect, How to auto start on logon cornish Linux - Networking 2 05-09-2005 01:02 PM
Newbie to linux - KP at start (pic) zband Mandriva 2 04-04-2005 09:41 AM
Gateway 700 USB, LNX-BBC or Damnsmall linux Waggs Slackware 1 09-13-2003 12:26 PM
Small Linux for newbie to start with? dive Linux - Newbie 8 08-19-2003 08:13 AM


All times are GMT -5. The time now is 03:23 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration