LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 04-11-2015, 06:42 AM   #1
umbloaded
Member
 
Registered: Apr 2013
Posts: 38

Rep: Reputation: Disabled
linux mint - internet works badly


Hi, I'm running Linux Mint 17.1 and the Internet connections generally works well but sometime it is slow and pages take many seconds to load or the connection fails.
The driver is the wikidevi suggested for my card and signal is good, do you have any idea about this problem ?

Thanks
 
Old 04-11-2015, 06:51 AM   #2
floppy_stuttgart
Member
 
Registered: Nov 2010
Location: Stuttgart, Germany
Distribution: Debian like
Posts: 781
Blog Entries: 2

Rep: Reputation: 75
please give the outputs of
lspci or lsusb (only what indicate your card) and
dmesg (only what indicate connection start/ stop / restart..).
 
Old 04-11-2015, 07:33 AM   #3
JeremyBoden
Senior Member
 
Registered: Nov 2011
Distribution: Debian
Posts: 1,151

Rep: Reputation: 237Reputation: 237Reputation: 237
Have you tried one of the many speedtest web sites?

Could it be network congestion such as other PC's on the same connection or
congestion at peak times (evenings)?

The command
Code:
sudo iwconfig
may give useful information...
 
Old 04-11-2015, 07:34 AM   #4
umbloaded
Member
 
Registered: Apr 2013
Posts: 38

Original Poster
Rep: Reputation: Disabled
No there is no network congestion, speed test latency is around 180 while normally is around 60

lsusb

Code:
NetGear, Inc. WG111v3 54 Mbps Wireless [realtek RTL8187B]
dmesg

Code:
[ 2782.240686] wlan0: associated
[ 2782.240733] cfg80211: Calling CRDA for country: CA
[ 2782.243241] cfg80211: Regulatory domain changed to country: CA
[ 2782.243245] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
[ 2782.243247] cfg80211:   (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2700 mBm)
[ 2782.243249] cfg80211:   (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 1700 mBm)
[ 2782.243251] cfg80211:   (5250000 KHz - 5330000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[ 2782.243252] cfg80211:   (5490000 KHz - 5710000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[ 2782.243254] cfg80211:   (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 3000 mBm)
[ 2783.263981] wlan0: deauthenticated from **:**:**:**:**:** (Reason: 2)
[ 2783.398298] cfg80211: Calling CRDA to update world regulatory domain
[ 2783.404567] cfg80211: World regulatory domain updated:
[ 2783.404575] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
[ 2783.404580] cfg80211:   (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[ 2783.404586] cfg80211:   (2457000 KHz - 2482000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[ 2783.404590] cfg80211:   (2474000 KHz - 2494000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
[ 2783.404593] cfg80211:   (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[ 2783.404597] cfg80211:   (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[ 2789.188520] wlan0: authenticate with **:**:**:**:**:**
[ 2789.370243] wlan0: send auth to **:**:**:**:**:** (try 1/3)
[ 2789.371615] wlan0: authenticated
[ 2789.372204] wlan0: associate with **:**:**:**:**:** (try 1/3)
[ 2789.374160] wlan0: RX AssocResp from **:**:**:**:**:** (capab=0x411 status=0 aid=1)
[ 2789.377659] wlan0: associated
[ 2789.377753] cfg80211: Calling CRDA for country: CA
[ 2789.381824] cfg80211: Regulatory domain changed to country: CA
[ 2789.381828] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
[ 2789.381830] cfg80211:   (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2700 mBm)
[ 2789.381832] cfg80211:   (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 1700 mBm)
[ 2789.381834] cfg80211:   (5250000 KHz - 5330000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[ 2789.381835] cfg80211:   (5490000 KHz - 5710000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[ 2789.381837] cfg80211:   (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 3000 mBm)
[ 5190.800465] ecryptfs_decrypt_page: Error attempting to read lower page; rc = [-4]
[ 5190.800469] ecryptfs_readpage: Error decrypting page; rc = [-4]
[ 5224.645442] systemd-hostnamed[3791]: Warning: nss-myhostname is not installed. Changing the local hostname might make it unresolveable. Please install nss-myhostname!
iwconfig

Code:
wlan0     IEEE 802.11bg  ESSID:"wifi"  
          Mode:Managed  Frequency:2.412 GHz  Access Point: **:**:**:**:**:**   
          Bit Rate=11 Mb/s   Tx-Power=20 dBm   
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality=70/70  Signal level=-17 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:572  Invalid misc:64   Missed beacon:0

Last edited by umbloaded; 04-11-2015 at 07:39 AM.
 
Old 04-11-2015, 08:38 AM   #5
floppy_stuttgart
Member
 
Registered: Nov 2010
Location: Stuttgart, Germany
Distribution: Debian like
Posts: 781
Blog Entries: 2

Rep: Reputation: 75
What is the ID of your chip? (read it with lsusb -> xxxx:yyyy)
https://help.ubuntu.com/community/Wi...ealtekRTL8187b
http://wiki.ubuntuusers.de/WLAN/ChipsC3%A4tze
seems ndiswrapper is an option..
 
Old 04-11-2015, 09:00 AM   #6
umbloaded
Member
 
Registered: Apr 2013
Posts: 38

Original Poster
Rep: Reputation: Disabled
0846:4260
 
Old 04-12-2015, 03:38 AM   #7
floppy_stuttgart
Member
 
Registered: Nov 2010
Location: Stuttgart, Germany
Distribution: Debian like
Posts: 781
Blog Entries: 2

Rep: Reputation: 75
Quote:
Originally Posted by umbloaded View Post
0846:4260
google "linux driver for 0846:4260" and you will find few things.
One artcle from 2012 say "if you have performance problems, use ndiswrapper".
So, I would give a try to ndiswrapper (use of windows driver file = workaround in case a linux driver is not the optimal).
http://blog.pboehm.org/blog/2012/12/...x-ndiswrapper/
I personally already used ndiswrapper with a usb fritz wlan stick 057c:5601
It was working fine.
Perhaps somebody has a better idea.

Last edited by floppy_stuttgart; 04-12-2015 at 03:40 AM.
 
Old 04-12-2015, 12:02 PM   #8
ardvark71
LQ Veteran
 
Registered: Feb 2015
Location: Oregon, USA
Distribution: Lubuntu 14.04, Windows Vista
Posts: 6,279
Blog Entries: 3

Rep: Reputation: 835Reputation: 835Reputation: 835Reputation: 835Reputation: 835Reputation: 835Reputation: 835
Hi...

I'm not sure if this will be applicable in your case, meaning if someone else can help you fix the issue with your current adapter but if not, another suggestion would be to purchase another Linux compatible adapter, like the one listed here. I personally own one of these adapters and I've never had an issue with it on any Linux system that had a driver for it.

Regards...

Last edited by ardvark71; 04-12-2015 at 12:05 PM. Reason: Corrections.
 
Old 04-12-2015, 03:00 PM   #9
joe_2000
Member
 
Registered: Jul 2012
Location: Aachen, Germany
Distribution: Void, Debian
Posts: 823

Rep: Reputation: 237Reputation: 237Reputation: 237
On some adapters it helps to turn power management off:
Code:
iwconfig wlan0 power off
 
Old 04-19-2015, 01:21 PM   #10
umbloaded
Member
 
Registered: Apr 2013
Posts: 38

Original Poster
Rep: Reputation: Disabled
I've tried ndiswrapper but works worse than with linux driver
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
What mono laser printer works best on linux mint 15 and then how do I install it? Gwynny Linux - Newbie 6 06-18-2014 03:09 AM
which wireless usb adapter works with Linux Mint on pc? Estephanie Linux - Newbie 3 04-09-2014 05:39 PM
Linux Mint LDE Works Great jmc1987 Linux Mint 1 01-13-2013 11:51 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 01:46 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration