LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 04-25-2014, 04:48 PM   #1
chandos
LQ Newbie
 
Registered: Apr 2014
Posts: 4

Rep: Reputation: Disabled
Linux mint DVD, USB Flash and external SSD won't boot to desktop


Hi Folks.
I am new to Linux, but I've made some progress. I have been able to create bootable Linux-mint OS on a flash drive, a dvd and an external SSD. Every one of them works fine on my laptop and my friend's desktop. They won't boot to my desktop (except in compatibility mode). It could be because my desktop has a disabled (in WIN7) on-board video chip and Linux is trying to use it.
In another forum, it was suggested that a use a Linux-mint cheat code such as radeon.modeset=0 Does anyone know HOW to use this code? Where does it go? I assume it goes in the boot file somewhere.

You're help would be appreciated
 
Old 04-26-2014, 06:07 AM   #2
ondoho
Senior Member
 
Registered: Dec 2013
Posts: 4,176

Rep: Reputation: 837Reputation: 837Reputation: 837Reputation: 837Reputation: 837Reputation: 837Reputation: 837
when booting, when you get to grub (where you are asked to select your os, or it automatically boots the first entry after some time) press 'e' on the highlighted entry and append that "cheat code" to the line that starts with "linux /boot/vmlinuz....."

if that helps we can discuss ways to make that permanent.
if not, we'll find other ways to get your setup working.
 
Old 04-26-2014, 06:09 AM   #3
Doc CPU
Senior Member
 
Registered: Jun 2011
Location: Stuttgart, Germany
Distribution: Mint, Debian, Gentoo, Win 2k/XP
Posts: 1,099

Rep: Reputation: 343Reputation: 343Reputation: 343Reputation: 343
Hi there,

Quote:
Originally Posted by chandos View Post
I am new to Linux, but I've made some progress.
so welcome to a fascinating new world. Yea, coming from Windows, the learning curve may be steep at times, but I think it's rewarding.

Quote:
Originally Posted by chandos View Post
I have been able to create bootable Linux-mint OS on a flash drive, a dvd and an external SSD. Every one of them works fine on my laptop and my friend's desktop. They won't boot to my desktop (except in compatibility mode). It could be because my desktop has a disabled (in WIN7) on-board video chip and Linux is trying to use it.
Yes, I think that's the gist. If you disabled your onboard video in Windows device manager, that's a setting in Windows only. Another operating system doesn't know anything about this. And Mint, like Ubuntu, configures itself dynamically at boot time scanning the available hardware. In that process, it will use the first video adapter it finds.

So I can see two ways out of that dilemma - a quick & dirty one, and one that makes sense.

Quick & dirty would be to simply plug your monitor into the onboard video adapter.
But since I assume you're using an add-on video adapter for some reason, you will want to keep using it. So the better approach would be to go into the BIOS setup and disable the onboard VGA adapter there. Then Mint shouldn't recognize it any more and go on to the next one available, which should be the add-on card you're using normally.

Quote:
Originally Posted by chandos View Post
In another forum, it was suggested that a use a Linux-mint cheat code such as radeon.modeset=0 Does anyone know HOW to use this code? Where does it go? I assume it goes in the boot file somewhere.
I don't know either, but even so, it wouldn't get you any further with your current setup. The suggested instruction (assuming I understand it correctly) should prevent Linux from switching video modes at boot time. But that would be pointless because at boot time, your onboard video is the active and primary adapter. So with your current setup, the OS HAS TO switch video adapters and modes during boot.
So the only reasonable thing is to disable the internal video, and to do that at system (BIOS) level, not through Windows.

[X] Doc CPU
 
Old 04-26-2014, 02:12 PM   #4
chandos
LQ Newbie
 
Registered: Apr 2014
Posts: 4

Original Poster
Rep: Reputation: Disabled
Thanks for your response...I think you're right...BIOS is the place to disable the on-board video (other than taking a hammer to it (LOL).I went into BIOS to change my video. I was able to change the order to GFXO-GPP-IGFX-PCI..it didn't make any difference. There is no setting in my BIOS to completely disable the on-board video.


The next step was to attempt to change the boot line in Linux. I pressed "e" and was able to see the line in the attachment.

I tried entering the line radeon.modeset=0 at the end of the line and at the end of the "ro"...no difference.

The on-board video is: ATI Radeon HD3200 graphics
the card that I am using for windows is AMD Radeon HD5700 series.

Once I get this issue figured out I intend to install LM on an internal HD by itself so it's completely isolated from the windows HD.

I thank you for your help.
Attached Thumbnails
Click image for larger version

Name:	pressing e in boot.jpg
Views:	12
Size:	196.5 KB
ID:	15327  
 
Old 04-27-2014, 11:51 AM   #5
chandos
LQ Newbie
 
Registered: Apr 2014
Posts: 4

Original Poster
Rep: Reputation: Disabled
Thanks for your reply.

There seems to be an issue with AMD vireo cards. (See: http://forums.linuxmint.com/viewtopic.php?t=122257)

I was able to change the loading sequence of the BIOS to GFXO-GPP-IGFX-PCI, but it didn't make any difference. ( I am still not sure why it didn't make any difference unless LM sees the AMD video driver for WIN and skips it. I am not sure how to load 2 different video drivers into the system. If I could, I'd put the AMD Linux driver in too (it's on the AMD site).

I tried loading LM from the boot cd to an external drive when Linux was in compatibility mode, thinking that somehow it might pick up the driver...no luck...no video.

My next approaches will be to:

(1) try to figure out if there is some way to load the video driver into the LM on the external HD. I just have to find a way to load it as a proprietary driver, when Linux isn't working correctly. and (2) Continue to see if anyone has found a solution to this in the forums.
 
Old 04-27-2014, 02:32 PM   #6
ondoho
Senior Member
 
Registered: Dec 2013
Posts: 4,176

Rep: Reputation: 837Reputation: 837Reputation: 837Reputation: 837Reputation: 837Reputation: 837Reputation: 837
ok, so back to your original problem:
did i understand correctly that you have made a usb with linux mint, which boots nicely on your laptop (all the way until the graphical desktop) but not on your desktop computer?

so a few questions:

- what's different about your desktop computer?
- is there any reason to believe that this issue is graphics related, other than your suspicion?
- how exactly does it "not boot"? we already established that grub is loading from the usb. that's good. what happens after that, how does it look exactly? have you tried loading recovery mode from grub (might be called differently in the menu)?
 
Old 04-27-2014, 02:57 PM   #7
chandos
LQ Newbie
 
Registered: Apr 2014
Posts: 4

Original Poster
Rep: Reputation: Disabled
SOLVED !!

I practiced an installation on an external HD (XHD) in case anything went seriously wrong. These are the steps;
1. Format the XHD with the root/home/swap partitions
2. Attempt to boot from the Linux boot cd
3. boot to compatibility mode
4. install Linux to the XHD
5. shut down and boot from the XHD
6. press e as soon at the menu appears
7. At the line that starts with Linux...and ends with quiet splash and add radeon.modeset=0 GRUB_GFXMODE=1280x1024x32
8. Press Cntl X to boot with the added commands.
9. Linux will boot without the video acceleration hardware (a window will warn you of this)
10. open terminal and follow the instructions at: https://www(dot)youtube(dot)com/watch?v=Ka5gBMlo-zo
11. (note the text below the video for written instructions and for applicable video cards)

When you reboot from the XHD, everything should work fine.

I am sure that some of the steps I did are unnecessary..but I am new at this. I hope that this will help someone else.

Thank you all for your help ! You folks are amazing.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Trying to boot Linux Mint 9 from USB flash drive: "vesamenu.c32: Not a COM32R image" Kenny_Strawn Linux Mint 26 09-26-2012 07:40 AM
Grub kills XP boot-up after Mint 9 USB flash full install jimwg Linux - Newbie 42 05-31-2012 02:22 AM
[SOLVED] Linux won't boot from usb flash drive suhlk Linux - Laptop and Netbook 2 04-15-2012 01:36 PM
Is there a DVD that can read usb flash drives/external HDD? swalker23 General 2 11-21-2008 11:58 PM


All times are GMT -5. The time now is 08:23 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration