LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-12-2006, 07:00 PM   #16
flipwhy
Member
 
Registered: Jul 2006
Posts: 102

Rep: Reputation: 15

ummm..im a new user.. and i have the same problem i.e
kernel panic - I/O error reading memory message..
was wondering what CONFIG_PM_STD_PARTITION was for? cant really find anythnig meaningful on google...
thanks
 
Old 08-13-2006, 12:24 PM   #17
bathory
LQ Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 11,522

Rep: Reputation: 1502Reputation: 1502Reputation: 1502Reputation: 1502Reputation: 1502Reputation: 1502Reputation: 1502Reputation: 1502Reputation: 1502Reputation: 1502Reputation: 1502
It's an option in your kernel's configuration file. If you want to change it to point to your /boot, edit the file: /usr/src/linux/.config and re-compile your kernel
 
Old 09-22-2006, 12:35 PM   #18
Alkin
LQ Newbie
 
Registered: Sep 2006
Location: Bulgaria
Distribution: Slackware
Posts: 24

Rep: Reputation: 2
Hi guys
I am a bit confused because I've read somewhere that it should point swap partition? It works with root partition fine, but I am curious about what is the difference?
 
Old 10-05-2006, 03:57 PM   #19
jussen
LQ Newbie
 
Registered: Oct 2006
Posts: 4

Rep: Reputation: 0
hi guys,

I helped 4 peoples to install gentoo. we are using the '2.6.17-gentoo-r8' kernel. 2 of us had the described issue.
We changed the "CONFIG_PM_STD_PARTITION=/dev/hda2" to our root partition. but the problem still exists.
I'm wondering why the other 2 guys don't have the result. Both of them don't edit their "CONFIG_PM_STD_PARTITION". that's why i think that it isn't the right solution.

We work with different laptops. one of us only had a swap partition. i checked the kernel config of right device drivers, a lot times the grub.conf. i can't find the lution .... thanks for your help.


greeties

jussen
 
Old 10-05-2006, 04:11 PM   #20
jussen
LQ Newbie
 
Registered: Oct 2006
Posts: 4

Rep: Reputation: 0
edit: connection problem ... posting twice
 
Old 10-06-2006, 12:36 AM   #21
HushPe
LQ Newbie
 
Registered: Jul 2006
Posts: 3

Rep: Reputation: 0
jussen:

You need to set it from /dev/hda2 to either your boot or swap partition.

For me it happened to be my boot partition, but as pointed out above it's primarily for swap. If you are using make menuconfig there is an option to turn it off which may make life easier.

As for the other systems that worked fine first time, it could be how their partitions are setup differently to your other systems.
 
Old 10-06-2006, 06:23 AM   #22
Alkin
LQ Newbie
 
Registered: Sep 2006
Location: Bulgaria
Distribution: Slackware
Posts: 24

Rep: Reputation: 2
Could you post their /etc/fstab's please

Last edited by Alkin; 10-06-2006 at 06:25 AM.
 
Old 10-07-2006, 07:07 AM   #23
jussen
LQ Newbie
 
Registered: Oct 2006
Posts: 4

Rep: Reputation: 0
i'll post the fstab on monday. we decided to spread out this weakend and just have fun.

thanks for repeating. i'll be right back
 
Old 10-10-2006, 12:54 PM   #24
jussen
LQ Newbie
 
Registered: Oct 2006
Posts: 4

Rep: Reputation: 0
hey folks,

we made it!!!!

we converded the boot and root partition to primary ( before that it was in extended dos partition ). but it still doesn't work. than we deleted the swap partition ( i hope 512MB ram is enough ) and hurray \o/ it works!

thanks for help again
 
Old 10-13-2006, 04:23 AM   #25
Alkin
LQ Newbie
 
Registered: Sep 2006
Location: Bulgaria
Distribution: Slackware
Posts: 24

Rep: Reputation: 2
Lucky you
(anyway next time if you are rebuilding kernel try to rebuild everything you have selected in DMA section as build-in not as modules)
 
Old 02-09-2007, 07:06 AM   #26
vincent_1234567
LQ Newbie
 
Registered: Feb 2007
Posts: 1

Rep: Reputation: 0
it is in the initrd

== SOLUTION to "kernel panic - not syncing: I/O error reading memory image" ===

Hi all,
after reading all the messages here and google, i found in /etc/initramfs-tools/conf.d/resume
RESUME=/dev/sda2
which used to be the swap partition on the machine i originally made my kernel and initrd on.

I chroot into the / partition (/dev/sda5) booting from network,

mount -o rw /dev/sda5 /mnt
chroot /mnt
mount -t proc proc /proc

By changing the file

/etc/initramfs-tools/conf.d/resume

RESUME=/dev/sda6

(this is my current swap partition)

and running
update-initramfs -u

all is fine again!

Hope this helps googlers
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
kernel panic after image restore turnbui Linux - Software 1 06-20-2006 03:30 AM
Kernel Panic can not find init image ToeShot Linux - General 5 08-03-2005 03:05 PM
kernel panic error after rebooting new kernel image fiero Linux - General 4 07-13-2005 09:32 AM
kernel-image generates Kernel Panic Osten Debian 1 03-10-2004 01:08 AM
Linux error: Kernel Panic wilbasket23 Linux - Software 5 07-01-2003 01:19 PM


All times are GMT -5. The time now is 06:28 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration