LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 04-21-2003, 05:24 PM   #1
newlin
Member
 
Registered: Jan 2003
Location: UK
Distribution: Red Hat 9 FC2
Posts: 51

Rep: Reputation: 15
linux is slow


i am dual booting windows 98 and linux like 98% linux and 2%
windows but i have noticed that linux is much slower to boot than windows ..I have been led to believe that linux is very efficient and slick so why is it so slo .can anyone explain .....???
 
Old 04-21-2003, 05:26 PM   #2
Proud
Senior Member
 
Registered: Dec 2002
Location: England
Distribution: Used to use Mandrake/Mandriva
Posts: 2,794

Rep: Reputation: 116Reputation: 116
Which distro, what's your pc stats?
Very probably running services you dont need.
Run GKrellm and monitor your pc usage, see what the average swapping is etc.
 
Old 04-21-2003, 05:32 PM   #3
BigNate
Member
 
Registered: Mar 2003
Location: Harrisburg, PA
Distribution: Gentoo, Debian, Ubuntu, Red Hat/CentOS
Posts: 719

Rep: Reputation: 30
Boot up is a little slower on Linux I believe because the Kernel takes care to activate the proper apps/daemons and processes ( speculation ). However, you can stop some of those processes from loading in the beginning. I do not know what distro you are using and I am not sure of the command line route. But if you are using Redhat if you go to menu=>server settings=>services you will get a gui list of start up processes and check boxes you can de-.select Alternatively, if you know what you are doing and feel brave, I'm sure if dig around in the files you could find something in a conf file that would allow you to change a value so that the process did not start at boot. I just allow the kernel to do it's thing. Because linux is built for stability, I just don't reboot too often unless X crashes :}
 
Old 04-21-2003, 05:35 PM   #4
trickykid
LQ Guru
 
Registered: Jan 2001
Posts: 24,149

Rep: Reputation: 234Reputation: 234Reputation: 234
I have a machine, 400mhz Celeron, takes Linux to boot in roughly less than 30 seconds.. Windows98 on the same machine when last installed a couple of years ago took about 2 minutes..

Don't ever assume something til you've troubleshooted.

Like everyone else mentioned, give us your specs, and what services you have starting up? Have you tried recompiling your kernel to suit your needs? Anything else you need to tell us?
 
Old 04-21-2003, 05:36 PM   #5
Proud
Senior Member
 
Registered: Dec 2002
Location: England
Distribution: Used to use Mandrake/Mandriva
Posts: 2,794

Rep: Reputation: 116Reputation: 116
He's using Mandrake9 (9.1?)
The Mandrake Control Centre -> System -> Services allows you to deal with most services that start at boot. Also the SysV-Init Editor allows some powerful configuring of every runlevel. Know what you are doing or you can easily wreck your current setup.
 
Old 04-21-2003, 05:50 PM   #6
BigNate
Member
 
Registered: Mar 2003
Location: Harrisburg, PA
Distribution: Gentoo, Debian, Ubuntu, Red Hat/CentOS
Posts: 719

Rep: Reputation: 30
"He's using Mandrake9"

ahhh yes. Posted at the side of the post. Thanks I'll keep my eyes open for it.
 
Old 04-21-2003, 05:53 PM   #7
newlin
Member
 
Registered: Jan 2003
Location: UK
Distribution: Red Hat 9 FC2
Posts: 51

Original Poster
Rep: Reputation: 15
I just boot to use the apps installed .i dont normally interogate the mc for info .. but i am using suse 8.0 which seems ok ....until i need to reboot to recover my default emails in ms but otherwise i use suse which is fine ,and now i am learning emacs and bash with a struggle but i will not go bak to ms w i n - ... Bear with me ok..
 
Old 04-22-2003, 07:38 AM   #8
salparadise
Senior Member
 
Registered: Nov 2002
Location: Birmingham UK
Distribution: Various
Posts: 1,736

Rep: Reputation: 146Reputation: 146
have you enabled DMA ?
it's NOT enabled on Linux by default
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Suse 9.2 & SATA - Slow, Slow, Slow jess1975 SUSE / openSUSE 6 01-28-2007 01:17 PM
New Fedora Internet connection slow slow slow matrim Fedora 9 07-29-2005 02:39 PM
Linux is really slow... How come? thinhla Linux - General 11 07-03-2005 12:46 PM
Why is my linux so slow the_imax Linux - General 11 05-20-2005 10:59 PM
RH8 vs. W2k - Slow, slow, slow zerojosh Linux - Software 2 06-30-2003 08:19 PM


All times are GMT -5. The time now is 01:01 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration