LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices



Reply
 
Search this Thread
Old 09-04-2010, 07:05 AM   #16
jay73
Guru
 
Registered: Nov 2006
Location: Belgium
Distribution: Ubuntu 11.04, Debian testing
Posts: 5,019

Rep: Reputation: 130Reputation: 130

Quote:
It says SUPER P6DGE/DBE when I start up the machine, and also Pentium III x2, 800MHz. So what would I do with that info?
You would feed that info to google so as to find out whether the motherboard is known to be linux compatible. Apparently, the board was made by Super Micro and it did not pose any problems until 2006; I have not found any later references but then I have done only a quick check.

I can think of two problems:
- a malfunctioning cd drive
- the driver has been dropped from the kernel or it is present but it cannot be found for some reason

The problem sounds quite like what I experienced a year or five ago so I would suggest that you try the generic IDE workaround. When the cd boots up, look for a field to input extra boot options and enter:
all-generic-ide irqpoll
Press enter and the cd should continue to boot. If you are lucky, the installer should now be able to mount the cd.
 
Old 09-04-2010, 08:34 AM   #17
hughetorrance
Member
 
Registered: Aug 2009
Location: London North West
Distribution: x86_64 Slack 13.37 current : +others
Posts: 459

Rep: Reputation: 59
Two things...
1/ I always zero out a drive like that...

2/ I have known in the past that a USB device has caused an installer to stall. !
 
Old 09-04-2010, 12:22 PM   #18
pyrospade
LQ Newbie
 
Registered: Sep 2010
Posts: 17

Original Poster
Rep: Reputation: 0
So I can definitely try an older distro, but here's something to think about. When I stick a blank USB stick in the PC and run the installer it mounts the CD, but if I don't have a USB stick in it won't. Could there be something wrong with the hard disks?

When the Linux partitioner asks me to pick a drive to partition, they appear like this...

Code:
IDE1 master (hda) - 20.0 GB WDC WD200BB-32AUA1
IDE1 slave (hdb) - 30.0 GB WDC WD300BB-00AUA1
SCSI2 (0,0,0) (sda) - 2.0 GB Imation Clip
So from this I'm guessing both the master and slave HDDs are connected to the first cable. Then again, I don't really know what I'm talking about. But maybe this could provide some insight.

By the way, the CDROM is connected to the Sec Slave. I tried using boot: 'expert all-generic-ide irqpoll', but I got the same results as before. If I don't have a USB stick in, it won't mount. If I do, it does. Also, there is no option for booting from USB in the BIOS.

Last edited by pyrospade; 09-04-2010 at 02:45 PM. Reason: forgot
 
Old 09-05-2010, 03:44 AM   #19
DevilFreeBSD
LQ Newbie
 
Registered: Aug 2010
Distribution: kodak digital unix
Posts: 18
Blog Entries: 12

Rep: Reputation: 3
So where is the secondary master? That's rhetorical. You have to open up the box and look at the back of these drives to see if they are set as master, slave or cable select. (To eliminate the possibility).

Your hard drives typically are connected by a cable that connects to the mother board. That cable can accommodate two drives, 1 master, 1 slave. The drives thenselves have a small pin. Settings on the back, master on pen setting should match up with position on cable that can connect two drives.

You may also try to see if the cd drive works in another computer. It could be its gone bad.

You know what, maybe its just my imagination, but I don't recall ever seeing a machine with
both hda (h) and sda (s). Either they usually are all hda, hdb, hdc, etc. Or sda, sdb, sdc...etc.
 
Old 09-05-2010, 08:57 AM   #20
jay73
Guru
 
Registered: Nov 2006
Location: Belgium
Distribution: Ubuntu 11.04, Debian testing
Posts: 5,019

Rep: Reputation: 130Reputation: 130
Quote:
You know what, maybe its just my imagination, but I don't recall ever seeing a machine with
both hda (h) and sda (s).
No, that was quite common in the pre-2.6.18 days, before libata was introduced. IDE drives were hd, SATA and SCSI drives were sd.

Anyway, if nothing helps, I would suggest moving one drive to another computer to do the install, then put it back.
 
Old 09-05-2010, 03:44 PM   #21
pyrospade
LQ Newbie
 
Registered: Sep 2010
Posts: 17

Original Poster
Rep: Reputation: 0
@jay73 If trying an older distro doesn't work, that'll be my only option.

This is my thought...tell me if I'm close...

The computer is able to boot from the CD-ROM. Then the installer is unable to find a "live file system" and is unable to mount the CD-ROM. If I plug in my USB stick, it then recognizes the USB as the "live file system" and is then able to mount the CD-ROM.

That's my thought process at least. The error message I get when trying to mount the CD-ROM WITHOUT a USB stick connected is...

Code:
No common CD-ROM drive was detected.

You may need to load additional CD-ROM drivers from removable media, such as a
driver floppy.  If you have such media available now, insert it, and continue.
Otherwise, you will be given the option to manually select CD-ROM modules.

Load CD-ROM drivers from removable media?

<Yes>          <No>

Last edited by pyrospade; 09-05-2010 at 03:44 PM. Reason: format
 
Old 09-05-2010, 07:56 PM   #22
jay73
Guru
 
Registered: Nov 2006
Location: Belgium
Distribution: Ubuntu 11.04, Debian testing
Posts: 5,019

Rep: Reputation: 130Reputation: 130
That's the kind of message you would get if your chipset is not supported. However, for several versions, Debian had a bug that caused it to mess up the drive order if drives were connected to more than one controller. I had some SATA drives plugged directly into the motherboard, two more into and add-on SATA card and my optical drive was connected to the IDE controller. The effect was lots of trouble getting the installer to pick up the optical drive; though I succeeded at last, Debian would boot off the wrong controller half of the time so I ended up with busybox and I had to reboot until it got it right.

I would say: remove the second hard drive and put the optical drive in its place. It may make a difference but then again it may not. There are only two alternatives I can think of right now. The first is the one I suggested in my previous post; the other one would be recompiling the kernel.

Last edited by jay73; 09-05-2010 at 07:58 PM.
 
Old 09-05-2010, 08:11 PM   #23
skola
Member
 
Registered: Nov 2009
Posts: 66

Rep: Reputation: 19
no, don't apologise. I should do it being late in reply and I missed seeing your normal Debian thinking you just had server iso's

the others have said about as much as I'd have continued. A few points though.

yes, the command line is when the BusyBox goes to a prompt.

the controller port is what you've seen in the bios, wthether the hdd is Primary master or slave etc.

in the bios, check for anything which might restrict changes to the hdd. Some have an anti-virus setting which might disallow writing to the mbr (master boot record) of a hdd.

See if you can get the cdrom as secondary master. That means it should be on the end cable socket and any small jumper on its back should be set as 'm' or as indicated if at all.

If you have never done an actual build or stripdown of a pc then it might be tricky knowing what's what.

It seems you can get it to boot up but the install borks. Try finding out more about the IDE controller which has been suggested is incompatible. At the prompt type:

lspci --help

that will show what switches to use, so:

lspci -v or maybe lspci -k

will identify the names of the various things.
 
Old 09-06-2010, 06:03 AM   #24
pyrospade
LQ Newbie
 
Registered: Sep 2010
Posts: 17

Original Poster
Rep: Reputation: 0
@jay73 --

So, I took one of the HDDs out and stuck it in an old VAIO, which ironically the CD drive of it seemed to not be so friendly either. Only the Ubuntu Server disc would boot. All of the others did not even register as a disc was inserted. Anyways, long story short, I installed Ubuntu Server on the HDD, moved it back to the server and tried to boot from it. All I get is a

Code:
Searching for boot record from IDE-1..OK
and it just halts. So I thought maybe I didn't install it right. I tried to boot the VAIO without the server's HDD in, and it was unable to find a boot record, so I knew I hadn't accidentally installed it to the wrong HDD. So I put the HDD back in the VAIO and tried to boot, no go. It didn't give an error message, just halted at the 2nd startup screen. I then tried to put in the Ubuntu disk and choose 'Boot from first hard disk', then it boots sucessfully. I put it back in the server and try to boot, no go, I get the same "searching for boot record" as before. I then tried to boot from the disk and all it did was

Code:
Booting from local disk...
@skola --

So I figured out how to set the CD-ROM to Sec Master, but the CD still won't mount during installation. When I try the 'lspci' command, I get this

Code:
~ #lspci -k
Host bridge: Intel Corporation 440BX/ZX/DX - 82443BX/ZX/DX Host bridge (rev 03)
PCI bridge: Intel Corporation 440BX/ZX/DX - 82443BX/ZX/DX AGP bridge (rev 03)
ISA bridge: Intel Corporation 82371AB/EB/MB PIIX4 ISA (rev 02)
IDE interface: Intel Corporation 82371AB/EB/MB PIIX4 IDE (rev 01)
  Kernal driver in use: ata_piix
USB Controller: Intel Corporation 82371AB/EB/MB PIIX4 USB (rev 01)
  Kernal driver in use: uhci_hcd
Bridge: Intel Corporation 82371AB/EB/MB PIIX4 ACPI (rev 02)
Ethernet controller: 3Com Corporation 3c905C-TX/TX-M [Tornado] (rev 30)
SCSI storage controller: Adaptec AHA-2930CU (rev 03)
  Kernal driver in use: aix7xxx
  Kernal modules: aix7xxx
VGA Compatible controller: ATI Technologies Inc Rage 128 SM/4x AGP 4x
I did '#lspci -v' as well, but it was a bit verbose
 
Old 09-06-2010, 06:19 AM   #25
edzams
LQ Newbie
 
Registered: Oct 2008
Posts: 3

Rep: Reputation: 1
Try updating the BIOS. Make sure you download the BIOS update from the manufacturer site of either the motherboard or the laptop. Do the same for the other components such as graphics card, cd drive, etc.
 
Old 09-06-2010, 03:14 PM   #26
jay73
Guru
 
Registered: Nov 2006
Location: Belgium
Distribution: Ubuntu 11.04, Debian testing
Posts: 5,019

Rep: Reputation: 130Reputation: 130
Quote:
I then tried to put in the Ubuntu disk and choose 'Boot from first hard disk', then it boots sucessfully.
If you're not even getting busybox, it is likely that either GRUB was not installed to the master boot record or the drive order is wrong. Possible causes:
- There was another hard drive in the VAIO that presented itself to the installer as the primary master so GRUB was installed onto the wrong drive.
- GRUB was installed onto the right drive but onto a partition rather than onto the MBR; this does not happen unless explicitly requested. It can be solved by marking the partition that contains GRUB as active.
- Neither of the above but you did not make the drive primary master when you put it back into the server.
 
Old 09-06-2010, 11:41 PM   #27
pyrospade
LQ Newbie
 
Registered: Sep 2010
Posts: 17

Original Poster
Rep: Reputation: 0
Ok, so in the words of Professor Farnsworth..."Good news, everyone!" But seriously, it works now, but I have to boot from the CD. I even set the jumper on master and unplugged the other HDD when I installed from the VAIO. If I don't 'Boot from first hard disk', it will hang on the 'Searching for boot record from IDE-1..OK' screen.

Any ideas? I will be researching this one you (jay73) said...it sounds like it may be the culprit...

Quote:
- GRUB was installed onto the right drive but onto a partition rather than onto the MBR; this does not happen unless explicitly requested. It can be solved by marking the partition that contains GRUB as active.
THANK YOU EVERYONE FOR ALL OF YOUR HELP!
 
Old 09-07-2010, 11:34 AM   #28
pyrospade
LQ Newbie
 
Registered: Sep 2010
Posts: 17

Original Poster
Rep: Reputation: 0
I think I'm doing something wrong when sdetting the drives to master/slave. All I do is change the jumper on the back to match where it says on the board, right?

When I put the HDD from the server into the VAIO and disconect it's original HDD, it doesn't recognize any drive as pri master, or pri slave for that matter. When I get in the bios I can go to pri master and set it to auto (not changing anything, that's where it was already) and after a few moments it wiL display the HDD as pri master. When I exit and save changes it still doesn't find a pri master. I'm sure this is the problem.
 
Old 09-07-2010, 07:20 PM   #29
skola
Member
 
Registered: Nov 2009
Posts: 66

Rep: Reputation: 19
Hi again. It's a real pain when you think things are ok and then next time, not! Your lspci output showed nothing that should ruffle any present day Linux module-wise I'd say.

At times, the most simplified approach is necessary, and then other things get introduced to complicate it.

The procedures with some hard disks for making them master/slave was often fraught and diff makers had diff methods. And IDE controllers seeing disk geometry differently.

Here's a start from first principles scenario which establishes what's where. The idea is that with your server PC you have only 1 hdd connected correctly, and then the cdrom, and bios options to minimise problems.

Get back inside the server PC and pull any cards except the ATI graphics card (presuming that is a card). The hdds will be on a flat ribbon cable connected to the mainboard IDE sockets as will be the cdrom. And maybe a floppy drive to its own. Pull them all.

Those WD make hard disks. I see from WD's site that they are 10-pin total each. The jumper pins on the back total 10, 2 rows of 5.

A hdd alone should have no jumper.
A hdd as master (with a slave) has jumper on 5-6, the slave on 3-4.

Another simplified method is "Cable select". Each drive has a jumper on 1-2. The idea is that the socket on the cable determines the master, in this case the cable end.

Have 1 hdd only, cnctd on the cable end and put the other cable end into an IDE socket.

Switch on, get into bios and do a "Setup defaults" again. Usually you see that and "bios defaults" where this latter gives a more "failsafe" lower performance base.

Check a tab for "antivirus" or "security" and disable as these might interfere with hdd usage. Save and reboot.

Again into bios. Now use the various options for the disk tabs to see that your hdd is the Primary Master. It will be if it's in the correct IDE socket and jumpered/cabled correctly.

Note that when you have 'Auto' enabled for the hdd bios entries you should see how it's being used by the controller when you hit 'Enter' key- meaning the hdd should show something like 'LBA xxxx sectors' and a cdrom 'PIO mode x'

While in the bios, pare it down further.

It probably has pages for - Main, chipset, Power, PCI, Onboard, Boot. or similar.

Find and disable- floppy, network (LAN) and scsi if were not cards, parallel, serial, infrared, usb. In 'Power' disable APM plus anything about 'wake up' or 'power down'. Have 'ACPI' enabled. In 'PCI' it might have 'PNP OS installed' for a plug'n'play operating system. That deals with how things get an IRQ and memory address; start with 'yes' and try 'no' later. You want a setup where nothing might interfere with what's going to be needed for the hdds, and then the cdrom.

Set the boot to 1st hdd, save and reboot. See what happens if it was a hdd that you thought had a working install. Try the other hdd alone also.

If you get a successful boot then you can go ahead and put in the cdrom and restore things back in the bios etc, etc. If you just get the "no bootable, waiting..." messages it's hard to say whether trying to get the cdrom up and having a go at fixing or a fresh install. I'd be tempted to wipe and install.

Still with 1 hdd only. Plug up the cdrom, check if it needs a jumper or not, again on the end of its cable and switch on and in bios ensure it shows as Secondary master.

Now try booting an Install CD. If you like, re-enable the USB and do your trick. Remember, if neither hdd is booting, that using the 'dd' command I gave earlier will clean up any code at the start to allow a fresh use of 'fdisk' to partition.
 
Old 09-07-2010, 09:46 PM   #30
pyrospade
LQ Newbie
 
Registered: Sep 2010
Posts: 17

Original Poster
Rep: Reputation: 0
@skola

I will try those tomorrow...working on this server has pushed back a lot of music I've been needing to record. But while I'm here, I wanted to throw this at you.

Grub did successfully install when I used the VAIO, I was just an idiot and didn't do something right. It installed to its original HDD, which I had not disconnected the first time. If I boot the VAIO with its original HDD connected, I get a grub error stating that the device was not found.

What is the appropriate jumper/cable combination? Which connector of the cable should I be using? I tried both and it seems like I got the same results.
 
  


Reply

Tags
installation, linux, partition


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Partitioning for Linux Installation oxblood Linux - Newbie 5 12-13-2008 11:06 AM
study of linux(SUSE 10.1) operating system installation with partitioning nids Linux - Newbie 1 04-06-2008 04:27 AM
LXer: Partitioning - one of the hardest steps in a Linux installation LXer Syndicated Linux News 0 10-25-2006 06:54 PM
RH Linux 9.0 installation step "Auto partitioning" not able to read partition table awahab Linux - Newbie 5 05-19-2005 08:53 AM


All times are GMT -5. The time now is 10:20 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration