LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (http://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Linux Installation - Problem During Partitioning (http://www.linuxquestions.org/questions/linux-newbie-8/linux-installation-problem-during-partitioning-829952/)

pyrospade 09-02-2010 10:01 AM

Linux Installation - Problem During Partitioning
 
I just received an old server with Windows Server 2000 on it, and I do not have the administrator password. I want to turn it into a Linux server and just get rid of Windows. I've tried to install Debian and Ubuntu and get the same problem.

- I pop in the CD with Linux on it and stick my USB drive in as well because if I don't, the CD-ROM won't mount during installation. (I was actually stuck on the step of getting the CD-ROM drive to mount for a couple days until I accidentally left the USB drive in and inadvertently provided Linux with the CD-ROM drivers. Yay!)

- Once it boots I use the "expert" boot parameter

- When I get to the partitioning stage of the installation, it takes around 25 minutes to start the partitioner and about 5 minutes to scan the disks.

- Once it starts partitioning the progress bar goes away and I am left with that dreaded blue screen and some bar where I can type text at the bottom. This lasts for hours. I can also press Alt+F2 to get to the BusyBox console, which I use to "reboot" once the partitioning has proven to not be working.

My goal is to have a dedicated Linux server with a LAMP setup so I can deploy intranet and internet sites. I would also like to learn Linux altogether, but this is the road block I am facing.

Any ideas on what/how I should be troubleshooting?

brianL 09-02-2010 10:06 AM

Could you try deleting the Windows partition first with a live CD, such as gparted?

pyrospade 09-02-2010 11:50 AM

That's crazy, because I just downloaded GParted after looking at some other topics. I will try that...but the CD-ROM mounting fiasco has left me with no blank CDs...so I will have to get some.

Thanks for your insight!

basheer 09-02-2010 02:10 PM

Hi,
Which distribution of linux are u using.
There are a lot of live cds available.
Ubuntu10.04 is one such.
Put in the cd and boot in live mode.
Go to, Applications---Accessories---Terminal.
In the terminal window type----
#sudo su
#fdisk -l (to see how many partitions are there)
#fdisk /dev/sda
delete all the partitions by using the option d. press m for help.
After this just reboot the machine with the ubuntu cd and use the option to install it. See if this works.

pyrospade 09-03-2010 01:05 AM

I have Debian and Ubuntu. I have the server additions of each. I have tried to use GParted, unsuccessfully. It start out with the "Gnome Partition Editor" main screen. It then goes into the code dump (or whatever it is) and eventually stops at a black screen. Once I press a key I get...

BOOT FAILED!

This Debian Live image failed to boot.

Please file a bug against the 'live-initramfs' package or email the Debian Live mailing list at <debian-live@lists.debian.org>, making sure to note the exact version, name and distribution of the image you were attempting to boot.

The file /live.log contains some debugging information but booting with the debug command-line parameter will greatly increase its verbosity which is extremely useful when diagnosing issues.

live-initramfs will now start a shell. The error message was:

Unable to find a medium containing a live file system

Then it says the BusyBox prompt...

Also, I have Ubuntu server, so I don't think that will work. But I will probably try the desktop version, even though I want this to be my server.

pyrospade 09-03-2010 01:41 AM

Just realized I didn't answer your question...

debian-505-i386-CD-1.iso

ubuntu-10.04.1-server-i386.iso

gparted-live-0.6.2-2.iso [this one gave me the "BOOT FAILED!" message.]

gparted-live-0.4.6-1.iso [suggested by this page - http://gparted-forum.surf4.info/viewtopic.php?id=13835]

pyrospade 09-03-2010 06:39 AM

The other gparted wouldn't even boot...it just kept dumping code.

The desktop version of Ubuntu 10.04.1 gave me a "Unable to find a medium containing a live file system" message, similar to the gparted error...I could get to fdisk from within the Debian installation (BusyBox, Ctrl+F2), though. It looks like my USB drive is on /dev/sda, so I don't think I am supposed to partition that one; Windows was originally installed on /dev/hdb, so shouldn't that be the drive I partition for Linux? I am learning this as I go, so please bare with me.

I deleted all partitions from hda and hdb, but I still encountered the same problems as before when using the partitioner from the linux installation.

What would you do to troubleshoot the issue? Is it normal for the "Starting up the partitioner" to halt at 42% for over 20 minutes? According to the initial screen (where you can enter the AMI BIOS by pressing DEL) this PC is from 1997; after doing some research it appears that older machines like this may need some /boot partition needs to be within the first 1024 cylinders of the drive.

I am completely new to a lot of this, so pretty much assume I am completely ignorant :)

skola 09-03-2010 06:40 AM

Forgive me if you went through this already.

Given an old PC I would get into the BIOS setup.

make a note of all the settings particularly memory/cpu speed settings, hard disk/cdrom on which controller port.

reset everything to default, change the date and save.

go inside it and re-seat memory, cables in their sockets. - or maybe this first if booting problems.

I'm intrigued by your saying it needed a usb hdd. All the flavours of IDE/SATA/SCSI modules are there in any Linux booting distro so unless there's some quirky "kickstart" being given by the usb discovery onto the cdrom controller. hmmm

If you went into the BIOS setup which drives can be bootable in preference order?

Others have mentioned ways to have the hdd blanked if some code on it is giving probs. I'd be using a disk editor to check that and zero out any previous code. Alas, not under Linux so how about using 'dd' once you get a command line.

dd if=/dev/zero of=/dev/hda bs=512 count=2000

that should remove any partition and initial windows stuff. Of course double-check that it's the correct /hda or /sda :)

Having a "normal" Live Linux cd is a good investment for these probs, though sometimes one that can easily just go to a command line, circumventing any graphics card probs, is better. A smaller download than a _distro_ cd with many useful tools including Gparted , is PartedMagic. It has boot options to run in lower spec machines.

pyrospade 09-03-2010 04:52 PM

I apologize in advance for the verbosity of the following post :b

Quote:

Forgive me if you went through this already.
As much info you want to give me, please go right ahead. I want to learn everything about this stuff, but right now my knowledge is mostly in basic programming and web development.

Quote:

Given an old PC I would get into the BIOS setup.
make a note of all the settings particularly memory/cpu speed settings, hard disk/cdrom on which controller port.
I have AMIBIOS v2.5 from way back in 1997. Not sure of exactly where those settings are. Under {Setup > Standard} I have a listing of each drive, Pri Master, Pri Slave, Sec Master, Sec Slave, Date/Time, Floppy A, Floppy B. Pri Master and Pri Slave are of Type 'Auto', which the Auto Detection Status finds...

Cyl - 16383
Hd - 16
WP - 0
Sec - 63
Size(MB) - 8064

Sec Master is on Auto, which detects nothing, and Sec Slave detects the CD-ROM (mine is a Plextor PX-W1210A I believe).

Basically, the BIOS main menu shows like this...

Setup - Standard, Advanced, Chipset, Power Mgmt, PCI/PnP, Peripheral
Security - Supervisor, User
Utility - Anti-Virus, Language
Default - Optimal, Fail-safe

But I'm not sure about the controller port thing...unless that's Pri Master, Slave, etc.

Quote:

reset everything to default, change the date and save.
go inside it and re-seat memory, cables in their sockets. - or maybe this first if booting problems.
I have tried to default it to Fail-safe, but it did not seem to help. I had to go to Chipset and enable 'USB Function' so that the USB stick could be found. I am a bit nervous about opening up the server since I don't know the first thing about hardware. Any tips?

Quote:

I'm intrigued by your saying it needed a usb hdd. All the flavours of IDE/SATA/SCSI modules are there in any Linux booting distro so unless there's some quirky "kickstart" being given by the usb discovery onto the cdrom controller. hmmm
I have a 2.0 GB Imation USB stick with a Debian 5.0.5 iso burned onto it, with the use of Universal-USB-Installer. The PC will boot from the CD-ROM, but then Linux can't mount it for installation. If I enable USB Function in the BIOS, stick the USB stick in, then restart, Linux finds the USB stick and identifies it as Imation (I see it in those fast code dumps, but it goes away rather quickly). Then it is able to mount the CD-ROM. My theory is that maybe the USB is providing it with the Plextor drivers, or maybe it's mounting the USB as a CD-ROM. Whatever the case is, it will actually 'Load installer components from CD' once I do this.

Quote:

If you went into the BIOS setup which drives can be bootable in preference order?
The options for 1st, 2nd, and 3rd Boot Devices show as follows - Disabled, 1st IDE-HDD, 2nd IDE-HDD, 3rd IDE-HDD, 4th IDE-HDD, Floppy, ARMD-FDD, ARMD-HDD, ATAPI CDROM, SCSI, NETWORK, I20

Quote:

Others have mentioned ways to have the hdd blanked if some code on it is giving probs. I'd be using a disk editor to check that and zero out any previous code. Alas, not under Linux so how about using 'dd' once you get a command line.

dd if=/dev/zero of=/dev/hda bs=512 count=2000

that should remove any partition and initial windows stuff. Of course double-check that it's the correct /hda or /sda
Ok, at the risk of sounding stupid, the command line is the BusyBox console that you can get to during installation by pressing Alt+F2, right? If so, I can try that. I used fdisk to delete all of the partitions once the installer components were loaded from the CD, and Linux even shows that the hda and hdb are comprised of FREE SPACE, but it still locks up on me while partitioning.

Quote:

Having a "normal" Live Linux cd is a good investment for these probs, though sometimes one that can easily just go to a command line, circumventing any graphics card probs, is better. A smaller download than a _distro_ cd with many useful tools including Gparted , is PartedMagic. It has boot options to run in lower spec machines.
Is there a good tutorial on how to do this? I don't want to start shooting in the dark and really mess something up.

Anyways...hopefully I provided some more clarification.

frankbell 09-03-2010 08:42 PM

Get Slackware.

The first install disk asks you to partition the hard drive using either Linux fdisk or Linux cfdisk (I recommend cfdisk--it's easier).

When I have used it, it has never failed to blow everything away and allow me to do a clean install.

Here's a link to a blog post I wrote about partitioning hard disks using cfdisk from the Slackware installation CDs.

jay73 09-03-2010 09:17 PM

To me it sounds like an unsupported IDE controller. It would help if you could determine the exact type of motherboard.

littlejoe5 09-03-2010 09:18 PM

It would be good if you could get that "ATAPI CDROM" into the first position so that you could boot directly from the CD and not need to have your "USB hdd". If you system is calling that USB "sda" or "sda#" then it is booting from there, and not from the CD. Once you get it to actually booting from the CD I think you will find that Gparted works much more smoothly.

"If you went into the BIOS setup which drives can be bootable in preference order?"

"The options for 1st, 2nd, and 3rd Boot Devices show as follows - Disabled, 1st IDE-HDD, 2nd IDE-HDD, 3rd IDE-HDD, 4th IDE-HDD, Floppy, ARMD-FDD, ARMD-HDD, ATAPI CDROM, SCSI, NETWORK, I20"

pyrospade 09-04-2010 01:09 AM

@littlejoe5 - I'm about to try slackware.

@jay73 - It says SUPER P6DGE/DBE when I start up the machine, and also Pentium III x2, 800MHz. So what would I do with that info?

pyrospade 09-04-2010 01:44 AM

In the BIOS I have the 1st boot device as ATAPI CDROM.

I tried slackware, same problem. It gives me a...

Code:

Searching for Boot Record from CDROM..OK

ISOLINUX 3.84 2009-12-18 ...blah blah blah

isolinux: Disk error 20, AX = 429B, drive EF

Boot failed: press a key to retry...

The problem seems to be that Linux is not detecting my CD-ROM, but the PC can boot from it. I read somewhere that I could just move the hard drive into another computer and then install it. If that's what it takes, so be it. I don't mind getting in there, I just need to know what I'm doing. Looking for guides/tutorials online.

DevilFreeBSD 09-04-2010 03:20 AM

Id almost bet that there is a hardware issue and id bet the hardware problem could have something to do with the cdrom itself.

However, if say for instance the hard drive and cd rom share the same cable but are both set to master that can be it.

Also if you turned acpi off in the bios that might impact the outcome. I've had that before.

You could possibly also write a disk image to the usb drive and boot from it, if my guesses here don't ring true.

Although this problem is too basic to be caused by a non overcomeable incompatability) A basic rule of thumb I think works (but the advice to try slackware is worth a try before what I mention next) is to use a distribution that is a year older then your hardware. I don't know where exactly to find cds of distributions older versions released 2000 to 2003, but say a version of REd Hat 7, Bloatdrake 7, Suse 7 Slackware 8 or 9 might make a difference. Though I doubt it. I think its acpi or damaged hardware, or bios unable to deal with cable select. Try specificly assigning master slave, get an additional cable.

All avenues to look at.

Also occurs to me that maybe the cdrom atapi driver is not modprobing after El Torito quits. Another reason to try an age appropriate distro instead of something like Damn Small tbhat may leave you unsatisfied for lack of features.


All times are GMT -5. The time now is 05:27 PM.