LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 05-25-2003, 12:55 AM   #1
arunshivanandan
Member
 
Registered: May 2003
Location: Kerala,India
Distribution: RedHat,Mandrake,Debian
Posts: 643

Rep: Reputation: 30
linux installation problem


hai,
i partitioned my HD(40GB) as 5GB for c drive,10 gb each for d,e and f,and 5 gb for linux.i installed windows me in c drive and tried to install RH 8 .after installation.on booting,when i tried to enter linux,the message i got was:


Booting 'Red Hat Linux(2.4.18-14)'
root(hd0,7)
Filesystem type is ext 2f s,partition type 0x83
kernel /boot/vmlinuz -2.4.18-14
ro root =LABEL
=/hdc=ide-scsi
[Linux-bz image,setup,0x1400,size=0x10ea0d]
Error 28:
Selected item cannot fit into memory
press any key to continue.....


i am having amd athlon and asus A7N266 mother board and 256mb ddr(puma).
wha is happening?i think all these hardware support linux.
i am having RH7.2 and 9.0 as well.should i try to install any of these??
some body please help me out.i mean it is URGENT.
 
Old 05-25-2003, 01:56 AM   #2
Rick422
Member
 
Registered: Apr 2003
Location: Arizona
Distribution: Red Hat Linux 9
Posts: 158

Rep: Reputation: 30
You said you used 5GB for Linux, did you create a swap file? As far as I know, Linux requires the use of at least two partitions. One partiton needs to be the / partition an probably also needs to be a primary partition. You also need to create a swap partition. I am not sure if that is your problem or not.

I am assuming you probably have just one hard drive and that it is most likely just an ordinary IDE or EIDE hard drive, not a SCSI drive. It looks like you have 5 partitons. An IDE or EIDE harddrive can only have a maxmimum of 4 primary partitons. To get more than that one of the 4 primary partitions would have had to be replaced with an extended partition. Within the extended partiton one or more logical partitions could have been created. The point of all that is that There are only two partitons that need to be on a primary partiton. The Windows drive C needs to be on a primary partition and, as far as I know most likely, the Linux / partition needs to be on a primary partiton (at least that is how I have always done it). The other windows partitons or the Linux swap partition can be either a primary or logical partiton.

I hope I am not on the wrong track in my thinking. But, if you decide to try reinstalling RH 8, use the Disk Druid option for partitioning and do not use the automatic option or the fdisk option (unless you are fond of fdisk). Disk Druid is more user friendly for newbies and will tell which pariton is of which type is which and will show a picture. The 5 GB partiton can be deleted from within disk druid and a small swap partition created if you do not already have one. Of course then go ahead and recreate the / partion and while you are at it make it a ext3 partition instead of an ext2 partition. Ext3 is slightly better than the ext2 default coice. Also make sure while in Disk Druid to tell it which partition is the / partiton and which is the swap partiton.

By the way I see that you have a CD-ROM or something like that in the master position of your second IDE cable and that for the sake of Linux it is pretending to be a SCSI device. That is normal and is ok although I do not now much about that. I do not have much information to go on, so I may or may not be on the right track. I am only moderatly knowledgeable about Linux. I use RH 9 but used RH 8 before that. I do not know what error 28 is?
 
Old 05-25-2003, 01:59 AM   #3
Rick422
Member
 
Registered: Apr 2003
Location: Arizona
Distribution: Red Hat Linux 9
Posts: 158

Rep: Reputation: 30
PS by deleting the 5 GB partition I ment deleting the 5 GB Linux partion not your 5 GB Windows partiton. I hope that was obvious.
 
Old 05-25-2003, 02:35 AM   #4
whansard
Senior Member
 
Registered: Dec 2002
Location: Mosquitoville
Distribution: RH 6.2, Gen2, Knoppix,arch, bodhi, studio, suse, mint
Posts: 3,185

Rep: Reputation: 52
you don't have to have a swap partition.
he has 256 megs of ram. i think you've just run into
an hardware incompatibility with that kernel you're
booting with. since you have a new motherboard, there's
a good chance the problem was fixed by version 9.
Give 9 a shot, and maybe try using lilo as the boot loader
instead of grub. Grub may be what's having trouble with
your machine.
 
Old 05-25-2003, 04:05 AM   #5
Rick422
Member
 
Registered: Apr 2003
Location: Arizona
Distribution: Red Hat Linux 9
Posts: 158

Rep: Reputation: 30
You may be right about the newer hardware. My new computer has some unusual new hardware and Red Hat 8.0 and Red Hat 7.3 would not install. Only Red Hat 9 would work. It was the first version of any distro that I found that would install and run properly. On my old computer all versions of Linux that I installed worked well.
 
Old 05-26-2003, 09:30 AM   #6
arunshivanandan
Member
 
Registered: May 2003
Location: Kerala,India
Distribution: RedHat,Mandrake,Debian
Posts: 643

Original Poster
Rep: Reputation: 30
text mode works but no graphical mode

hai friends,thanks for trying to help me out.....
to day i tried 7.2 and then 8.0(RH).the same problem came up.i created a boot disk and went for text mode and it worked.i tried startx and xinit,either gave no result,they left the screen blank,and may be a hang.
i have always programmed on linux,and would be sorry if i am not having linux....
so please think on my problem........
arun
 
Old 05-26-2003, 09:35 AM   #7
kazuni
Member
 
Registered: May 2003
Location: Hong Kong
Distribution: Android on HTC Hero
Posts: 256

Rep: Reputation: 30
try startx with this option:

startx -- :0.0

to redirect the display to your current one - i donno if it helps but it worked for me like a miracle back then when i had the hungup problem
 
Old 05-28-2003, 12:24 AM   #8
arunshivanandan
Member
 
Registered: May 2003
Location: Kerala,India
Distribution: RedHat,Mandrake,Debian
Posts: 643

Original Poster
Rep: Reputation: 30
i tried that,but nno change.....there is no problem with text mode...but i love kdevelop for programming,....
some one please help me,whenever i go for anything in X,it says cant open display.....
please help....
 
Old 05-28-2003, 12:27 AM   #9
maitre
LQ Newbie
 
Registered: May 2003
Location: MA
Distribution: RedHat, SuSE, Mandrake, Slack
Posts: 17

Rep: Reputation: 0
can you post your XF86Config (or XF86Config-4) file?
-maitre
 
Old 05-28-2003, 09:58 AM   #10
arunshivanandan
Member
 
Registered: May 2003
Location: Kerala,India
Distribution: RedHat,Mandrake,Debian
Posts: 643

Original Poster
Rep: Reputation: 30
# File generated by anaconda.

Section "ServerLayout"
Identifier "Anaconda Configured"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"

# The location of the RGB database. Note, this is the name of the
# file minus the extension (like ".txt" or ".db"). There is normally
# no need to change the default.

RgbPath "/usr/X11R6/lib/X11/rgb"

# Multiple FontPath entries are allowed (they are concatenated together)
# By default, Red Hat 6.0 and later now use a font server independent of
# the X server to render fonts.

FontPath "unix/:7100"

EndSection

Section "Module"
Load "GLcore"
Load "dbe"
Load "extmod"
Load "fbdevhw"
Load "dri"
Load "glx"
Load "record"
Load "freetype"
Load "type1"
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "keyboard"

# Option "AutoRepeat" "500 5"

# when using XQUEUE, comment out the above line, and uncomment the
# following line
# Option "Protocol" "Xqueue"

# Specify which keyboard LEDs can be user-controlled (eg, with xset(1))
# Option "Xleds" "1 2 3"

# To disable the XKEYBOARD extension, uncomment XkbDisable.
# Option "XkbDisable"

# To customise the XKB settings to suit your keyboard, modify the
# lines below (which are the defaults). For example, for a non-U.S.
# keyboard, you will probably want to use:
# Option "XkbModel" "pc102"
# If you have a US Microsoft Natural keyboard, you can use:
# Option "XkbModel" "microsoft"
#
# Then to change the language, change the Layout setting.
# For example, a german layout can be obtained with:
# Option "XkbLayout" "de"
# or:
# Option "XkbLayout" "de"
# Option "XkbVariant" "nodeadkeys"
#
# If you'd like to switch the positions of your capslock and
# control keys, use:
# Option "XkbOptions" "ctrl:nocaps"
Option "XkbRules" "xfree86"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
#Option "XkbVariant" ""
#Option "XkbOptions" ""
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "PS/2"
Option "Device" "/dev/psaux"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "no"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "Monitor Model"
HorizSync 31.5-48.5
VertRefresh 50-70
Option "dpms"

# -- 1400x1050 --
# 1400x1050 @ 60Hz, 65.8 kHz hsync
Modeline "1400x1050" 129 1400 1464 1656 1960
1050 1051 1054 1100 +HSync +VSync

# 1400x1050 @ 70Hz, 76.8 kHz hsync
Modeline "1400x1050" 151 1400 1464 1656 1960
1050 1051 1054 1100 +HSync +VSync

# 1400x1050 @ 75Hz, 82.3 kHz hsync
Modeline "1400x1050" 162 1400 1464 1656 1960
1050 1051 1054 1100 +HSync +VSync

# 1400x1050 @ 85Hz, 93.2 kHz hsync
Modeline "1400x1050" 184 1400 1464 1656 1960
1050 1051 1054 1100 +HSync +VSync

EndSection

Section "Device"
# no known options
Identifier "NVIDIA GeForce 2 MX (generic)"
Driver "nv"
VendorName "NVIDIA GeForce 2 MX (generic)"
BoardName "NVIDIA GeForce 2 MX (generic)"

#BusID
EndSection

Section "Screen"
Identifier "Screen0"
Device "NVIDIA GeForce 2 MX (generic)"
Monitor "Monitor0"
DefaultDepth 16

Subsection "Display"
Depth 16
Modes "1024x768" "800x600" "640x480"
EndSubsection

EndSection

Section "DRI"
Mode 0666
EndSection
 
Old 05-28-2003, 10:08 AM   #11
arunshivanandan
Member
 
Registered: May 2003
Location: Kerala,India
Distribution: RedHat,Mandrake,Debian
Posts: 643

Original Poster
Rep: Reputation: 30
someone please help me.i have always argued for linux,
and always believed in
"have u met linux programmers?they are us."
so why i am not able to solve my problem,even when the redhat website says all the hardware i am using supports linux.
do help....i will always a GNU/linux supporter,even if my problem is not solved,but all these will be considered as disadavantages of the present -opensource-user groups- system.
 
Old 05-29-2003, 09:47 AM   #12
arunshivanandan
Member
 
Registered: May 2003
Location: Kerala,India
Distribution: RedHat,Mandrake,Debian
Posts: 643

Original Poster
Rep: Reputation: 30
sorry for double posting,somebody please help me...
arun
 
Old 05-29-2003, 10:14 PM   #13
maitre
LQ Newbie
 
Registered: May 2003
Location: MA
Distribution: RedHat, SuSE, Mandrake, Slack
Posts: 17

Rep: Reputation: 0
arun,
your xf86config looks alright to me - or at least I can't tell if theres anything your missing. remove your x log files from /var/log/X*
i.e.,
rm /var/log/X* -f
and then rerun X and go back into /var/log and open the X log file - i think its XFree86.0.log and look for the line with (EE) to lists errors, try posting that...
maitre
 
Old 06-04-2003, 10:35 AM   #14
arunshivanandan
Member
 
Registered: May 2003
Location: Kerala,India
Distribution: RedHat,Mandrake,Debian
Posts: 643

Original Poster
Rep: Reputation: 30
hi,
i just edited XF86Congfig file using xf86config,and didnt mention my video card as NVIDIA GeForce 2 (as it was given earlier) and it worked.i can run x now using startx.but,the size of the windows are very great,and in /var/log/XFree86.log.0,the default is taken as 300x180 or so.i cant see even half of the right click menu in the screen.a line of default font fills the screen(it is a 17 inch monitor).how can i rectify this,that is ,to make the default Screen Area lesser,preferably from text mode??
i had mounted CD R/W ,Drive and floppy drive from text mode,but it is not accessible from X.help...
ps:my video card is not given in the database of xf86config.so what to do?
thanx in adv.
arun
 
Old 06-05-2003, 01:31 AM   #15
maitre
LQ Newbie
 
Registered: May 2003
Location: MA
Distribution: RedHat, SuSE, Mandrake, Slack
Posts: 17

Rep: Reputation: 0
Inside of XF86Config, you'll see the screen resolutions under display section and Modes. Thats where you would change your res - as for the video card not being there - thats the limits of the xf86config script - but what you can do is just change the driver under the device section of your XF86Config file to either "nv" if you're using a vanilla distribution or "nvidia" if you've got the NVIDIA NVdriver stuff.
-maitre
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Linux installation problem Johnnyae17 Linux - Software 7 01-07-2005 12:58 AM
Linux installation problem crapper Linux - Software 1 07-16-2004 10:54 AM
linux installation problem arjun_007 Linux - General 2 12-21-2003 01:13 PM
New linux installation problem jborges Linux - General 1 11-18-2003 02:43 PM
Linux 7.0 Installation Problem suneet123 Linux - Newbie 0 10-22-2002 11:05 AM


All times are GMT -5. The time now is 05:54 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration