LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 04-20-2012, 08:56 PM   #16
VDP76
Member
 
Registered: Apr 2010
Location: Bayreuth, Germany
Distribution: CrunchBang Linux (#!)
Posts: 111

Rep: Reputation: 19

Quote:
Originally Posted by jkirchner View Post
I do not think the problem is Grub, I think Grub is notifying you of a problem but not that it is the problem.
I agree, and I think the problem is with initramfs, which is the piece of software which launches the kernel during boot process, and which in your case needs to be updated.

As suggested in that in that Ububtu forum, instead of editing grub.cfg, you should try the following:
Code:
sudo fdisk -l
sudo mount /dev/sdaX /mnt
X should be the proper partition hosting your OS, how is your partitioning scheme? you might want to post the output of fdisk -l in case you have doubts (If you do, and in general when you post code, use the [CODE] tag.. )
Now:
Code:
sudo mount --bind /dev /mnt/dev
sudo mount --bind /proc /mnt/proc
sudo chroot /mnt 
update-initramfs -u -k 2.6.XXXX
update-grub2
where 2.6.XXXX is your kernel version, you can check it with
Code:
uname -r
That's it...I hope it really works...

Good luck!
 
Old 04-21-2012, 01:37 AM   #17
greed109
Member
 
Registered: Nov 2010
Posts: 34

Original Poster
Rep: Reputation: 0
Thumbs up

Quote:
Originally Posted by VDP76 View Post
I agree, and I think the problem is with initramfs, which is the piece of software which launches the kernel during boot process, and which in your case needs to be updated.

As suggested in that in that Ububtu forum, instead of editing grub.cfg, you should try the following:
Code:
sudo fdisk -l
sudo mount /dev/sdaX /mnt
X should be the proper partition hosting your OS, how is your partitioning scheme? you might want to post the output of fdisk -l in case you have doubts (If you do, and in general when you post code, use the [CODE] tag.. )
Now:
Code:
sudo mount --bind /dev /mnt/dev
sudo mount --bind /proc /mnt/proc
sudo chroot /mnt 
update-initramfs -u -k 2.6.XXXX
update-grub2
where 2.6.XXXX is your kernel version, you can check it with
Code:
uname -r
That's it...I hope it really works...

Good luck!
WoW, thank you so much! It is realy works, every single line passed without any single error. But, still did not fixed the problem! Kernel panic: vfs block (0,0)...
Never the less, thank you, good sir, for your time.

Any other ideas?
 
Old 04-21-2012, 06:22 AM   #18
VDP76
Member
 
Registered: Apr 2010
Location: Bayreuth, Germany
Distribution: CrunchBang Linux (#!)
Posts: 111

Rep: Reputation: 19
I am happy that was helpful..even though the problem is not solved...

If you really want to have Debian my last suggestion is to try Crunchbang Linux (aka #!, you can find it here). It is a lightweight Debian-based distro which uses Openbox as window manager (and also has a very good community behind it ).
It is also released in BPO-version (with backports enabled by default) which gives you the chance to try the new kernel version 3.2, maybe that changes something.
If the system boots then you can either choose to stick with #! or just install Gnome or KDE or whatever you like....

Good luck!
 
Old 04-21-2012, 06:25 AM   #19
jayakrishnan
Member
 
Registered: Feb 2002
Location: India
Distribution: Slacky 12.1, XP
Posts: 992

Rep: Reputation: 30
1500 gb ram ???
 
Old 04-21-2012, 06:26 AM   #20
jayakrishnan
Member
 
Registered: Feb 2002
Location: India
Distribution: Slacky 12.1, XP
Posts: 992

Rep: Reputation: 30
...........

Last edited by jayakrishnan; 04-21-2012 at 06:27 AM. Reason: double post
 
Old 04-21-2012, 09:20 AM   #21
greed109
Member
 
Registered: Nov 2010
Posts: 34

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by jayakrishnan View Post
1500 gb ram ???
1x1gb, 2x254mb
He is an old pc

Last edited by greed109; 04-21-2012 at 09:29 AM.
 
Old 04-21-2012, 09:27 AM   #22
greed109
Member
 
Registered: Nov 2010
Posts: 34

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by VDP76 View Post
I am happy that was helpful..even though the problem is not solved...

If you really want to have Debian my last suggestion is to try Crunchbang Linux (aka #!, you can find it here). It is a lightweight Debian-based distro which uses Openbox as window manager (and also has a very good community behind it ).
It is also released in BPO-version (with backports enabled by default) which gives you the chance to try the new kernel version 3.2, maybe that changes something.
If the system boots then you can either choose to stick with #! or just install Gnome or KDE or whatever you like....

Good luck!
You see, this pc I am preparing for my cousin. She got hooked on windows, and i help her with her addiction. I month free trial is enough. So, she only uses firefox, skype, Office and couple of other programs for watching videos online or on pc. So, the idea is to setup the system so that i have a little time to spend at her place, and system that would work as a clock. Debian sounds like her choice, plus because my home system is Debian.) Ubuntu is heavy, 11.10 with their bar on a side...but i know people that like it. Even though, i could remove it and so on, but clean Deabian is light and fast.
Unless you know some other distro for this purpose?

Keep in mind, she knows nothing about pc`s, and life is complicated enough to learn about OS. Let her be..

Last edited by greed109; 04-21-2012 at 09:32 AM.
 
Old 04-21-2012, 10:16 AM   #23
jkirchner
Member
 
Registered: Apr 2007
Location: West Virginia
Posts: 765

Rep: Reputation: 196Reputation: 196
You could try a lighter weight *buntu like XUbuntu or Lubuntu, the first uses XFCE and the latter LXDE. Either may run faster on the PC than Ubuntu.
 
Old 04-23-2012, 01:35 PM   #24
greed109
Member
 
Registered: Nov 2010
Posts: 34

Original Poster
Rep: Reputation: 0
This sux5000 that there is no solution for Debian users. Ubuntu works fine, just change grub.cfg root=(UUID to the position of the HD,ex: /dev/sda1) and it works fine. Very strange. This is what tried:
1. sudo mount /dev/sda1 /mnt
sudo mount --bind /dev/ /mnt/dev
sudo mount --bind /proc/ /mnt/proc
sudo chroot /mnt

2. update-initramfs -d -k (ver.of kernel)
update-initramfs -c -k (.............)
update-initramfs -u -k (.............)

3. sudo gedit /dev/boot/grub/grub.cfg (remove UUID, keep root=/dev/sda1 or your location)
(sudo fdisk -l to check dev.config)

4. update-grub

Nothing helped. Same thing, grub loads, and then gives error...

Keeping this thread, maybe someone will share their solution at some point.
 
Old 04-24-2012, 01:42 AM   #25
Randicus Draco Albus
Senior Member
 
Registered: May 2011
Location: Hiding somewhere on planet Earth.
Distribution: OpenBSD
Posts: 1,644
Blog Entries: 8

Rep: Reputation: 577Reputation: 577Reputation: 577Reputation: 577Reputation: 577Reputation: 577
I am inclined to agree with the idea of a hardware problem for three reasons:
1) The problem occurs with both Debian and Ubuntu.
2) You mentioned problems with Microsoft on this (old?) machine.
3) I have not seen any mention of this problem on either of the two Debian fora. If there was a problem with the installer, there would be talk about.

I do not know which Debian you are trying, so I shall mention if the system is meant for someone without hacking knowledge and stability is the primary concern, make sure you install Stable, and not Unstable or Testing.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Linux Installation error sachinh Linux - Hardware 5 04-21-2011 09:31 AM
Linux installation error amerine Linux - Newbie 7 01-01-2005 08:49 PM
Linux installation error hoi_hop Linux - Software 1 11-11-2003 11:07 AM


All times are GMT -5. The time now is 09:53 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration