LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 08-25-2010, 01:14 PM   #1
thelostman
LQ Newbie
 
Registered: Aug 2010
Location: kuwait
Posts: 4

Rep: Reputation: 0
Question linux does now boot into gui mode


i am using a toshiba satellite laptop and i have windows 7 installed on C drive and Linux Mint 9 in stalled on D Drive. When i boot it gives me 2 options 1. Windows and 2. Linux. When i select Linux it boots to a screen where it gives me 3 options and if i select the first option it boots to a command screen with my username and then i have to type exit to reboot and then i have to use startx to boot to GUI mode. Is there a workaround so that i can boot directly to the GUI mode.

Somebody help me
 
Old 08-25-2010, 01:33 PM   #2
rubentje1991
Member
 
Registered: Feb 2008
Location: Belgium
Distribution: PCLinuxOS
Posts: 102

Rep: Reputation: 22
Question

Can you say which 3 options the Linux menu gives,
Thanks
 
Old 08-25-2010, 03:06 PM   #3
smilemukul
Member
 
Registered: Jun 2009
Distribution: Redhat,CentOS,Ubuntu,Puppet
Posts: 290

Rep: Reputation: 34
Your default runlevel is set to text mode(init 3). You have to edit init 5 for gui mode in /etc/grub.conf. Also you can check your runlevel through the command "runlevel"

Thanks
 
Old 08-26-2010, 02:07 AM   #4
thelostman
LQ Newbie
 
Registered: Aug 2010
Location: kuwait
Posts: 4

Original Poster
Rep: Reputation: 0
Question linux gui

linuxmint, linux 2.6.32-21-generic
linuxmint, linux 2.6.32-21-generic (recovery mode)
windows 7 (loader) (on /dev/sda2)

i select the first option and it some to a screen where it asks me to enter my password, upon entering the password it comes to a command prompt with the following $username$@linuxmint ~ $

if i select option 2 it comes to recovery menu where i select the last option "drop to root shell prompt" where it prompts me for my password and upon entering the same it comes to a prompt "linuxmint ~ #". I type startx here and it loads the gui linux

i hope thats all the info u need and i am really new to linux
 
Old 08-26-2010, 02:36 AM   #5
chrism01
Guru
 
Registered: Aug 2004
Location: Sydney
Distribution: Centos 6.5, Centos 5.10
Posts: 16,269

Rep: Reputation: 2028Reputation: 2028Reputation: 2028Reputation: 2028Reputation: 2028Reputation: 2028Reputation: 2028Reputation: 2028Reputation: 2028Reputation: 2028Reputation: 2028
The file you edit as root user is /etc/inittab
Code:
id:5:initdefault:
your system is probably set to '3' where the '5' is. Amend to look like the above and re-boot.
NB: take a backup copy of the file before editing!
 
1 members found this post helpful.
Old 08-26-2010, 02:55 AM   #6
thelostman
LQ Newbie
 
Registered: Aug 2010
Location: kuwait
Posts: 4

Original Poster
Rep: Reputation: 0
and how do i edit that, i m really a newbie so pls assist me
 
Old 08-26-2010, 06:26 AM   #7
ravichinchkar
LQ Newbie
 
Registered: Jun 2005
Posts: 4

Rep: Reputation: 0
You can give following commands to edit /etc/inittab file.
username@linuxmint~]$ vi /etc/inittab
Now Press 'Insert' key twice, you will see REPLACE at the bottom.
Replace 3 with 5
Press Esc:x
Press Enter
username@linuxmint~]$init 6
Your machine will reboot.
Now you can enter directly to GUI!
Cheers!!!
 
Old 08-28-2010, 07:23 AM   #8
jv2112
Member
 
Registered: Jan 2009
Location: New England
Distribution: Arch Linux
Posts: 718

Rep: Reputation: 102Reputation: 102
Question

ravichinchkar,

Just curiouse is this for a LM distro ?

I am running LM 9 & I can't seem to find this file (inittab)

Even did a sudo find / -iname inittab and came up with nothing.

Am I just not understanding this post ?

Thanks in advance for the direction.
 
Old 08-29-2010, 02:32 AM   #9
EDDY1
LQ Addict
 
Registered: Mar 2010
Location: Oakland,Ca
Distribution: wins7, Debian wheezy
Posts: 5,594

Rep: Reputation: 497Reputation: 497Reputation: 497Reputation: 497Reputation: 497
What desktop are you installing? Seems to me you only installed standard system.

Last edited by EDDY1; 08-29-2010 at 03:21 AM. Reason: mispelling
 
Old 08-31-2010, 01:04 AM   #10
ravichinchkar
LQ Newbie
 
Registered: Jun 2005
Posts: 4

Rep: Reputation: 0
jv2112,
Sorry for that post, the inittab file doesn'l seems to be there in LM. It's there in Redhat. Then in that case the solution I mentioned will not work.

Thanks
 
Old 08-31-2010, 01:13 AM   #11
Kenny_Strawn
Senior Member
 
Registered: Feb 2010
Location: /usa/ca/orange_county/lake_forest
Distribution: ArchBang, Google Android 2.1 + Motoblur (on Motortola Flipside), Google Chrome OS (on Cr-48)
Posts: 1,791
Blog Entries: 62

Rep: Reputation: 54
I'm guessing, since LM is based on Ubuntu, Ubuntu removed the file and LM had no choice but to leave it as is.
 
Old 08-31-2010, 02:26 AM   #12
linuxlover.chaitanya
Senior Member
 
Registered: Apr 2008
Location: Nagpur, India
Distribution: Cent OS 5/6, Ubuntu Server 10.04
Posts: 4,627

Rep: Reputation: Disabled
You could probably edit the file /etc/init/rc-sysinit.conf and change the option env DEFAULT_RUNLEVEL to look like this
Code:
 env DEFAULT_RUNLEVEL=2
If that does not solve the issue, if you look below the DEFAULT RUNLEVEL option, there is another option where you can set the runlevel by force.
set it to look like
env RUNLEVEL=2
 
Old 09-01-2010, 04:27 PM   #13
jv2112
Member
 
Registered: Jan 2009
Location: New England
Distribution: Arch Linux
Posts: 718

Rep: Reputation: 102Reputation: 102
Thanks for the clarification
 
Old 09-02-2010, 08:34 AM   #14
thelostman
LQ Newbie
 
Registered: Aug 2010
Location: kuwait
Posts: 4

Original Poster
Rep: Reputation: 0
it already says env RUNLEVEL=2
 
Old 09-02-2010, 12:01 PM   #15
smilemukul
Member
 
Registered: Jun 2009
Distribution: Redhat,CentOS,Ubuntu,Puppet
Posts: 290

Rep: Reputation: 34
Change to init 5 as

env RUNLEVEL=5

Thanks
 
  


Reply

Tags
boot, command prompt, gui


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Knoppix S-T-D how do i boot in GUI mode? w4r3_w01f Linux - Newbie 1 03-31-2009 04:47 AM
cannot boot linux in GUI mode ufmale Linux - Desktop 2 06-26-2008 09:14 PM
boot to GUI problem want grub boot to single user mode. hocheetiong Linux - Newbie 1 09-26-2007 06:41 PM
LXer: Howto Boot debian in text mode instead of graphical mode (GUI) LXer Syndicated Linux News 0 09-09-2007 07:41 PM
Mandrake 9.0 wont boot into gui mode. rossAINTfakin Linux - Newbie 9 08-09-2004 02:45 PM


All times are GMT -5. The time now is 07:15 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration