LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (http://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   linux does now boot into gui mode (http://www.linuxquestions.org/questions/linux-newbie-8/linux-does-now-boot-into-gui-mode-828434/)

thelostman 08-25-2010 02:14 PM

linux does now boot into gui mode
 
i am using a toshiba satellite laptop and i have windows 7 installed on C drive and Linux Mint 9 in stalled on D Drive. When i boot it gives me 2 options 1. Windows and 2. Linux. When i select Linux it boots to a screen where it gives me 3 options and if i select the first option it boots to a command screen with my username and then i have to type exit to reboot and then i have to use startx to boot to GUI mode. Is there a workaround so that i can boot directly to the GUI mode.

Somebody help me

rubentje1991 08-25-2010 02:33 PM

Can you say which 3 options the Linux menu gives,
Thanks

smilemukul 08-25-2010 04:06 PM

Your default runlevel is set to text mode(init 3). You have to edit init 5 for gui mode in /etc/grub.conf. Also you can check your runlevel through the command "runlevel"

Thanks

thelostman 08-26-2010 03:07 AM

linux gui
 
linuxmint, linux 2.6.32-21-generic
linuxmint, linux 2.6.32-21-generic (recovery mode)
windows 7 (loader) (on /dev/sda2)

i select the first option and it some to a screen where it asks me to enter my password, upon entering the password it comes to a command prompt with the following $username$@linuxmint ~ $

if i select option 2 it comes to recovery menu where i select the last option "drop to root shell prompt" where it prompts me for my password and upon entering the same it comes to a prompt "linuxmint ~ #". I type startx here and it loads the gui linux

i hope thats all the info u need and i am really new to linux

chrism01 08-26-2010 03:36 AM

The file you edit as root user is /etc/inittab
Code:

id:5:initdefault:
your system is probably set to '3' where the '5' is. Amend to look like the above and re-boot.
NB: take a backup copy of the file before editing!

thelostman 08-26-2010 03:55 AM

and how do i edit that, i m really a newbie so pls assist me

ravichinchkar 08-26-2010 07:26 AM

You can give following commands to edit /etc/inittab file.
username@linuxmint~]$ vi /etc/inittab
Now Press 'Insert' key twice, you will see REPLACE at the bottom.
Replace 3 with 5
Press Esc:x
Press Enter
username@linuxmint~]$init 6
Your machine will reboot.
Now you can enter directly to GUI!
Cheers!!!

jv2112 08-28-2010 08:23 AM

ravichinchkar,

Just curiouse is this for a LM distro ?

I am running LM 9 & I can't seem to find this file (inittab)

Even did a sudo find / -iname inittab and came up with nothing.

Am I just not understanding this post ? :study:

Thanks in advance for the direction.:confused:

EDDY1 08-29-2010 03:32 AM

What desktop are you installing? Seems to me you only installed standard system.

ravichinchkar 08-31-2010 02:04 AM

jv2112,
Sorry for that post, the inittab file doesn'l seems to be there in LM. It's there in Redhat. Then in that case the solution I mentioned will not work.

Thanks

Kenny_Strawn 08-31-2010 02:13 AM

I'm guessing, since LM is based on Ubuntu, Ubuntu removed the file and LM had no choice but to leave it as is.

linuxlover.chaitanya 08-31-2010 03:26 AM

You could probably edit the file /etc/init/rc-sysinit.conf and change the option env DEFAULT_RUNLEVEL to look like this
Code:

env DEFAULT_RUNLEVEL=2
If that does not solve the issue, if you look below the DEFAULT RUNLEVEL option, there is another option where you can set the runlevel by force.
set it to look like
env RUNLEVEL=2

jv2112 09-01-2010 05:27 PM

Thanks for the clarification

thelostman 09-02-2010 09:34 AM

it already says env RUNLEVEL=2

smilemukul 09-02-2010 01:01 PM

Change to init 5 as

env RUNLEVEL=5

Thanks


All times are GMT -5. The time now is 04:48 PM.