LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-01-2006, 03:31 AM   #1
Fro
LQ Newbie
 
Registered: Aug 2006
Location: Minsk
Distribution: Red Hat Enterpise 4
Posts: 5

Rep: Reputation: 0
Linux client of WIndows LAN.


Well, we have a LAN, and I have a high-speed connect to Internet via remote computer.

In WinXP I needed to write this:

route delete 10.1.3.1
route add 10.1.3.1 mask 255.255.255.255 192.168.2.203 -p

and create a shortcut with wizard.

But now, when I istalled Linux as the 2nd OS, I can't see the whole network, and ofc, can't connect to Internet. I even can't connect to Inet with my own modem, 'cause Linux doesn't see it!

Linux: Red Hat Enterpeise 4

So, I tried to find any manual in the Internet, but were no results.

Please, help configure the connection, and also eth0 to see the members of LAN.

Thank you.
 
Old 08-01-2006, 04:18 AM   #2
stevesk
Member
 
Registered: Dec 2004
Distribution: Slackware-current
Posts: 207

Rep: Reputation: 30
Is 10.1.3.1 the IP of your machine? What is the ip of the gateway? Details plz
 
Old 08-01-2006, 04:36 AM   #3
Fro
LQ Newbie
 
Registered: Aug 2006
Location: Minsk
Distribution: Red Hat Enterpise 4
Posts: 5

Original Poster
Rep: Reputation: 0
Detalis:

As I understand, 10.1.3.1 is IP of modem, 192.168.2.203 is IP of computer, where modem is situated.

My current IP is 192.168.2.44, I can set it between
192.168.2.1 and 192.168.2.254 (mask is 255.255.252.0).

In Windows, I didn't need to set up gateway for this connection.
 
Old 08-01-2006, 05:02 AM   #4
stevesk
Member
 
Registered: Dec 2004
Distribution: Slackware-current
Posts: 207

Rep: Reputation: 30
Well, I don't have experience on that, but let's try:

bash#ifconfig eth0 192.168.2.44 netmask 255.255.252.0 broadcast 192.168.2.255

bash#route add default gw 192.168.2.203

bash#route add -net 10.1.3.0 netmask 255.255.255.255 gateway 192.168.2.203 dev eth0

I don't know if the mask is correct...seriously, I don't know if any of this stuff is correct, but you will lose the changes when you reboot (doing this way) so there is no danger in testing. Try also the last command with netmask 255.255.255.0

Edit:

Maybe you can also try, in the last one:

bash#route add -net 10.1.3.1 netmask 255.255.255.255 gateway 192.168.2.203 dev eth0

or

bash#route add -net 10.1.3.1 netmask 255.255.255.0 gateway 192.168.2.203 dev eth0

Anyway, if one of these works or if none of these works, tell us plz

Last edited by stevesk; 08-01-2006 at 05:05 AM.
 
Old 08-01-2006, 08:22 AM   #5
Fro
LQ Newbie
 
Registered: Aug 2006
Location: Minsk
Distribution: Red Hat Enterpise 4
Posts: 5

Original Poster
Rep: Reputation: 0
When I try to write, "bash# ...", I can't insert '#' symbol,
Shift+3 just generating 'pounds'.

Without '#' Linux say that 'no such file or directory'.
Without 'bash' Linux doesn't recognize the commands (
 
Old 08-01-2006, 08:49 AM   #6
stevesk
Member
 
Registered: Dec 2004
Distribution: Slackware-current
Posts: 207

Rep: Reputation: 30
No, bash is just the command line

Ignore bash# and type the commands...
 
Old 08-03-2006, 06:16 AM   #7
Fro
LQ Newbie
 
Registered: Aug 2006
Location: Minsk
Distribution: Red Hat Enterpise 4
Posts: 5

Original Poster
Rep: Reputation: 0
Well, I think I have chosen a WRONG DISTRIBUTION.

Damn Red Hat does not recognize any command.
By the way, if write 'if config' instead 'ifconfig', it takes the command, but after that awaits for something!

Also, this distribution crash with 50% chance on start,
and 75% chance on exit.

I 'm sure I didn't anything to crash it.
Also, GUI provided for LAN configuration is USELESS.

I 'll find a better distribution, mb source-based, like Sorcerer, and the fattest book to learn.

I never knew that configurating of Linux is so hard.

IAE, Thank You for help.

Last edited by Fro; 08-03-2006 at 06:18 AM.
 
Old 08-03-2006, 06:31 AM   #8
ethics
Senior Member
 
Registered: Apr 2005
Location: London
Distribution: Arch - Latest
Posts: 1,522

Rep: Reputation: 45
Quote:
Originally Posted by Fro
Well, I think I have chosen a WRONG DISTRIBUTION.

Damn Red Hat does not recognize any command.
By the way, if write 'if config' instead 'ifconfig', it takes the command, but after that awaits for something!

Also, this distribution crash with 50% chance on start,
and 75% chance on exit.

I 'm sure I didn't anything to crash it.
Also, GUI provided for LAN configuration is USELESS.

I 'll find a better distribution, mb source-based, like Sorcerer, and the fattest book to learn.

I never knew that configurating of Linux is so hard.

IAE, Thank You for help.
ifconfig and if config are 2 totally seperate things, ifconfig is as you intended, the reason you couldn't run it is (probably) because you did it from a users environment, and /sbin/ where those sorts of programs are kept are not in the users path by default. If is totally different Linux doesn't really do spaces. As for crashing, i couldn't help because you didn't include any info at all. You probably did do something to crash it, as a computer takes input and gives output... nothing else.

If you're having these sorts of problems a source based distro won't help you. Arc his a good choice ,all it's configs are accessed via text files, no GUIS, which make thigns alot simpler. It'll make configuration particuly easy because chances are when you google for an answer and it says edit <foo_bar> you'll be able to find that file.
 
Old 08-03-2006, 09:12 AM   #9
Fro
LQ Newbie
 
Registered: Aug 2006
Location: Minsk
Distribution: Red Hat Enterpise 4
Posts: 5

Original Poster
Rep: Reputation: 0
Yea, Thank u for explaining that!
As a 'root' I can enter these commands. So, I 've changed some options via ifconfig, but I still can't see any computer in LAN (No Internet, also) (.
But I'm sure options IP, Mask, and Broadcast were set (via ifconfig) correctly.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
can not connect to my pureftp server from Linux client, but i can from windows client bonito SUSE / openSUSE 5 03-16-2005 09:45 PM
Apache/SSL - works with Windows client but not Linux client RickHDYoung Linux - Security 1 07-01-2004 04:02 PM
Lan authontication-(win client, linux server) sixth_sense Linux - Networking 6 03-26-2004 07:42 AM
mixed lan (client win + linux) qustion teo Linux - Networking 3 10-31-2003 09:00 AM
Win XP client on LAN can't find Linux server mournblade Linux - Networking 10 06-26-2003 03:54 PM


All times are GMT -5. The time now is 04:32 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration