LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-25-2003, 09:07 PM   #1
ariana
LQ Newbie
 
Registered: Feb 2003
Posts: 22

Rep: Reputation: 15
Unhappy linux and window on two hard drives


I installed window 2000 server on primary master(60GB) and redhat linux 8 on primary slave(13GB). I have installed GRUB as the boot loader. However, when I start the computer, the GUI for GRUB only shows redhat linux. I can not boot my window 2000 now. Please let me know if you have any idea of how to fix the problem. Thank you!
 
Old 02-25-2003, 09:29 PM   #2
mojie
LQ Newbie
 
Registered: Feb 2003
Posts: 3

Rep: Reputation: 0
I have almost the same setup : win xp on one drive and linux 8.0 on the other.
I have both drives set up for cable select as opposed to master/slave (I don't know if it matters)
But I had to edit my "/etc/lilo.conf" file:

prompt
timeout=50
default=Linux
boot/dev/hda
map=/boot/map
install=/boot/boot.b
message=/boot/message
lba32

image=/boot/vmlinuz-2.4.18-14
label=Linux
initrd=/boot/initrd-2.4.18-14.img
read-only
append="hdd=ide=scsi root=LABEL=/"

other = /dev/hdb1
label = Windows
table = /dev/hdb
map-drive = 0x80
to - 0x81
map-drive = 0x81
to = 0x81


---------------------------------------------------------------------------

Basically you only need to add everything from "other =" on.
( my hda is linux and hdb is windows, yours my be the other way around)
Check your hardware browser, and check hard drives to find out what hard drive is what! (I use KDE so my hardware browser is under System Tools). Hope this helps!
 
Old 02-25-2003, 09:31 PM   #3
mojie
LQ Newbie
 
Registered: Feb 2003
Posts: 3

Rep: Reputation: 0
Ooops! Sorry, forgot you were using GRUB, I use LILO
 
Old 02-26-2003, 05:20 AM   #4
bandit12
LQ Newbie
 
Registered: Feb 2003
Location: Bristol UK (53rd State of America)
Distribution: RH 8 Gnome / KDE
Posts: 22

Rep: Reputation: 15
I got a simmilar set up on my system 60gb master on primary IDE with CDRW set to Cable select and a 10gb master on the secodary IDE using grub whith no issues at all you could try your setup that way It works for me!
let me know if it works for you as us newbies gotta stick together there's safety in numbers LOL
 
Old 02-26-2003, 06:26 AM   #5
annehoog
Member
 
Registered: Jan 2002
Location: Nederland
Distribution: RH 8 Psyche and Debian Woody
Posts: 373

Rep: Reputation: 30
Try adding something like this to your Grub config file:
title Windows XP
rootnoverify (hd0,0)
chainloader +1
makeactive

Note that in grub hdo equals hda in linux, hd1,1 equals hdb,1 etc.

Anne
 
Old 02-26-2003, 07:34 AM   #6
Nefarious
Member
 
Registered: Nov 2002
Location: NY, USA
Distribution: Slackware / College Linux / WinXP
Posts: 198

Rep: Reputation: 30
Quote:
Originally posted by annehoog
Try adding something like this to your Grub config file:
title Windows XP
rootnoverify (hd0,0)
chainloader +1
makeactive

Note that in grub hdo equals hda in linux, hd1,1 equals hdb,1 etc.

Anne

1 Problem with that annehoog.... hes on win2000 not win xp
thats the code to unhide the flag for win xp....


What i would say to do personally is reinstall Red Hat and change it from a GRUB boot loader to a LILO boot loader.

Last edited by Nefarious; 02-26-2003 at 07:36 AM.
 
Old 02-26-2003, 07:56 AM   #7
waxiem
LQ Newbie
 
Registered: Feb 2003
Location: Africa
Distribution: Red Hat
Posts: 6

Rep: Reputation: 0
quote from moije above:
"map-drive = 0x80
to - 0x81
map-drive = 0x81
to = 0x81"

could someone explain what is meant by the hex and why the 'map-drive' is repeated twice but with different values please?

Wax
XXX
 
Old 02-26-2003, 09:23 AM   #8
mojie
LQ Newbie
 
Registered: Feb 2003
Posts: 3

Rep: Reputation: 0
The last line of my /etc/lilo.conf file should be "to = 0x80" not "to = 81" (sorry)
I don't know what it means, only that it works. I am very new to linux!!
 
Old 02-26-2003, 10:35 AM   #9
bandit12
LQ Newbie
 
Registered: Feb 2003
Location: Bristol UK (53rd State of America)
Distribution: RH 8 Gnome / KDE
Posts: 22

Rep: Reputation: 15
HEX is short for HEXADECIMAL
 
Old 02-26-2003, 11:49 AM   #10
ariana
LQ Newbie
 
Registered: Feb 2003
Posts: 22

Original Poster
Rep: Reputation: 15
Smile

I have solved the problem by adding to /etc/grub.config the following lines

title window 2000
rootnoverify hd(0,0)
makeactive
chainloader +1

Thank you for your help
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Linux and Hard drives question Gortex Linux - Newbie 1 11-28-2005 09:18 PM
external hard drives in linux cwl157 Linux - Hardware 1 09-27-2005 09:18 PM
Linux on Multiple Hard Drives apocolpse Linux - Newbie 5 08-06-2005 07:17 PM
linux killing my hard drives acicalla Linux - Newbie 2 06-11-2004 04:20 AM
Linux and USB hard drives Citizen Bleys Linux - Hardware 2 05-13-2004 04:00 PM


All times are GMT -5. The time now is 04:49 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration