LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 11-13-2003, 07:42 PM   #1
SuperNoob
LQ Newbie
 
Registered: Nov 2003
Distribution: Slackware 9.1
Posts: 5

Rep: Reputation: 0
Linux 2.6 and Alsa question via82xx


Ok, I have a couple of questions. Please help if you can answer even one:
Here is my setup:
1)Installed Slackware 9.1 (Full Install)
2)Login as root
3)startx (started up kde) = my sound worked here without making any changes
4)Downloaded linux 2.6.0-test9 kernel and extracted to /usr/src/
5) ran ln -s /usr/src/linux-2.6.0-test9 /usr/src/linux (so it points to new kernel)
6) make mrproper
7) make xconfig (Under Sound, I used defaults snd=y,alsa=y,oss api emulation=y ,mixer=y,pcm=y, changed intel=n and via82xx=y) I compiled everything into the kernel. Saved and quit.
8) make clean
9) make modules (Do I need to run these 2 lines???)
10) make modules_install (I compiled everything into the kernel)
11) make bzImage and put it in lilo to boot

When I reboot, I get:
via82xx: Assuming DXS channels with 48k fixed sample rate.
Please try dxs_support=1 option and report if it works on your machine.
and also:
FATAL: Module snd_pcm_oss not found.
FATAL: Module snd_mixer_oss not found.

I run alsamixer and unmute, then 'alsactl store' and startx(kde):

MAIN PROBLEM: I get sound static when it plays kde intro or and music.
I have heard that if you change dxs_support=1, 2 , or 3 you can fix this problem.
Where the heck do I change this dxs_support option??? (I have tried adding 'option snd-via82xx index=0 dxs_support=2' to my /etc/modules.conf) How can I add that option if I compiled everything into my kernel. Does the modules.conf even do anything when everything is compiled into the kernel? Also, I heard if I am using Slackware, then i need to put it in /etc/rc.d/rc.modules, but the only thing in there is commented out OSS stuff.

Where can I get the snd_pcm_oss and snd_mixer_oss modules from. Do I have to compile the ALSA 0.9.8 driver,lib,utils BEFORE I compile my kernel.
If I want to use the newer ALSA 0.9.8 driver,lib,utils. Do I compile with Sound Support=Y or M, and then do I put ALSA=n and OSS=n. Or Do I also want ALSA=Y or M with OSS emulation, pcm,mixer,sequencer=Y or M. Then do I put via82xx=Y, N, or M. I guess my question is, What should my config look like if I want soundcore module loaded and be able to use ALSA 0.9.8 dirvers, lib, utils??

Thanks in Advance... ( I have honestly spent many hours searching the net and trying to figure this out on my own, but I NEED HELP BAD)
 
Old 11-14-2003, 09:00 PM   #2
SuperNoob
LQ Newbie
 
Registered: Nov 2003
Distribution: Slackware 9.1
Posts: 5

Original Poster
Rep: Reputation: 0
Ok,
I Have managed to fix the dxs_support problem.
I manually editted the /usr/src/linux-2.6.0-test9/kernel/sound/pci/via82xx.c file and changed it. Here are the results:

DXS_SUPPORT=48K(Default). This gives loud static half of the time.

DXS_SUPPORT=ENABLED. This gives crappy sound quality, but everything plays and doesn't freeze.

DXS_SUPPORT=DISABLED. This gives great sound quality, but .mp3s only play on Kaboodle and Noatun right away. If I start XMMS, it freezes for about 30-60 secs and then starts playing fine. (Maybe this is a OSS vs. ALSA problem?? Does XMMS use ALSA or OSS? How about Kaboodle or Noatun??

I assume DXS_SUPPORT=AUTO would just enable 48K. Correct??

I am still having major trouble finding out how to get rid of the 2 errors for OSS Emulation: (I don't know if this has anything even to do with the above dxs_support thing?)

FATAL: module snd-pcm-oss not found
FATAL: module snd-mixer-oss not found
 
Old 11-15-2003, 11:59 AM   #3
SuperNoob
LQ Newbie
 
Registered: Nov 2003
Distribution: Slackware 9.1
Posts: 5

Original Poster
Rep: Reputation: 0
Another update:
I finally got it to load the snd_pcm_oss and snd_mixer_oss modules:
I selected everything to compile into kernel EXCEPT under OSS API Emulation I had the pcm and mixer set to compile as modules.

However, that had no effect on the dxs_support settings.

I reinstalled slack 9.1 and I am using the 2.4.22 kernel and alsa(which is used by default w/ slack 9.1?). I also figured out why my modules.conf file wasn't being read. It was because of hotplug. I added the via82xx stuff to my modules.conf and booted up with the nohotplug boot parameter. I changed between all 4 dxs_support option and it does the same thing.

How do I just disable ALSA altogether and use only OSS? Do I do it through modules.conf or do I have to recompile the kernel?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Alsa via82xx - master volume has no effect (dxs 1 does work) crispibits Linux - Software 3 01-11-2007 11:50 AM
Alsa with via82xx problem closeman Linux - Hardware 5 11-21-2005 08:44 AM
via82xx no sound Stamp Slackware 2 09-26-2004 03:02 PM
VIA82xx SPDIF goinup Red Hat 1 11-19-2003 08:33 AM
Need Help with snd-via82xx jswmcse Linux - Hardware 2 11-11-2003 01:13 PM


All times are GMT -5. The time now is 11:53 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration