LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-06-2003, 03:56 PM   #1
charlie123
Member
 
Registered: Jan 2003
Location: S.E. England
Distribution: Redhat 8.0
Posts: 64

Rep: Reputation: 15
LILO / XP dual boot problems


hi,

im probably just being stupid, but when i boot my computer up i dont get any option of booting into linux, it just goes straight into windows xp.

i have redhat 8 and i setup LILO in the installation process. Do i have to press a key during boot or should a screen come up?

Many thanks,

Charlie
 
Old 01-06-2003, 04:36 PM   #2
yngwin
Member
 
Registered: Dec 2002
Location: China
Distribution: Arch
Posts: 359

Rep: Reputation: 33
Where did you install lilo? In the mbr or on the linux partition? If it's on the linux partition you need to make that partition bootable with cfdisk or fdisk, whatever is on the cd. I suppose you can use the RH cd as a rescue boot cd too? Check the manual (it's online on the RH site), you can probably boot using the cd and then you have to add an option at the boot-prompt, something like linux root=/dev/hda3 or whatever your linux partition is. Then when you're in linux, check your /etc/lilo.conf and run lilo. Then you should have a screen come up at next boot with options for booting either linux or windows (depends on what exactly is in /etc/lilo.conf).
 
Old 01-06-2003, 04:41 PM   #3
deesto
Member
 
Registered: May 2002
Location: NY, USA
Distribution: FreeBSD, Fedora, RHEL, Ubuntu; OS X, Win; have used Slackware, Mandrake, SuSE, Xandros
Posts: 448

Rep: Reputation: 31
You should install LILO to the root of the primary partition, not to the MBR. If you created a boot/rescue disk during Red Hat installation, use that to boot with, and then once in Red Hat, verify your lilo.conf is the way you want it, and run lilo (or /sbin/lilo to "install" the LILO configuration.
Also, make sure your 'timeout' value in lilo.conf is greater than zero, as '0' will skip directly to your default OS on boot, without a menu.
 
Old 01-06-2003, 06:33 PM   #4
charlie123
Member
 
Registered: Jan 2003
Location: S.E. England
Distribution: Redhat 8.0
Posts: 64

Original Poster
Rep: Reputation: 15
hi,
here is a copy of my lilo.conf file:

***********8
prompt
timeout=50
default=DOS
boot=/dev/hda
map=/boot/map
install=/boot/boot.b
restricted
password= <snip>
message=/boot/message
linear

image = /boot/vmlinuz-2.4.18-14
label=linux
root=/dev/hda3
initrd=/boot/initrd-2.4.18-14.img
read-only
append="hdd=ide-scsi root=LABEL=/"

other=/dev/hda1
optional
label=DOS
table=/dev/hda

**********************

i added the bottom line, table=....., and the root=/dev/hda3 bit cos it was in my book, but it didnt change anything.

also, when i run lilo, i get this output

******************
Reading boot sector from /dev/hda
Merging with /boot/boot.b
Warning: device 0x0302 exceeds 1024 cylinder limit
Fatal: sector 78159371 too large for linear mode (try 'lba32' instead)

*******************

i have yet to try lba32, hmm might be worth trying, ill try that tomorrow.

i installed lilo to the MBR, how do i install it to the root of the primary partition?


thanks for the replies,

Charlie
 
Old 01-06-2003, 07:15 PM   #5
jetfreggel
Member
 
Registered: May 2002
Posts: 172

Rep: Reputation: 30
you have to make your primary partitions less then 1024
cylinders of the hd
 
Old 01-06-2003, 10:23 PM   #6
deadbug
Member
 
Registered: Oct 2002
Location: San Antonio, Texas
Distribution: MDK 8.0, 9.0; RH 7.2, 8.0, 9.0, FC3, FC4, FC5
Posts: 355

Rep: Reputation: 30
Check your BIOS and make sure LBA is enabled (should be on the same line that lists the hard drive's specs). A computer capable of running XP probably was made after 1997. Most BIOS since then do not have the 1024 restriction.
 
Old 01-07-2003, 05:32 AM   #7
ethanchic
Member
 
Registered: May 2002
Location: CDO, Ph
Distribution: slackware 9.0, LFS-3.3, mandrake 9.2
Posts: 65

Rep: Reputation: 15
You should install XP first after RH so that it wont override your MBR, so that RH should be the dominant MBR.
 
Old 01-07-2003, 09:13 AM   #8
deesto
Member
 
Registered: May 2002
Location: NY, USA
Distribution: FreeBSD, Fedora, RHEL, Ubuntu; OS X, Win; have used Slackware, Mandrake, SuSE, Xandros
Posts: 448

Rep: Reputation: 31
Quote:
Originally posted by ethanchic
You should install XP first after RH so that it wont override your MBR, so that RH should be the dominant MBR.
Sorry to point this out, but this statement is a bit confusing. Do you mean the user should install XP first, then Red Hat? If so, I agree, as that's what I've seen written hundreds of times, and it's worked in my experience. Also, if the BIOS is not restricted by the 1024 boundary, it's usually best to install the boot loader to the primary partition, not to MBR.
 
Old 01-07-2003, 01:33 PM   #9
charlie123
Member
 
Registered: Jan 2003
Location: S.E. England
Distribution: Redhat 8.0
Posts: 64

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by deesto
it's usually best to install the boot loader to the primary partition, not to MBR.
thnaks for replies, how do i do this?

cheers,

Charlie
 
Old 01-07-2003, 03:12 PM   #10
deesto
Member
 
Registered: May 2002
Location: NY, USA
Distribution: FreeBSD, Fedora, RHEL, Ubuntu; OS X, Win; have used Slackware, Mandrake, SuSE, Xandros
Posts: 448

Rep: Reputation: 31
The 'boot' line in lilo.conf tells the system from where to boot; this is where LILO is installed. So in your configuration above, it's /dev/hda, which is the first available drive on your system. This is may or may not be good, as that appears to be your DOS (Windows) drive, but you need to verify that the drive is indeed bootable.
Here's a quote straight from the LILO Mini-HOWTO:
Quote:
If you have another operating system installed in your hard drive, you'd better install Lilo to the root partition instead of the MBR. In this case, you must mark the partition as ``bootable'' using the ``a'' command of fdisk or the ``b'' command of cfdisk. If you don't overwrite the master boot sector you'll find it easier to uninstall Linux and Lilo if needed.
Check out the Mini-HOWTO for more info, specifically this page:
http://www.linux.org/docs/ldp/howto/mini/LILO-2.html
 
Old 01-07-2003, 06:30 PM   #11
charlie123
Member
 
Registered: Jan 2003
Location: S.E. England
Distribution: Redhat 8.0
Posts: 64

Original Poster
Rep: Reputation: 15
thanks for the help guys, replacing "linear" with "lba32" (as suggested by the error message originally, silly me) worked. i think it is probably best if i leave it be now as it seems to be functioning fine.

anyway thanks for the rapid and informative (and newbie friendly) replies.

Charlie
 
Old 01-13-2003, 12:45 PM   #12
mervinoh
LQ Newbie
 
Registered: Jan 2003
Distribution: Mandrake v9
Posts: 5

Rep: Reputation: 0
I have just done the same thing - install Mandrake Linux v9 with Win XP.
I have Win XP running, it is easier to install Win XP first.
Then I install Linux on a different partitiion.

refer to http://www.littlewhitedog.com/reviews_other_00011.asp for specific instructions
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Dual boot, Lilo and Western Digital software problems Fritz_Monroe Linux - Newbie 10 06-01-2005 05:41 PM
LILO Problems With Mandrake 8.1 and Win2K Dual Boot glenn_roth Linux - General 6 03-18-2005 01:47 AM
Need dual boot help...LILO..Winxp wont boot Scrag Linux - Hardware 2 09-01-2004 01:26 AM
Lilo lost, Install disk failing to restore Lilo on dual boot? Dobie Linux - Newbie 2 05-05-2004 06:00 PM
LILO problems: Mandrake XP dual-boot with SCSI/IDE venky Linux - General 1 03-30-2003 08:30 AM


All times are GMT -5. The time now is 12:18 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration